RT2500 and debian "lenny" testing

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4345

Nazcafan

08-10-2007 09:19:31

Hi, 2.6.22 reached testing status on debian so I had to recompile rt2500 legacy for this new kernel.

Some remarks the debian howto method can not be applied since -rt2500-source (either from testing or unstable) won't compile on rt2500.
-the beta won't compile either so if you want it to work, you need the cvs version, this perfectly compiles

-I had some trouble using this CVS version. I use dhcp at boot on a wep lan and everything was set on my /etc/interfaces

[code32k2t81c]
auto ra0
iface ra0 inet dhcp
wireless-essid MyESSID
wireless-key 12345678
wireless-channel 9
wireless-ap blah:blah:blah
[/code32k2t81c]

But this would not work anymore on the cvs version of rt2500 (dhclient found no response and post boot iwconfig showed no association). Hopefully, spy2x00 (Romain) gave me hand on that one and the driver proved to work when passing the essid AND the AP manually to iwconfig. However, that did not explain why it would not work with the interfaces file ... We tested some post-up settings until I remember I had run into some similar issue but with a rt61 card like a year ago. I decided to try the same thing that had worked with rt61

[code32k2t81c]
auto ra0
iface ra0 inet dhcp
pre-up ifconfig ra0 up
wireless-essid MyESSID
wireless-key 12345678
wireless-channel 9
wireless-ap blah:blah:blah
[/code32k2t81c]

And it seems to work perfectly now!
some questions remain
[list32k2t81c]why the AP seems to have become compulsory (I need to check that again, actually but It seems so) whereas as far as I remember the essid was enough to make it associate?
Why did this pre-up thing is now needed and what does it actually perform? (Spy says he does not need it but he runs a static connection, instead of dhcp ...)[/listu32k2t81c]

Anyway, I am glad I could get my connection back so those questions are not that important, it is just that I am very curious and I like to have an in-depth understanding of what I am doing.

greetings, and long life to you coders!

Guyou

03-11-2007 22:13:52

Please, for my better understanding, could you indicate how we can decide wifi association is done or not.

Personnally, I'm trying to bring-up a WPA connection with DHCP. I saw that DHCP stage failed, but how to decided if WPA association (and secured hand-chek) is successfully done ?

Spy84464

04-11-2007 15:17:26

Hello,
You can check association from "iwconfig" output. Just run "iwconfig ra0", and if your access point mac address appears in there, then association succeeded.

Regards,
Romain

Guyou

04-11-2007 16:54:54

You can check association from "iwconfig" output. Just run "iwconfig ra0", and if your access point mac address appears in there, then association succeeded.
[/quote1kkjakab]

OK, great thanks.

And concerning WPA mode, I suppose that association is not enough to decide hand-check is correct. How can we decide if WPA settings are correct and, if not, whose are incorrect, whose are correct?

Spy84464

10-11-2007 10:13:42

There is no easy way to do so, I guess your only chance is to compile the driver with debug enabled and look at the log.

jdurand

16-02-2008 15:11:15

why the AP seems to have become compulsory (I need to check that again, actually but It seems so) whereas as far as I remember the essid was enough to make it associate?[/quote3pym66zs]
Using the cvs version 2008021602 on 2.6.24, I confirm that I had to add
- ifconfig ra0 up
- iwconfig ra0 ap abcdef
to get associated.
That was not the case with a cvs version as of some months ago (can't be more precise).
The iwconfig channel config is not necessary for me.

My working config on debian/lenny is now
[code3pym66zs]auto ra0
iface ra0 inet dhcp
pre-up ifconfig ra0 up
pre-up iwconfig ra0 essid x
pre-up iwconfig ra0 key restricted y
pre-up iwconfig ra0 ap a:b:c:d:e:f
[/code3pym66zs]
Please find attached a failed session when the config did not have the ifconfig nor the iwconfig ap. There was only a setting of essid and key. The mode was managed by default and this is the correct mode.