FC8 Trouble

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4508

dnbwise

18-12-2007 04:12:45

I installed FC8 and my card (WMP54G) was recognized and assigned an ip address. However, the speeds were extremely SLOW. So, after failing to find any solution, I decided to install the rt2500 drivers from this site, as I did with FC7. Everything went well by following this guys tutorial[/url3dccqhg5], and I was happy. However, after updating and restarting, it reverted back to its ways of slowness - I suppose it loaded the original kernel module? So, I'm trying to make the changes permanent once I install the driver correctly, even after updating the kernel and such. Any help with this would be greatly appreciated.

Spy84464

22-12-2007 10:58:10

Hello,
Post the output of "lsmod", so we can see which driver is being used.

Regards,
Romain

dnbwise

22-12-2007 11:22:17

Thanks for the reply, here is the the output

(kernel 2.6.32.1-42.fc8)

Module Size Used by
rt2500 156388 1

Spy84464

22-12-2007 11:50:19

It looks good, the interface is called "ra0", right? Are you far from the AP? Is the network heavily loaded?

dnbwise

22-12-2007 12:22:23

Actually that was the output for the previous kernel, which is what I have been working from since the updated kernel screws it up. The output of lsmod in the newer kernel is as follows

(kernel 2.6.32.8-63.fc8)

Module Size Used by
rt2500pci 156388 1

I know this probably appears ok as well, however, until I uninstalled the rt2500pci module which came with FC8, and installed the one from the "CVS hourly" things weren't working. Btw, the card is called "wlan0" not "ra0". As far as network traffic and such, there is no apparent differences.

Spy84464

23-12-2007 21:05:59

This is the problem I suspected. rt2x00 is being used, not the legacy driver, notice rt2500[b34qohtk3]pci[/b34qohtk3]. Unload that module, then load "rt2500" (no pci), and you should be fine. To prevent rt2x00 from being loaded, you can blacklist it, or simply remove it.

ivnmad

06-01-2008 20:13:27

I am having two different problems with my Gigabyte card (based on RT2500) on Fedora 8

1. The card is detected, connects to the network fine, but the Bit Rate is set to 1Mb/s, if the connection setting is Rate=Auto, and the connection is very slow.
I need to change that manually, by using iwconfig, to 54Mb/s to get normal speed.
Even if I set the speed connection to Rate=54M in the config file, the connection is still set to 1Mb/s when the computer starts and I still need to change that manually to get my normal speed. A bug has been filed on Fedora bugzilla.
I tried to install your firmware instead of the one from Fedora and at that point I cannot even change the speed manually. It is stuck to 1Mb/s.

2. The power led is on, but the link led does not "work".
It goes on for a split of a second and then goes off when the card is activated.
This is not a big deal, but I wanted you to know about it.
I filed another bug on Fedora bugzilla for this.

Have you got any suggestions?

The Fedora kernel is -99.f8
I am attaching the output from lsmod.

Thanks,

Ivan

Vern

06-01-2008 21:18:37

Your lsmod output shows you have rt2500pci, not rt500, loaded.

ivnmad

07-01-2008 20:33:28

That is correct... Where is the problem?
Why should I load RT500 when I need RT2500pci?

Ivan

IvD

07-01-2008 21:38:15

I am aware of the link quality problems of rt2500pci in FC8, I have already send several patches upstream that should help. I understood the next experimental kernel of FC will contain those patches.

More patches that should help are on the way, so hopefully it will be ready soon so this issue will be resolved. )

ivnmad

08-01-2008 20:35:32

Hi Ivo,

That is good news, thank you..

The bad news is that I have just installed Kernel 2.6.23.12-101.fc8 and now I cannot even modify the speed by using iwconfig. It is stuck at 1 Mb/s.
If I start my computer using Kernel 2.6.23.12-99.fc8 then I can still modify the speed manually with "sudo iwconfig wlan1 rate 54M"

I am adding this information to the bug on Fedora.

Regards,

Ivan

ivnmad

10-01-2008 20:53:00

I just want you to know I have just installed kernel-2.6.23.13-104.fc8 and the speed is now adjusted automatically depending on the quality of the signal (with rate set to auto, of course).

Still experiencing the problem with the link led not working, but that is a minor issue.

Thank you,

Ivan

IvD

10-01-2008 20:54:39

Good to hear it is working. )
I'm still looking into the LED handling.