rt2500 on Debian Lenny 2.6.24-1

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4850

darrenyeats

12-06-2008 18:03:22

I ran 2.6.18 (with etch) previously and had built the rt2500 module there and it was fine.

I haven't managed to get the rt2x00 module in the 2.6.24 kernel (lenny) to work. (Do I need some firmware to get this to work?; does it work anyway? - I read elsewhere on the board there are some patches missing; come to think of it do I need to [b19krl0wp]blacklist[/b19krl0wp] rt2500 further to removing from /etc/modules?) So, anyway, I've tried the legacy rt2500 again.

So...under 2.6.24-1 (lenny) I have tried to use the 2500-source modules again with module-assistant auto-install. It builds and installs fine, rt2500 is in /etc/modules. As indicated elsewhere I added rt2500pci to /etc/modprobe.d/blacklist.

However, the PCMCIA card doesn't work 2.6.24-1. If I boot into 2.6.18 it works like it did before. Do I need to blacklist some more modules or is there some other problem preventing rt2500 running under 2.6.24-1?

Many thanks,
Darren

Vern

13-06-2008 20:20:11

Hi darrenyeats,

Could you be more specific about "doesn't work"? What exactly did you expect that did not happen, or what exactly happened that you did not expect?

Thanks,

darrenyeats

13-06-2008 21:51:38

Doesn't work = when using 'ifup eth1' the lights on the card don't come on and although a MAC address comes up it doesn't find the DHCP server, keeps searching forever.

HTH, Darren

Vern

14-06-2008 01:14:04

Hi darrenyeats,

When you do "make module" under 2.6 kernels, the default is to install an alias for ra0 in /etc/modprobe.d/ralink. /etc/modules is not changed. So it looks like there may be some distro- specific stuff going on.

What is the result of "ifconfig eth1" and "iwconfig eth1"?

Thanks,