Problems to get my RT2500 WiFi card to connect during boot

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4983

RomMon

07-09-2008 21:02:10

I’m currently having problems to get my RT2500 chip based WiFi card to connect during startup to my new Wireless ADSL router.
I use this laptop and wifi-card already for a long time (about two years) where I boot into init3 and the wifi card will normally connect to my old wifi-AP from boot-up.

The system was originally configured using “Configuration Utility – RT2500 version 1.2.1.0” RaConfig2500 (part of rt2500-1.1.0-b4) as far as I can remember.

I can connect manually using “Configuration Utility – RT2500 version 1.2.1.0” RaConfig2500 (part of rt2500-1.1.0-b4) to the new Wireless ADSL router.
But it will not connect to it at startup.

I also tried RutilT (http//cbbk.free.fr/bonrom/), but same thing. I can connect manually but it will not do so at startup.

Can RaConfig2500 change the files needed to connect at startup?
Which config files should be modified to automatically connect at startup to the new AP?

Distribution Slackware-12.0
Driver http//rt2x00.serialmonkey.com/rt2500-cvs-daily.tar.gz


Followed the info in the following threads
viewtopic.php?f=4&t=4875 NA
viewtopic.php?f=9&t=4957 –e sounds ok
viewtopic.php?f=9&t=4500 tried rutilt ra0 –e –p home Q. Where can I find profile “home”? /root/.config/rutilt/
created home with GUI exit is rutilt ra0 –v –p home –e >> Does not work
viewtopic.php?f=8&t=4919 different distro

Some static config
[codebinwzmo0]root@slackware:/etc/udev/rules.d# cat 75-network-devices.rules
# Local network rules to name your network cards.
#
# These rules were generated by nethelper.sh, but you can
# customize them.
#
# You may edit them as needed.
# (If, for example, your machine has more than one network
# card and you need to be sure they will always be given
# the same name, like eth0, based on the MAC address)
#
# If you delete this file, /lib/udev/nethelper.sh will try to
# generate it again the next time udev is started.

KERNEL=="ra?", ATTR{address}=="00:50:18:32:4c:df", NAME="ra0"
root@slackware:/etc/udev/rules.d#

root@slackware:/etc/udev/rules.d# cat /etc/modprobe.conf
# /etc/modprobe.conf (old location for Linux 2.6+ config)
#
# The use of this config file is deprecated.
# Instead, create files in the /etc/modprobe.d/ directory
# containing modprobe options.
#
# For more information, see "man modprobe.conf".
alias ra0 rt2500
root@slackware:/etc/udev/rules.d#[/codebinwzmo0]

Info after connected to the new WiFi AP
[codebinwzmo0]root@slackware:/etc/Wireless/RT2500STA# ifconfig -a
dummy0 Link encap:Ethernet HWaddr FE:E7:A9:C0:E0:58
BROADCAST NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

ra0 Link encap:Ethernet HWaddr 00:50:18:32:4C:DF
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::250:18ff:fe32:4cdf/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:105531 errors:0 dropped:0 overruns:0 frame:0
TX packets:62495 errors:138 dropped:138 overruns:0 carrier:0
collisions:2050 txqueuelen:1000
RX bytes:148746828 (141.8 MiB) TX bytes:6055973 (5.7 MiB)
Interrupt:11 Base address:0x4000



root@slackware:/etc/Wireless/RT2500STA# iwconfig
lo no wireless extensions.

dummy0 no wireless extensions.

ra0 RT2500 Wireless ESSID:"Scenic2" Nickname:"slackware"
Mode:Managed Frequency=2.462 GHz Access Point: 00:1E:8C:47:A4:ED
Bit Rate=54 Mb/s Tx-Power:-3 dBm
RTS thr=2312 B Fragment thr=2312 B
Encryption key:xxx-xxxx-xx Security mode:restricted
Link Quality=68/100 Signal level:-35 dBm Noise level:-80 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

root@slackware:/etc/Wireless/RT2500STA#

root@slackware:/etc/Wireless/RT2500STA# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=3.29 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1.18 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=1.19 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=1.48 ms

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 1.184/1.789/3.296/0.878 ms
root@slackware:/etc/Wireless/RT2500STA#



root@slackware:/etc/Wireless/RT2500STA# lsmod |grep 2500
rt2500 153184 1
root@slackware:/etc/Wireless/RT2500STA#


Sep 3 17:27:19 slackware dhcpcd[3502]: timed out waiting for a valid DHCP server response
Sep 3 17:27:19 slackware kernel: ndas: network down. Unregistering ra0
Sep 3 17:27:27 slackware kernel: PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
Sep 3 17:27:27 slackware kernel: ndas: network up. Registering ra0
Sep 3 17:27:59 slackware dhcpcd[3566]: timed out waiting for a valid DHCP server response
Sep 3 17:27:59 slackware dhcpcd[3545]: recvfrom: Network is down
Sep 3 17:27:59 slackware kernel: ndas: network down. Unregistering ra0
Sep 3 17:30:34 slackware kernel: ndas: network up. Registering ra0
Sep 3 18:24:30 slackware dhcpcd[3626]: DHCP_NAK server response received
Sep 3 18:24:30 slackware kernel: ndas: network down. Unregistering ra0
Sep 3 18:24:30 slackware kernel: ndas: network up. Registering ra0[/codebinwzmo0]

Hope someone can help to be able to connect automatically at bootup again.



Edit (8-9-2008)
I used a spare hard disk and re-installed Slack-12.0

After installation I only changed/etc/rc.d/rc.inet1.conf
IFNAME[4]="ra0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"

/etc/modprobe.conf
alias ra0 rt2500

And again, if I use the GUI I can manually connect. But before this I have to use
rmmod rt2500
modprobe rt2500
(or reseat the card)
And use the GUI immediately.
This is the same as with the original hard disk

Spy84464

09-09-2008 18:54:47

Hello,
Your distro should provide some facility to configure the card on boot, I don't know Slackware, so can't help directly, there must be some relevant document somewhere.
I can help with RutilT though, you basically need to have that command executed from a startup script "rutilt ra0 -dep home".
Where "home" is the name of your profile, run RutilT as root to create it, and have it recorded in /root/.config/rutilt.
Which version of the driver are you using by the way? We recommend using the latest CVS tarball, beta4 is badly outdated.

Regards,
Romain

RomMon

09-09-2008 22:05:44

Romain,

Thanks for your reply.

I tried both "rutilt ra0 -dep home" and "rutilt ra0 -e -dep home" and the results are almost the same (only the interval changes each time)
[code2daroqq2]# rutilt ra0 -e -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
Trying recorded lease 192.168.1.10
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

No working leases in persistent database - sleeping.
root@slackware:/#[/code2daroqq2]

If I startx and use the GUI RutilT I can connect very easy.

My Profile
[code2daroqq2]root@slackware:~/.config/rutilt# cat RutilT_profiles.xml
<?xml version="1.0" encoding="UTF-8"?>
<Rutilt_Profiles>
<Profile Name="home">
<SSID>Scenic2</SSID>
<Mode>2</Mode>
<Channel>11</Channel>
<Encryption>
<Type>1</Type>
<Key>xxxxxxxxx</Key>
<Key></Key>
<Key></Key>
<Key></Key>
<AuthenticationType>1</AuthenticationType>
<DefaultKey>0</DefaultKey>
</Encryption>
<IPSettings>
<How>1</How>
</IPSettings>
</Profile>
</Rutilt_Profiles>
root@slackware:~/.config/rutilt#[/code2daroqq2]

Yesterday used the spare hard disk and powerd up my old WiFI access point, and after using RaConfig2500 it would connect at startup again.
I rebooted 3-4 times and each time it would connect at startup. But it won't do that with the new WiFi AP.

Spy84464

10-09-2008 19:02:21

So it works when applying the profile through the GUI and not the command line?

RomMon

10-09-2008 20:35:38

So it works when applying the profile through the GUI and not the command line?[/quote1kzv5qa3]

Correct, I can only connect with the GUI.

Edit1 (11-09-2008)
The new WiFi ADSL Modem that I recieved from my ISP is a Davolink DV2020.
And someone mentioned that this box only supports 802.11G (54Mbit/s) so it doesn't support 802.11B (11Mbit/s).

Spy84464

11-09-2008 18:53:19

This is weird, as the same code is run underneath. If, after applying a profile though the command line, you manually run dhclient, does that help? Remove the "-d" option for that test. It might be that dhclient is run too soon after configuring the card, and association is not yet established.

RomMon

11-09-2008 20:48:22

It tried "rutilt ra0 -e -dep home" (with and without -e) and afterwards "dhcpcd ra0", but no improvement.

What worries me is that if I power-up my old WiFI-AP and reboot my PC it is connecting at bootup again.
How can I make sure the RaConfig2500 configuration results are not interfering?

If I use "rutilt ra0 -e -dep home" it will disconnect from my old WiFi-AP but wont connect to the new WiFi-AP.

Spy84464

15-09-2008 18:48:47

RaConfig2500 uses a file located in "/etc/Wireless". Moving away that directory should prevent any interference.
"-e -dep" is the same with or without "-e", as the "e" option is already inside "dep", -dep is equivalent to "-d -e -p". ;)
Maybe you could try that succession of commands
[codeim0yjjy4]rutilt ra0 -e -dep home
sleep 5
rutilt ra0 -e -dep home[/codeim0yjjy4]
I know this is weird, but I'm as puzzled as you, especially if that works for one AP and not the other.

RomMon

15-09-2008 20:23:27

Romain,

No change...here the output

[code3vvm0o4m]root@slackware:/tmp# cat 16-sep-08-rt2500
rutilt ra0 -dep home
sleep 5
rutilt ra0 -dep home
root@slackware:/tmp# rutilt ra0 -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
root@slackware:/tmp# sleep 5

rtium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.[/code3vvm0o4m]

Here the steps I take to get connected via the GUI
(home = the profile, Scenic2 = new AP)
After this I started X-Windows (with startx) and started the RutilT GUI.
If I try to connect to my AP via "Profiles" > Select "home" > "Apply" it doesn't work.
Only if I select "Site survey" > from the list of AP's dubble click "Scenic2" > in new window select profile "home" and press "OK" it will connect.

Here the output while the rt2500 is already connected to the new-AP
[code3vvm0o4m]root@slackware:/tmp# cat 16-sep-08-rt2500
rutilt ra0 -dep home
sleep 5
rutilt ra0 -dep home
root@slackware:/tmp# rutilt ra0 -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.7 -- renewal in 42263 seconds.
root@slackware:/tmp# sleep 5
root@slackware:/tmp# rutilt ra0 -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.7 -- renewal in 40541 seconds.[/code3vvm0o4m]

Spy84464

16-09-2008 18:09:17

Ok, there is a little difference between applying a profile directly, and through the site survey tab. In that last case, an additional command is issued, equivalent to "iwconfig wlan0 ap XXXXXXXXXXXX", where XXXX... is your ap mac address. If you run that command after applying a profile, does that help? That could be what we're missing, the driver should be able to do without, but you never know with the legacies.

RomMon

16-09-2008 21:44:58

Yes. your the man..

I first have to use the "iwconfig ra0 ap 001E8C47A4ED" command and than the "rutilt ra0 -dep home" command.

[code3bmqxjqb]root@slackware:/tmp# lsmod |grep rt2500
rt2500 180064 1
root@slackware:/tmp# rutilt ra0 -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
Trying recorded lease 192.168.1.7
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

No working leases in persistent database - sleeping.
root@slackware:/tmp# iwconfig ra0 ap 00:1E:8C:47:A4:ED
root@slackware:/tmp# lsmod |grep rt2500
rt2500 180064 0[/code3bmqxjqb]During this the "rutilt ra0 -dep home" command takes about a full minute.


But if I use them in the reverse order
[code3bmqxjqb]root@slackware:/tmp# lsmod |grep rt2500
rt2500 180064 1
root@slackware:/tmp# iwconfig ra0 ap 00:1E:8C:47:A4:ED <--- at this point the two LED's on the card go on.
root@slackware:/tmp# rutilt ra0 -dep home
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.7 -- renewal in 41483 seconds.
root@slackware:/tmp#[/code3bmqxjqb]Now it also takes about 5 seconds.


And it is also working if I boot the system
[code3bmqxjqb]:
:
:
Using /etc/random-seed to initialize /dev/urandom.
INIT: Entering runlevel: 3
Going multiuser...
Updating shared library links: /sbin/ldconfig &
Starting PCMCIA services:
<PCIC already loaded>
Starting sysklogd daemons: /usr/sbin/syslogd /usr/sbin/klogd -c 3 -x
Updating X font indexes: /usr/bin/fc-cache -f &
Triggering udev events: /sbin/udevtrigger --retry-failed
Starting Internet super-server daemon: /usr/sbin/inetd
Starting OpenSSH SSH daemon: /usr/sbin/sshd
Starting ACPI daemon: /usr/sbin/acpid
Starting system message bus: /usr/bin/dbus-uuidgen --ensure ; /usr/bin/dbus-daemon --system
Starting HAL daemon: /usr/sbin/hald --daemon=yes
Loading ALSA kernel modules.
Loading ALSA mixer settings: /usr/sbin/alsactl restore
Loading OSS compatibility modules for ALSA.
Starting gpm: /usr/sbin/gpm -m /dev/mouse -t exps2
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:50:18:32:4c:df
Sending on LPF/ra0/00:50:18:32:4c:df
Sending on Socket/fallback
DHCPREQUEST on ra0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.7 -- renewal in 38438 seconds.


Welcome to Linux 2.6.21.5-smp (tty1)

slackware login: root
Password:
Linux 2.6.21.5-smp.
Last login: Tue Sep 16 23:24:44 +0200 2008 on pts/0 from 192.168.1.8.
You have mail.

The important thing is not to stop questioning.

root@slackware:~#[/code3bmqxjqb]

This is how my /etc/rc.d/rc.local file looks now
[code3bmqxjqb]root@slackware:/tmp# cat /etc/rc.d/rc.local
#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local startup commands in here. Also, if you have
# anything that needs to be run at shutdown time you can
# make an /etc/rc.d/rc.local_shutdown script and put those
# commands in there.
iwconfig ra0 ap 00:1E:8C:47:A4:ED
rutilt ra0 -dep home
root@slackware:/tmp#[/code3bmqxjqb]

Thanks a lot Romain.

I'm really happy with this.

If I find the time tomorrow I will try the same with my original hard-disk, but I expect the same results.

RomMon

18-09-2008 20:26:30

Yes, also on my original hard-disk it is working now.

Only thing I had to change was to comment out the folllowing lines in /etc/rc.d/rc.inet1.conf (make it original again)
IFNAME[4]="ra0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
These lines caused the bootup to wait for one minute or so for dhcpcd to unsuccessfully finish.

Thanks again.

Spy84464

18-09-2008 21:24:44

Good to hear everything is sorted out now ).