problems whit scan in rt2500

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5216

edaah24

27-02-2009 03:08:49

hello

i have a rt2560f chipset based card, it works good under kernel 2.6.18-6 ( debian etch ) whith driver rt2500-1.1.0-b4.

i upgrade to kernel 2.6.26 ( debian lenny ), the default driver dont work, i download the lastest version from this site, and install it.

after modprobe rt2500
and ifconfig ra0 up

the new driver don,t scan

iwlist ra0 scan

dont find any
los sineto pero mi ingles es bastante malo

descargue la ultima version del driver, la compile y la instale si problemas, despues de cargar el modulo, el driver no me encunertra ninguna red inlambrica

Spy84464

28-02-2009 18:52:51

Hello,
can you translate the error "iwlist" returns?

Regards,
Romain

Vern

28-02-2009 20:36:45

Hi edaah24,

Como dice Romain, que son los mensajes que aparecen despues de mandar "iwlist ra0 scan" (mismo sin traducion sera bien (tal vez!))?

Thanks,

edaah24

28-02-2009 21:55:24

with old driver


root@localhost/home/darwin# modprobe rt2500
root@localhost/home/darwin# dmesg | tail
NET Registered protocol family 4
NET Registered protocol family 3
NET Registered protocol family 5
rt2500 1.1.0 BETA4 2006/06/18 http//rt2x00.serialmonkey.com
rt2500 EEPROM 1 2 3 4 5 6 7 8 9 10 11 12 13 14 Channel
rt2500 EEPROM 2 2 2 2 2 2 3 3 3 3 3 3 3 3 dBm Maximum
ra0 no IPv6 routers present
root@localhost/home/darwin# ifconfig ra0 up
root@localhost/home/darwin# iwlist ra0 scan
ra0 Scan completed
Cell 01 - Address 00146CD225D2
ModeManaged
ESSID"SHIMATA"
Encryption keyoff
Channel1
Quality50/100 Signal level-93 dBm Noise level51 dBm




with new driver


root@localhost/home/darwin# modprobe rt2500
root@localhost/home/darwin# dmesg | tail
rt2500 EEPROM 2 2 2 2 2 2 3 3 3 3 3 3 3 3 dBm Maximum
ra0 no IPv6 routers present
ACPI PCI interrupt for device 00000109.0 disabled
PCI Enabling device 00000109.0 (0110 -> 0112)
ACPI PCI Interrupt 00000109.0[A] -> Link [LNKB] -> GSI 19 (level, low) -> IRQ 233
rt2500 1.1.0 CVS 2009022815 http//rt2x00.serialmonkey.com
root@localhost/home/darwin# ifconfig ra0 up
root@localhost/home/darwin# iwlist ra0 scan
ra0 No scan results

Vern

02-03-2009 17:10:23

I'll take a look at it as time allows.

Thanks,