Cannot compile rt2570 :(

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4449

Yamigami

18-11-2007 14:56:23

Hello I have tried to compile rt2570 but I got an following error.

[code1hgs7t61]make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-rt'
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_main.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/mlme.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_bulk.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/connect.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/sync.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_init.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtmp_tkip.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/wpa.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtmp_wep.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_info.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/assoc.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/auth.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/auth_rsp.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/md5.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_io.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/sanity.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rtusb_data.o
CC [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rt2x00debug.o
LD [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rt2570.o
Building modules, stage 2.
MODPOST 1 modules
WARNING: "there_is_no_init_MUTEX_LOCKED_for_RT_semaphores" [/home/alper/Desktop/rt2570-cvs-2007111808/Module/rt2570.ko] undefined!
CC /home/alper/Desktop/rt2570-cvs-2007111808/Module/rt2570.mod.o
LD [M] /home/alper/Desktop/rt2570-cvs-2007111808/Module/rt2570.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-rt'
[/code1hgs7t61]

I have UbuntuStudio installed with kernel 2.6.22-14-rt (

Spy84464

18-11-2007 15:48:06

Hello,
Compilation succeeded, have you tried to insert the module despite this warning?

Regards,
Romain

geminjim

01-12-2007 22:21:05

I have a similar problem. Running Ubuntu Studio on an AMD64. The rt2570 module compiles with warning

WARNING "there_is_no_init_MUTEX_LOCKED_for_RT_semaphores" [path-to-module] undefined!

It installs, but when I run 'sudo modprobe rt2570' it returns an error with the same message..

It all works fine with the generic kernel. If you need the specific dmesg line, I will have to reboot to the rt kernel to retrieve that.