F9 + Linksys WUSB54GC - doesn't start automatic after boot

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4836

alex-cross

08-06-2008 13:15:09

Hello,

I've the WLAN-USBStick "Linksys WUSB54GC" and OS is Fedora 9.

After boot the network / my wlan doesn't start automatically.

Only when I restart the network with "service network restart" or "ifup wmaster0" it works fine!

After boot over "dmesg" I see the following
[code7tjoy419]
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: RX authentication from 00:1d:7e:bc:75:55 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1d:7e:bc:75:55
wlan0: RX AssocResp from 00:1d:7e:bc:75:55 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:1d:7e:bc:75:55)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: RX authentication from 00:1d:7e:bc:75:55 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1d:7e:bc:75:55
wlan0: RX AssocResp from 00:1d:7e:bc:75:55 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: RX deauthentication from 00:1d:7e:bc:75:55 (reason=15)
wlan0: deauthenticated
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: RX authentication from 00:1d:7e:bc:75:55 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1d:7e:bc:75:55
wlan0: RX ReassocResp from 00:1d:7e:bc:75:55 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:1d:7e:bc:75:55)
wlan0: no IPv6 routers present
[/code7tjoy419]

when I restart the network with "service network restart" I got the following messages with "dmesg"
[code7tjoy419]
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
wlan0: RX authentication from 00:1d:7e:bc:75:55 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1d:7e:bc:75:55
wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1d:7e:bc:75:55
wlan0: RX authentication from 00:1d:7e:bc:75:55 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1d:7e:bc:75:55
wlan0: authentication frame received from 00:1d:7e:bc:75:55, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1d:7e:bc:75:55, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1d:7e:bc:75:55, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1d:7e:bc:75:55, but not in authenticate state - ignored
wlan0: authentication frame received from 00:1d:7e:bc:75:55, but not in authenticate state - ignored
wlan0: RX AssocResp from 00:1d:7e:bc:75:55 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:1d:7e:bc:75:55)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
[/code7tjoy419]
and after that it works fine!


"modinfo rt2500usb" gives me
[code7tjoy419]
filename: /lib/modules/2.6.25.4-30.fc9.x86_64/kernel/drivers/net/wireless/rt2x00/rt2500usb.ko
license: GPL
description: Ralink RT2500 USB Wireless LAN driver.
version: 2.1.5
author: http://rt2x00.serialmonkey.com
[/code7tjoy419]

and "lsusb" gives me back
[code7tjoy419]
Bus 002 Device 003: ID 13b1:0020 Linksys WUSB54GC 802.11g Adapter [ralink rt73]
[/code7tjoy419]
-> rt73 confused me a little bit?

My config is as follows

vi /etc/sysconfig/networking/devices/ifcfg-wlan0
[code7tjoy419]
# Linksys WUSB54GC
DEVICE=wlan0
BOOTPROTO=none
HWADDR=00:1c:10:e6:44:69
ONBOOT=yes
TYPE=Wireless
USERCTL=yes
PEERDNS=yes
NETMASK=255.255.255.0
IPADDR=192.168.1.4
GATEWAY=192.168.1.1
ESSID=linksys
CHANNEL=1
MODE=Managed
IPV6INIT=no
RATE=auto
[/code7tjoy419]

vi /etc/wpa_supplicant/wpa_supplicant.conf
[code7tjoy419]
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1

network={
ssid="linksys"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
psk="..."
}
[/code7tjoy419]

vi /etc/sysconfig/wpa_supplicant
[code7tjoy419]
...
INTERFACES="-iwlan0"
...
DRIVERS="-Dwext"
[/code7tjoy419]


Under Fedora 8 I had a similar problem - the network doesn't start automatically after boot. But the problem was that the wpa_supplicant starts before the message bus and this doesn't work. So there was a workaround to let start the service wpa_supplicant after the service message bus and after that it works fine!
In Fedora 9 this - I think - is not the problem, because this workaround is already set by default by the OS.

IvD

08-06-2008 13:30:11

This sounds like a Fedora problem rather then a driver problem.
Perhaps you should ask how to automatically start the interface on F9 on a Fedora forum/mailinglist.