problem with autoloading rt2570 at startup

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4875

hormati

04-07-2008 16:45:51

Hi,
I recently updated my kernel from 2.6.22-14 to 2.6.22-15 and obviously my rt2570 wireless card stopped working. So, I downloaded and reinstalled the newest version of the driver for the new kernel in exactly the same way as I installed it for 2.6.22-14. After loading the module the card started working and everything was fine. The problem is that when I restart my machine, my wireless card is not working. When I do "lsmod | grep rt2570", I get these two lines
> lsmod | grep rt2570
rt2570 190912 0
usbcore 138632 5 rt2570,usbhid,ehci_hcd,uhci_hcd

At this point if I just try to restart the card with 'ifdown' and 'ifup', I get an error
> sudo ifdown rausb0
ifdown interface rausb0 not configured

Apparently rt2570 is loaded but is not used by any device. If I do
> sudo rmmod rt2570
> sudo modprobe rt2570
> sudo ifdown rausb0
> sudo ifup rausb0

everything starts working, but it's annoying that I have to do this every time. Does any one have any idea why this is happening?

Thanks a lot.

BTW I am in Ubuntu Gutsy.

Vern

04-07-2008 18:01:53

At this point if I just try to restart the card with 'ifdown' and 'ifup', I get an error[/quote10hk8y2e]You might try "ifconfig -a" at this point and see what you do have. It may be that your upgrade also changes the interface name.

Thanks,

hormati

04-07-2008 18:56:03

Thanks for your suggestion, but that's not the problem here. As I said, if I do
> sudo rmmod rt2570
> sudo modprobe rt2570
> sudo ifdown rausb0
> sudo ifup rausb0

the card starts working. So, the interface name is the same. Something else is wrong.

Thanks
Amir

Vern

04-07-2008 19:06:35

Did you do what I asked?

hormati

04-07-2008 19:53:38

hehehe D I did not initially, but now i did it and you are right. The name is changed to wlan0. The thing that I don't understand is why it gets changed to rausb0 if I do rmmod and insmod again? ? ? ?

Everything is working now D
Thanks a lot

IvD

04-07-2008 20:02:05

Check your modprobe config file, it probably contains a line giving the ifname=wlan0 parameter to the rt2570 module.
Note that wlan0 is the correct name for a wireless interface and rausb0 is not, hence the reason we have a module parameter to configure the name.

hormati

04-07-2008 21:22:21

in my modprob.conf file i have this line
alias rausb0 rt2570

I added this line when I originally installed this driver on my old kernel. I still don't understand why rausb0 is changed to wlan0 and why if I rmmod and insmod rt2570 manually after system startup, the name gets changed to rausb0 again! ? ? ? ? ?

Thanks

Starcrasher

07-07-2008 16:54:06

Maybe because at startup udev gives the name wlan0 but when you rmmod/modprobe only the alias rausb0 line is read.
To avoid that, change the line in your modprobe.conf to
alias wlan0 rt2570.