does my rt2750USB device even work

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5232

AoXoMoXoA

23-03-2009 19:49:05

I got this SuperPassUSB-A20 off eBay. Supposedly has 38dbm of power. It uses rt2570.ko (device ID 0x0eb00x9020) which is installed OK. I used the latest "daily" driver. The "scan" function of RutilT finds the local wifi spot but won't connect.

[code2tbqw3tn]rausb0 RT2500USB WLAN ESSID:"<confidential>" Nickname:""
Mode:Managed Frequency=2.462 GHz Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Encryption key:<confidential> Security mode:open
Link Quality=0/100 Signal level:-120 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code2tbqw3tn]

Link Quality=0/100? That seems pretty poor.

My dinky net-book eeePC sees a 78% signal from the same spot. It won't connect either, something about "no working leases in the database". But I'm using the right key. And the link quality is 24/100.

What am I missing?

AoXoMoXoA

Spy84464

24-03-2009 18:46:17

Hello,
How did you configure the stick? Did you use RutilT? Have you tried connecting through the command line?
What are the settings of the network (encryption/authentication etc...)?

Regards,
Romain

AoXoMoXoA

25-03-2009 03:54:21


How did you configure the stick? Did you use RutilT? Have you tried connecting through the command line?
What are the settings of the network (encryption/authentication etc...)?
[/quote1zmm3950]

I used RutilT like I said. If by command line you mean iwconfig then yes I tried that. And ifconfig, iwlist and iwspy

Encrytion is WEP, Authentication is OPEN, Mode is Managed(according to the Link Status tab, but says Ad-Hoc mode under the RT2500USB WLAN tab), Channel is 11. And the key I got from the guy who's renting the service from his ISP.

The status is disconnected but under statistics I see that a meg or two gets received and a few hundred thousand bytes transmitted, but that's all. I can't connect to the web or even ping a url.

AoXoMoXoA

Spy84464

25-03-2009 18:14:02

Ok, you should have no problem at all connecting to this network.
This is worrisome that the status is disconnected, it means that association did not even succeed.
Have you tried "shared" instead of "open" as authentication mechanism? I don't think that this can be detected through scanning, you have to somehow know that this is in use. Make also sure that there is no mac filtering, or add your stick address in the AP control interface.

AoXoMoXoA

26-03-2009 17:55:27

Thanks for your suggestions.

I moved my 2500USB device to my net-book running the excellent systemrescuecd(no RutilT) and ran [code3jqwg5fx]root@sysresccd /root % iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:1E:58:06:39:01
ESSID:"Rock-Core Mine"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=47/100 Signal level:-73 dBm
Encryption key:on
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Preauthentication Supported
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000019a304462
Extra: Last beacon: 42ms ago
[/code3jqwg5fx]

Is "Address 001E58063901" the "stick address" you speak of? I ran[code3jqwg5fx]iwconfig wlan0 ap 00:1E:58:06:39:01[/code3jqwg5fx] but still[code3jqwg5fx]oot@sysresccd /root % iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"Rock-Core Mine"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:1234-5678-90 Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[/code3jqwg5fx] So, no luck. And I ran[code3jqwg5fx]root@sysresccd /root % iwconfig wlan0 mode shared
Error for wireless request "Set Mode" (8B06) :
invalid argument "shared".
[/code3jqwg5fx] So, I must be doing that wrong. What's the right way, please?

Spy84464

26-03-2009 18:28:22

The command is
iwconfig wlan0 key restricted [i2bq4joja]your_wep_key_here[/i2bq4joja]
Notice the "restricted" word.