Cnet CWP-854 with RT2561T chip rt61pci, firmware 1.2

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=1211

elhumano

18-04-2006 00:24:53

I just want to know if some one has got a RT2561T chip set working successfully ?, Its just that I have tried every thing and none drivers work for me nor firmware nor kernel or >= 2.6.13.
I have tested rt61.ko from ralink (ifconfig freezes computer with these drivers on reboot) and rt61pci.ko (does nothing) none off them worked for me

[imgeftnijzz]http://www.cnet.com.tw/product/photo/mCWP-854(D).jpg[/imgeftnijzz]

My wireless card is a CNET CWP-854 (pci) with a RT2561T

This is the device I have.
http//www.cnet.com.tw/product/cwp-854.htm

Best regards and thanks for any help
Gary

I even tested Ubuntu Dapper F6 it comes with rt61.ko driver y just copied firmware to the firmware folder but when I activate the device and reboot my system it freezes.

serialmonkey

18-04-2006 01:54:41

If you can read the sticky post at the top of the forum and give us some debug info on what happens with the rt2x00 driver then we can assist.

Cat5

18-04-2006 09:58:24

I have tested rt61.ko from ralink (ifconfig freezes computer with these drivers on reboot) and rt61pci.ko (does nothing) none off them worked for me

I even tested Ubuntu Dapper F6 it comes with rt61.ko driver y just copied firmware to the firmware folder but when I activate the device and reboot my system it freezes.[/quote21ompppj]

Have you tried compiling the source from Ralinktech but not using the firmware files included in said source archive but offered as an extra download on ralinktech site? That works for me on a Thinkpad T23 with Gigabyte GN-WI01GS Mini-PCi card. With included firmware my system freezes like yours and with rt2x00 BETA it at least loaded the driver, found the AP but did nothing more, like others write in another thread about rt61, too. I run Kubuntu Breezy badger, gave Dapper a try but it was a lot more messy than BB on the laptop.

I actually use said setup for about two weeks now without trouble but I don't know if your card will act different. But you could give it a try.

Benanov

17-12-2007 15:27:15

I have a CWC-854 rev E, which is same chipset but PCMCIA.

Apparently there shouldn't be much difference between the T and the non T chipsets.

I haven't gotten mine to work mainly due to lack of time.

--BK