No ProbeResp from current AP - assume out Problem

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=2081

arpspoof

03-10-2006 23:37:46

My Problem
Often, I lost the connection... and dmesg return me this message
[17183155.720000] wlan0 No ProbeResp from current AP 0013644e9a23 - assume out of range.

My Solution
At moment i've raised the value of IEEE80211_MONITORING_INTERVAL in ieee80211/ieee80211_sta.c file.

#define IEEE80211_MONITORING_INTERVAL (1000 * HZ)

a-slack

04-10-2006 00:32:34

I can confirm the problem (no encryption, Open AP)[code160aiv37]rt2500pci->rt2500pci_config_channel: Info - Switching channel. RF1: 0x00002020, RF2: 0x00080ca6, RF3: 0x00063611, RF4: 0x00000a1b.
rt2500pci->rt2500pci_conf_tx: Info - Configured TX ring 0 - CWmin: 4, CWmax: 10, Aifs: 2.
rt2500pci->rt2500pci_conf_tx: Info - Configured TX ring 1 - CWmin: 4, CWmax: 10, Aifs: 2.
rt2500pci->rt2500pci_conf_tx: Info - Configured TX ring 7 - CWmin: 5, CWmax: 10, Aifs: 2.
wlan0: Initial auth_alg=0
wlan0: authenticate with AP <BSSID>
wlan0: RX authentication from <BSSID> (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP <BSSID>
wlan0: RX AssocResp from <BSSID> (capab=0x461 status=0 aid=1)
wlan0: associated
wlan0: No ProbeResp from current AP <BSSID> - assume out of range
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: No STA entry for own AP <BSSID>
wlan0: RX deauthentication from <BSSID> (reason=2)
wlan0: deauthenticated
wlan0: authenticate with AP <BSSID>
wlan0: RX authentication from <BSSID> (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP <BSSID>
wlan0: RX ReassocResp from <BSSID> (capab=0x461 status=0 aid=1)
wlan0: associated[/code160aiv37]

wim

25-02-2008 20:37:32

i've had the same problem, increasing the timeout worked for me 2.

i'm using the sitecom wl-172 usb dongle (rt73usb).
increasing the timeout to 100 seems to be making a big difference. the driver in general seems more responsive. (no more packet loss with 1000 pings etc).

i've also had to disable the "nl80211 new netlink interface support" in the kernel (2.6.25-rc3). which i had previously enabled.
(with this enabled the driver did not work at all).

ggking7

17-04-2008 19:29:17

Had the same problem, increasing the timeout worked for me too.

gonchocho

04-08-2008 17:46:55

hi, I'm kind of newbie. how do you increase the timeout seconds?

Thanks in advance.

ggking7

04-08-2008 18:14:29

Search for the ieee80211/ieee80211_sta.c file and increase the value of IEEE80211_MONITORING_INTERVAL. You could also upgrade to the newest kernel version you can. That fixed it for me without hacking the file. The 2.6.25 series is a big improvement.

mikegerwitz

08-09-2008 10:42:09

The file ieee80211/ieee80211_sta.c does not exist in kernel 2.6.27. For those of you confused about the above posts (I was initially for a few moments), we're talking about the kernel source, which is generally located in

/usr/src/linux

Certain distributions may require you to download the kernel source before that location exists. Please see your distribution's documentation for more information on that.

For kernel 2.6.27 (and possibly earlier, I don't know), the file you are looking for is

/usr/src/linux/net/mac80211/mlme.c

Search for "IEEE80211_MONITORING_INTERVAL", modify it as stated in the first post (change "2 * HZ" to something like "100 * HZ"), then go back to /usr/src/linux

[code1wvp2zr2]
$ cd /usr/src/linux
$ make && make modules_install
$ cd arch
$ ls
[/code1wvp2zr2]

Locate your architecture (e.g. x86, x86_64, etc) and navigate to that folder. Then navigate to the boot folder. Within it, copy the file bzImage to your /boot partition, overwriting your current kernel (back up the old one first!). Then reboot - that's it.

If you're not sure what your current kernel is, type

[code1wvp2zr2]$ uname -r[/code1wvp2zr2]

EDIT Oh, yes - this problem still exists in kernel 2.6.27. ;) I am using rt61pci

Bert-

27-09-2008 17:57:15

Hi,


For information I had the same bug.
I use Ubuntu Hardy. my wireless adapter is a ralink
0409.0 Network controller RaLink RT2561/RT61 rev B 802.11g

kernel
Linux AciD 2.6.24.3-bertox #3 SMP Sat Sep 27 163615 MUT 2008 i686 GNU/Linux

I used driver from kernel
filename /lib/modules/2.6.24.3-bertox/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
license GPL
firmware rt2661.bin
firmware rt2561s.bin
firmware rt2561.bin
description Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version 2.0.10
author http//rt2x00.serialmonkey.com
srcversion D71C36F67F7A0F8B005A78F
alias pciv00001814d00000401sv*sd*bc*sc*i*
alias pciv00001814d00000302sv*sd*bc*sc*i*
alias pciv00001814d00000301sv*sd*bc*sc*i*
depends rt2x00lib,rt2x00pci,mac80211,eeprom_93cx6
vermagic 2.6.24.3-bertox SMP mod_unload 586


I had the No ProbeResp issue from generic kernel from ubuntu (2.6.24-16-generic)

So I compiled my kernel with the "IEEE80211_MONITORING_INTERVAL" option set to 1000 * HZ

I didn't have the No ProbeResp problem anymore. However, I was systematically disconnected. I mean the card seems to be connected to the AP, but no traffic at all.

After a lot of searches, I finally tried the Enhanced legacy drivers from serialmonkey

Result I've never been disconnected again ! )


I really don't know why kernel drivers seem to be broken (at least for me), nor what are the differences between the two drivers for end users, but if you have the No ProbeResp 'bug', you should try theses legacy drivers ;)

Hope it will help someone


Cheers,
Bert-.