rt73 works! - Update: Not working sorry!

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4243

Rich43

07-09-2007 13:13:29

Im running ubuntu and my D-Link DWL-G122 works out the box with no problems. It uses a rt73 chipset.

I **** you not, this thing has problems with windows.. its a nightmare to get working under windows.. even the official ralink drivers dont support it under windows and this driver has managed to get it working fine with linux and out the box!

IvD

07-09-2007 17:39:37

good to hear. )

Rich43

08-09-2007 00:51:30

Okay there are some problems after all..

Kernel is 2.6.22.. after a while of use the wireless cut out and I get this in dmesg, I cannot reconnect with any luck when it happens and pulling out the stick and putting back in just makes it worse.

[17076.187418] wlan1 Initial auth_alg=0
[17076.187423] wlan1 authenticate with AP 001b2f4227ee
[17076.188802] wlan1 RX authentication from 001b2f4227ee (alg=0 transaction=2 status=0)
[17076.188805] wlan1 authenticated
[17076.188807] wlan1 associate with AP 001b2f4227ee
[17076.192300] wlan1 RX AssocResp from 001b2f4227ee (capab=0x471 status=0 aid=1)
[17076.192304] wlan1 associated
[17076.192333] wlan1 WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 burst=0
[17076.192337] wlan1 WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
[17076.192340] wlan1 WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 burst=30
[17076.192342] wlan1 WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 burst=15
[17076.194599] ADDRCONF(NETDEV_CHANGE) wlan1 link becomes ready
[17076.204170] wlan1 RX WEP frame with unknown keyidx 2 (A1=333300000016 A2=001b2f4227ee A3=00195b81b158)
[17076.496125] wlan1 duplicate address detected!
[17079.743320] wlan1 duplicate address detected!
[18811.031638] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18811.131616] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x308c with error -110.
[18811.231597] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18811.331450] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18811.431428] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x308c with error -110.
[18812.531197] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18812.631176] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x308c with error -110.
[18812.731156] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18812.831134] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x30c4 with error -110.
[18812.931115] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18813.031093] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18813.131070] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18813.231050] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18813.331028] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -110.
[18813.331132] phy0 -> rt73usb_bbp_write Error - PHY_CSR3 register busy. Write failed.



.... some time later I got another error

[19527.929899] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3008 with error -110.
[19528.029877] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3024 with error -110.
[19528.129856] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3024 with error -110.
[19528.229834] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3020 with error -110.
[19528.329813] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3020 with error -110.
[19528.429792] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3040 with error -110.
[19528.529771] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3040 with error -110.
[19528.629625] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3050 with error -110.
[19528.729605] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3050 with error -110.
[19528.829584] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3064 with error -110.
[19528.929561] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3064 with error -110.
[19529.029540] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x01 failed for offset 0x0000 with error -110.
[19529.129520] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.229499] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x3030 with error -110.
[19529.329477] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.445454] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.561429] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.677406] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.793382] phy0 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x3030 with error -110.
[19529.809312] phy0 -> rt73usb_enable_radio Error - Register initialization failed.

mcmlxxii

08-09-2007 07:51:44

There are indeed some problems with the rt73usb module in Gutsy, it dies horribly (for me requiring a shut-down and restart), but it isn't the latest CVS. I couldn't get the CVS to compile, I think it requires a newer version of the wireless stack than the one in Gutsy. If you have any luck I'd be delighted to hear about it as I'd like to be help with testing!

On a more positive note, the rt73 module compiles and works flawlessly - see [url1ec0vd77]http://ubuntuforums.org/showthread.php?t=400236[/url1ec0vd77]

Austin_KW

11-09-2007 13:16:07

There are indeed some problems with the rt73usb module in Gutsy, it dies horribly (for me requiring a shut-down and restart), but it isn't the latest CVS. I couldn't get the CVS to compile, I think it requires a newer version of the wireless stack than the one in Gutsy. If you have any luck I'd be delighted to hear about it as I'd like to be help with testing!

On a more positive note, the rt73 module compiles and works flawlessly - see [url3b8eoqjv]http://ubuntuforums.org/showthread.php?t=400236[/url3b8eoqjv][/quote3b8eoqjv]
If you look later in that thread http//ubuntuforums.org/showthread.php? ... ost3267508 you will see my instructions for compiling the cvs beta driver with gutsy.

defcon

08-10-2007 15:10:10

rt73 does not compile/run flawlessly anymore
http//forum.deluge-torrent.org/viewtop ... 4e37f55547

sefs

23-10-2007 18:15:17

Austin_KW does this solve the hard lock problem (scroll lock, caps lock blinking) with gutsy and rt73? That requires a hard reboot?

Thanks.