Problem using rt2x00 driver as network brigde for vmware

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4324

artcrime

02-10-2007 17:26:31

Hi,

I have just installed the Gutsy Gibbon Beta distribution and nearly everything is working fine.
The only problem I found is bridging between vmware and the interface.
If I start the virtual machine and it starts its dhcp request my physical interface sometimes looses link to the access point and they never can communicate with each other. Static IP's dont solve the problem.

I never encountered this error with the old rt2500 module only with the new driver rt2x00, a bridge to my eth0 works fine!

This is what modinfo tells me

filename /lib/modules/2.6.22-12-generic/ubuntu/wireless/rt2x00/rt2500pci.ko
license GPL
description Ralink RT2500 PCI & PCMCIA Wireless LAN driver.
version 2.0.4
author http//rt2x00.serialmonkey.com
srcversion 551DB639C693C1B6DB7ACBB
alias pciv00001814d00000201sv*sd*bc*sc*i*
depends rt2x00pci,rt2x00lib,mac80211,eeprom_93cx6
vermagic 2.6.22-12-generic SMP mod_unload 586


Does anyone have a solution? Or tried out the same?

I use the most recent vmware server or player package.

Greetings from germany

Sascha

cgizmo

07-10-2007 10:36:06

Look here, it's in the changelog

[quote16jn8ge0] CURRENTLY NOT SUPPORTED
* Power Saving Modes (1159331)
* Bridging with other interfaces
[/quote16jn8ge0]
Hope I have helped you.

artcrime

22-10-2007 18:23:01

Hi,

yes you did, I just tested it with virtual box (same result) now I know why!

Greetings from germany!