driver behavior at boot in Debian Etch

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4489

nbi

06-12-2007 19:47:00

The latest snapshot seems to perform very well (stable 54M rate, good link quality) but it's boot time behavior has changed.

With a previous version I could start wireless in Debian etch with only the following two commands in rc.local (this assumes /etc/network/interfaces is correct)

modprobe rt2500pci
ifup wlan0

but now this doesn't work. modprobe correctly loads the rt2* modules but ifup fails for some reason. If I execute 'ifup wlan0' from the command line everything is ok. Timing problem?

nbi

07-12-2007 21:47:17

The latest snapshot seems to perform very well (stable 54M rate, good link quality) but it's boot time behavior has changed.

With a previous version I could start wireless in Debian etch with only the following two commands in rc.local (this assumes /etc/network/interfaces is correct)

modprobe rt2500pci
ifup wlan0

but now this doesn't work. modprobe correctly loads the rt2* modules but ifup fails for some reason. If I execute 'ifup wlan0' from the command line everything is ok. Timing problem?[/quote174lweq8]

Ok, got it to work by declaring wlan0 as "auto" in /etc/network/interfaces and changing rc.local to

modprobe rt2500pci
ifup -a wlan0

Note the addition of "-a". Don't know why it worked without this with the older driver, but it works with the new. Guess I shouldn't look a gift horse in the mouth. roll

jilse

28-12-2007 00:19:56

The latest snapshot seems to perform very well (stable 54M rate, good link quality) but it's boot time behavior has changed.

With a previous version I could start wireless in Debian etch with only the following two commands in rc.local (this assumes /etc/network/interfaces is correct)

modprobe rt2500pci
ifup wlan0

but now this doesn't work. modprobe correctly loads the rt2* modules but ifup fails for some reason. If I execute 'ifup wlan0' from the command line everything is ok. Timing problem?[/quote1vgp6fd1]

Ok, got it to work by declaring wlan0 as "auto" in /etc/network/interfaces and changing rc.local to

modprobe rt2500pci
ifup -a wlan0

Note the addition of "-a". Don't know why it worked without this with the older driver, but it works with the new. Guess I shouldn't look a gift horse in the mouth. roll[/quote1vgp6fd1]

Maybe, this leads to an "additional try" to load the drivers ...
I noticed, that (with my rt2500 mini-PCI card), that i see no
wlan-Interface the first time, i try to load the drivers. If i than
unload the drivers and reload them again, the interfaces are
there and wlan0 comes up ...

I have the following lines in my /etc/modprobe.d/options

install wlan0 { modprobe arc4; modprobe aes; modprobe mac80211; modprobe cfg80211; modprobe eeprom_93cx6; modprobe crc-itu-t; modprobe rt2x00lib; modprobe rt2x00pci; modprobe rt2500pci; ; }
remove wlan0 { rmmod rt2500pci; rmmod rt2x00pci; rmmod rt2x00lib; rmmod eeprom_93cx6; rmmod crc-itu-t; rmmod mac80211; rmmod cfg80211; ; }

The driver is (according to debugfs)
driver rt2500pci
version 2.0.13
compiled Dec 28 2007 003218

I used the daily-snapshot rt2x00-cvs-2007122716.

The distribution is Ubuntu 7.10, the kernel is a
self-conpiled 2.6.24rc6.

Btw. how can i add additional virtual interfaces?

# $ echo -n <name> > /sys/class/ieee80211/<dev>/add_iface

seems not to work, because there is no file add_iface below
/sys (i used the mac80211 that is contained in the kernel
2.6.24rc6) ...

zorxd

31-12-2007 07:54:48

This is what I use in /etc/network interfaces

auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant.conf


the modules should load automatically with udev