rt2500usb not working anymore:authentication with AP timeout

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4542

nicofo

06-01-2008 11:05:01

Hello,

I'm using Fedora 7 which includes rt2x00 as module in the kernel.
Previously (<= kernel 2.6.23.1-21.fc7), the rt2x00 driver was working fine. I use rt2500usb.
Now, with the latest updates of the kernel (2.6.23.8-34.fc7 (Dec '07) and 2.6.23.12-52.fc7 (Jan '08 )) the wifi doesn't work anymore though the card seems well configured and recognized.
The version of the driver is
[code39xx5qbg]# modinfo rt2500usb -k 2.6.23.1-21.fc7 -F version
2.0.8 (was working)

# modinfo rt2500usb -k 2.6.23.8-34.fc7 -F version
2.0.10 (doesn't work)

# modinfo rt2500usb -k 2.6.23.12-52.fc7 -F version
2.0.13 (doesn't work)[/code39xx5qbg]

iwconfig and ifconfig give
[code39xx5qbg]IWCONFIG
wlan0 IEEE 802.11g ESSID:"yyyyyyyyyyyyyyy
Mode:Managed Frequency:2.462 GHz Access Point: xxxxxxxxxxxxxxxxxxx
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:xxxxxxxxxxxxxxxxxx
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

IFCONFIG

wlan0 Link encap:Ethernet HWaddr 00:12:17:87:C8:99
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)[/code39xx5qbg]

The scan is working and my network is recognized
[code39xx5qbg]iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: xxxxxxxxxxxxxxxxx
ESSID:""
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=47/100 Signal level=-75 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=00000000ad31818e[/code39xx5qbg]
But I cannot ping my router
[code39xx5qbg] ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable
From 192.168.1.10 icmp_seq=3 Destination Host Unreachable
From 192.168.1.10 icmp_seq=4 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2999ms
, pipe 3[/code39xx5qbg]

In dmesg I have the following error[code39xx5qbg]
usbcore: registered new interface driver rt2500usb
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:06:25:fa:ea:75
wlan0: authenticate with AP 00:06:25:fa:ea:75
wlan0: authenticate with AP 00:06:25:fa:ea:75
wlan0: authentication with AP 00:06:25:fa:ea:75 timed out[/code39xx5qbg]

Can you help me
Thanks

PS perhaps it's the same problem as http//rt2x00.serialmonkey.com/phpBB2/v ... php?t=4534

AdamBaker

06-01-2008 17:29:39

It does seem likely that it is the same error.

nicofo

31-01-2008 20:57:15

Ok, with the ast version of the kernel (2.6.23.14-64.fc7 on fedora 7) the timeout problem is resolved.
The version of rt2500usb is now [codeoqbcgn0o]/sbin/modinfo rt2500usb -F version
2.0.14[/codeoqbcgn0o]

BUT, I experience now VERY POOR connection (Link Quality => 7% !! ) and as a result I loose my connection after a while.

This is probably connected with other recent threads for the rt2500 on this forum...