weird: 1M and 11M connection faster than 54M connection

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4560

Arthur Dent

15-01-2008 10:24:10

Hello everybody,

i have a weird problem with the next generation driver (a build from 20071026). I use this old build, because it is the only way to get my card (rt73 chipset) work under a mpc5200-board (ppc) with kernel 2.6.23.

Now my problem I made a performance test by transfering data via FTP and found out, that the connection is much faster when I set it manually to 1M or 11M. If I set the connection to 54M, I have the lowest bitrate. Any ideas what is going on here?

Thank you very much.

Arthur Dent

Arthur Dent

16-01-2008 09:15:25

Hi again, I am a little confused because this thread was moved. The driver I am using is the rt2x00-driver, an old one, but it is (was) not the legacy driver.

IvD

16-01-2008 15:09:36

Sorry, I only skimmed your topic and immediately moved it to the legacy driver section.

Anyway, using a rt2x00 build from oktober 2007 is too old, could you retry with a more recent version?

AdamBaker

16-01-2008 20:35:47

If you can't upgrade to a newer kernel you could google for compat wireless for help running the latest drivers and latest mac80211 on older kernels.

One reason the lower rates could be slower is because lots of retries happen at 54M. There could be lots of retries because older rt2x00 versions had bugs that caused poor sensitivity or bad antenna settings. Higher data rates are mor sensitive to such problems.

Arthur Dent

21-01-2008 15:29:17

Hi AdamBaker,

thanks for your reply. I definitely can not switch to a newer kernel, so I tried your tip. I downloaded the latest wireless drivers from linuxwireless.org. The drivers compiled fine and I copied the three modules rt2x00lib.ko, rt2x00usb.ko, rt73usb.ko to my device. After a "modprobe rt73usb" I got a kernel Oops.

Are you more familiar with that stuff? Is it possible, that I have to change the kernel sources in net/mac80211 net/wireless and so on?

Best regards

Arthur Dent

AdamBaker

21-01-2008 20:51:24

Sorry, I haven't actually used the compat wireless stuff, I use the rt2x00 git tree but

1) Your post suggests you are cross compiling - are you following the guidelines for compiling for external kernels but additionally setting CC?
2) I'd expect you to need a new mac80211.ko as well as the rt2x00 modules

alex-it

21-01-2008 22:25:16

[quote2qct1sdo]2) I'd expect you to need a new mac80211.ko as well as the rt2x00 modules[/quote2qct1sdo]I confirm that.
To install compat-wirless packages correctly, you should execute the command "sudo make load" after compiling it.