Slow connection with rt2500

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4579

frenkel

21-01-2008 19:57:03

Hi,

I'm still experiencing very slow connection speeds with the latest daily build from Ubuntu (it uses this kernel Linux ubuntu 2.6.24-3-generic #1 SMP Thu Jan 3 233029 UTC 2008 i686 GNU/Linux).
I thought this problem was fixed in the driver that's going to be included in the kernel? I tried setting the connection rate manually, but that doesn't help. There are no weird messages in my logs either.

Also see this bugreport [url1spdmp54]https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/134660[/url1spdmp54]

AdamBaker

21-01-2008 21:06:14

As 2.6.24 isn't yet released it is hard to know whether the most recent fixes will make it. The current rt2x00 git tree is looking good on rt73 and rt61, I don't have any rt2500 devices to test with but there has been work to address rt2500 issues recently so they stand a good chance of working too.

frenkel

25-01-2008 11:14:10

I just installed kernel 2.6.24 and it's still a slow connection, so there was no fix in 2.6.24.

goethe

29-01-2008 05:32:55

I can confirm this bug. I was using 2.6.24 final with a rt61 chip, connection speed was around 80kb/s max, I experienced poor link quality, too so I switched back to the legacy driver. Is there any way to provide you with further debug information (what do you need)?

simjoko

29-01-2008 08:17:55

As 2.6.24 isn't yet released it is hard to know whether the most recent fixes will make it. The current rt2x00 git tree is looking good on rt73 and rt61, I don't have any rt2500 devices to test with but there has been work to address rt2500 issues recently so they stand a good chance of working too.[/quote7d8ecyzc]

I wonder of which git he is speaking of?
The last git change regading rt250 have been 2 weeks ago. There is no/very low traffic on the mailing lists. I really would like to know who to contact for debugging purpose. Since this series is going mainline I thought there should be a single bit more traffic here.
I gave up on this. I have no time to wait weeks for anyone to respond on a problem. Sad that all the time I took trying to investigate in how, where and what to debug seems wasted.

IvD

29-01-2008 19:09:05

There are several git branches
linux-2.6
wireless-2.6
rt2x00-2.6

Linux 2.6 contains rt2x00-2.0.10
while wireless-2.6 and rt2x00 are up to 2.0.14. This version is much better then the version in the main linux tree.

mikkoc

31-01-2008 17:06:57

Hi,

I can confirm this behavior with my rt2500 pci card.
iwconfig shows a 1 Mb rate, instead of 54.
Speed varies from 0 to 50 kb/s, and it hangs very often, it's actually not usable.

Kernel is 2.6.24.

EDIT I've tried installing this http//linuxwireless.org/download/compa ... .6.tar.bz2

It has version 2.0.14 in it, but actually it's even worse there's no way I can connect to my access point... It scans correctly and finds it, but no matter what, it times out when trying to associate.

nicofo

31-01-2008 20:59:13

IDEM on fedora 7 with the last kernel (2.6.23.14-64.fc7).
Link Quality = 7% (instead of 60-80 % !)
The connection is so poor that I loose it after a while.

chrisV

01-02-2008 19:36:07


EDIT I've tried installing this http//linuxwireless.org/download/compa ... .6.tar.bz2

It has version 2.0.14 in it, but actually it's even worse there's no way I can connect to my access point... It scans correctly and finds it, but no matter what, it times out when trying to associate.[/quote1ey6wo6f]

Something seems to be amiss with mac80211 in the current wireless-2.6 everything branch (and therefore in compat-wireless-2.6). Versions from the last 2 or 3 days have caused my rt73 stick to cease to associate and my syslog gets filled with messages like

kernel WARNING at /usr/local/src/rt2x00-kernel/compat-wireless-2.6/net/mac80211/rx.c2022 __ieee80211_rx()
kernel Pid 0, comm swapper Not tainted 2.6.24 #1
kernel [<cef3307e>] __ieee80211_rx+0x6e/0x620 [mac80211]
kernel [<cea02740>] ehci_work+0xb0/0x780 [ehci_hcd]
kernel [<cef2356f>] ieee80211_tasklet_handler+0x11f/0x130 [mac80211]
kernel [<c011f4d7>] tasklet_action+0x27/0x60
kernel [<c011f432>] __do_softirq+0x42/0x90
kernel [<c011f4a6>] do_softirq+0x26/0x30
kernel [<c0106a2a>] do_IRQ+0x4a/0x80
kernel [<c0104fd3>] common_interrupt+0x23/0x30
kernel [<c0104fd3>] common_interrupt+0x23/0x30
kernel [<c0102d3a>] default_idle+0x2a/0x40
kernel [<c01025cf>] cpu_idle+0x3f/0x60
kernel [<c0392aaf>] start_kernel+0x1ef/0x230
kernel [<c0392370>] unknown_bootoption+0x0/0x1f0

If you are getting similar in your syslog then go back a week, or wait for the bug to be fixed.

Chris

IvD

01-02-2008 22:26:57

This has been fixed in rt2x00.git

chrisV

01-02-2008 23:22:15

This has been fixed in rt2x00.git[/quote3sl2oje1]
Is that a fix to the rt2x00 driver or to mac80211?

Chris

IvD

01-02-2008 23:34:05

Although the bug could have been fixed in mac8021 (by changing a u16 back to u32), I fixed it in rt2x00 by a more flexible implementation of rate handling.

So you can say it was a mac80211 bug because a variable was changed from u32 to u16 or a rt2x00 bug because it stored too much information in a variable which wasn't designed for such an abuse.. ;)

mikkoc

02-02-2008 07:13:48

This has been fixed in rt2x00.git[/quote3kdcyxsk]

Thanks!
where can i download it? )

EDIT Following this link http//rt2x00.serialmonkey.com/wiki/ind ... structions
it downloads the whole kernel shock
Isn't there a way to download the driver only??

IvD

02-02-2008 11:56:26

yes, using the cvs nightly tarball, but you will still need the entire kernel repository since the current rt2x00 version is incompatible with the mac80211 version in 2.6.24

nand

14-02-2008 17:25:49

The bug (slow connection because of a default bitrate of 1Mb/s) is still here in the alphas of ubuntu
https//bugs.launchpad.net/ubuntu/+sour ... bug/190515
(But when setting manually the bitrate to 54 Mb/s, it goes to the expected speed.)

I understand there was a fix, will it go to the 2.6.24.x kernel branch, or will it wait for the 2.6.25 release? In the latter case, I wonder if a backport patch for 2.6.24 would be feasible...

Thanks!

oponek

21-02-2008 14:11:02

I have the same problem with rt2400 card. Hope it will be fixed in Ubuntu Hardy...

IvD

25-02-2008 16:23:41

The fix is in linux 2.6.25.
And no, I am not backporting any fixes to older kernels (unless it fixes segmentation faults / null pointers faults or other crashes).

nand

26-02-2008 11:27:02

Ok thanks for the info!

ngc2997

07-04-2008 11:33:59

Hm does that mean that unless I am using a legacy driver (not working with Gnome's Network Manager), or compile a newer kernel, this won't be fixed in Hardy? If so, that is a slightly unpleasant perspective for the next six months, meaning I will have to go 'back' to a wired connection.. *sigh*

Best wishes,
Karsten

thnker

09-04-2008 21:39:53

I have this problem too - 1 Mb/s bit rate. I'm using kernel version 2.6.24.4-69 on a mac G4 (ppc) with a linksys wireless g pci card. Being a newbie to linux, I'm not sure I understand the current situation with the rt2x00 driver. From this thread, I see that there is a thing called rt2x00.git that contains a fixed version of the rt2x00 driver but also, the rt2x00.git contains an entire kernel.

a) Is the kernel in the rt2x00.git a fedora core 8 kernel or is it a beta version of fedora core 9?

b) Is there any way to get the fixed version of rt2x00 driver without installing a beta version of a kernel?

c) Would the old rt2500 driver work better for me than the best version of rt2x00 that I'm able to get with fedora core 8 and if so, how do I switch from using the rt2x00 driver to the rt2500 driver?

d) What is a git?

Sorry for so many questions. I've spent days getting to where I am now on this problem and still feel lost. Thanks in advance for any help you can offer.

IvD

09-04-2008 21:53:45


a) Is the kernel in the rt2x00.git a fedora core 8 kernel or is it a beta version of fedora core 9?
[/quote21y7cgw3]

rt2x00.git is not fedora.
rt2x00.git is a branch of the Linux Kernel, the Fedora kernel is a branch of the Linux Kernel. The Fedora kernel contains many patches from rt2x00.git which are not yet in the main Linux kernel.


b) Is there any way to get the fixed version of rt2x00 driver without installing a beta version of a kernel?
[/quote21y7cgw3]

Either use the latest Fedora kernel, or go to linuxwireless.org and download the wireless-compat package. But that version contains the same rt2x00 version that is currently found in the latest Fedora kernel...
Note that with latest Fedora kernel I mean the development kernel that is not yet available through Yum(?) but is available for download on the Fedora website.


c) Would the old rt2500 driver work better for me than the best version of rt2x00 that I'm able to get with fedora core 8 and if so, how do I switch from using the rt2x00 driver to the rt2500 driver?
[/quote21y7cgw3]

If you don't intend to use NetworkManager and want to write all networking configuration manually, then yes you can use the rt2500 package. Simply read the INSTALL and README files provided in that package. And Google is your friend when you want complete howtos for Fedora and rt2500.


d) What is a git?
[/quote21y7cgw3]

http//en.wikipedia.org/wiki/Git_(software)

thnker

16-04-2008 21:31:18

I just installed 2.6.25 and all of my problems relating to the rt2x00 wireless driver are fixed except that I'm getting a low throughput rate. When using a wired connection on this machine, I can download the latest fedora 8 core at about 600 kB/sec (almost full ISP connection bitrate). However, with the wireless connection (rt2x00) the same download occurs at about 30 kB/sec.

Is there a setting somewhere that is misconfigured so as to cause the low bitrate?

ifconfig reports

wlan0 Link encapEthernet HWaddr 000F66ED70A7
inet addr192.168.2.100 Bcast192.168.2.255 Mask255.255.255.0
inet6 addr fe8020f66fffeed70a7/64 ScopeLink
UP BROADCAST RUNNING MULTICAST MTU1500 Metric1
RX packets2399 errors0 dropped0 overruns0 frame0
TX packets2518 errors0 dropped0 overruns0 carrier0
collisions0 txqueuelen1000
RX bytes2786385 (2.6 MiB) TX bytes278028 (271.5 KiB)

iwconfig reports

wlan0 IEEE 802.11 ESSID"linksys"
ModeManaged Frequency2.437 GHz Access Point 00121709554C
Bit Rate=54 Mb/s Tx-Power=23 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption key<hidden>
Link Quality=62/100 Signal level=-21 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

Rikz

18-04-2008 07:57:28

I have the same problem with rt2500 driver from 2.6.25 kernel in case you are collecting some statistics.

Hazzl

20-04-2008 20:37:39

I have the same problems (as already described in this thread[/url37k6i97w]. When the link is first established, iwconfig shows a rate of 1M, however, the speed doesn't improve even after manually setting the rate to 54M (

With the latest rt2x00 git kernel (2.6.25-rc9-wl-30069-g026c62a) I get some interesting looking warnings in the kernel log

[quote37k6i97w]Apr 20 220815 eressea kernel [ 3174.692609] phy0 -> rt2x00lib_rxdone Warning - Frame received with unrecognized signal,signal=0x09, plcp=0.
Apr 20 222031 eressea kernel [ 3891.556084] phy0 -> rt2x00lib_rxdone Warning - Frame received with unrecognized signal,signal=0x0c, plcp=0.
[/quote37k6i97w]

Can this help to trace down the causes for the missing performance?

IvD

20-04-2008 21:19:31

Unfortunately no, that bug is a hardware bug which causes a frame to be marked with an incorrect RX rate. rt2x00 compensates this by setting the RX rate to something mac80211 will accept (if rt2x00 wouldn't do that, the frame would be dropped by mac80211).

osuwop

21-04-2008 21:31:01

Unfortunately no, that bug is a hardware bug which causes a frame to be marked with an incorrect RX rate. rt2x00 compensates this by setting the RX rate to something mac80211 will accept (if rt2x00 wouldn't do that, the frame would be dropped by mac80211).[/quote1mkzjxeh]

so are you saying that this speed issue is a bug that cannot be corrected due to it being a hardware issue? also are people confirming that this speed issue is NOT corrected in .25?

IvD

21-04-2008 21:37:10

No I am saying that the error message reported by Hazzl is caused by a hardware error AND that this error message has _nothing_ to do with the rate issue.

I have heard mixed reports about the 2.6.25 kernel, in some rc releases people reported high speeds, but with the follow-up rc release the rate was slow again. Changes in rt2x00 between those rc releases were minimal and didn't affect the TX code.
Based on what I heard from other drivers, is that _perhaps_ the issue is caused by the rate selection module provided by mac80211 in combination with bad link quality reporting by the driver.
In addition another possible cause had to do with short preamble mode.
Both causes are under investigation.

mikkoc

25-04-2008 08:29:32

I can confirm that going from 2.6.24 to .25 did NOT fix any speed/rate issue for me.
I still get the 1M rate, even after manually setting it to 54M.
The download speed is around 30-40 KB/s, but not very stable, it tends to drop very often, web pages always timeout.

Result back to old rt2500, which works like a charm D

lspci --v
[code2cdz4hr0]00:10.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
Subsystem: Micro-Star International Co., Ltd. Device 6834
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 12
Region 0: Memory at da100000 (32-bit, non-prefetchable) [size=8K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Kernel driver in use: rt2500pci
Kernel modules: rt2500pci[/code2cdz4hr0]

Toon

26-04-2008 09:38:02

I have heard mixed reports about the 2.6.25 kernel, in some rc releases people reported high speeds, but with the follow-up rc release the rate was slow again. Changes in rt2x00 between those rc releases were minimal and didn't affect the TX code.
Based on what I heard from other drivers, is that _perhaps_ the issue is caused by the rate selection module provided by mac80211 in combination with bad link quality reporting by the driver.
In addition another possible cause had to do with short preamble mode.
Both causes are under investigation.[/quote3h67g7rk]

Yeah, sounds plausible.
I'm currently running Gentoo Linux with kernel 2.6.25-r1.
I'm using the in-kernel rt2500pci driver.
The link speed is (automatically) set to 1Mb.
Interesting observation in the NetworkManager icon the signal strength indication is fluctuating wildly.
I didn't have problems with an earlier CVS-version of the rt2500pci driver on 2.6.23.

Regards,
Toon.

madwolfa

18-05-2008 05:28:10

Confirmed, the same problem with 2.6.25-4 under Ubuntu Hardy 8.04 (rt2500pci 2.0.14).. I'm now building the 2.6.26-rc2 to check, if it's still there.. ( This problem is dreading me for a few months already (since the release of 2.6.24)... I can't imagine why it wasn't fixed yet with so many complaints.

IvD

18-05-2008 10:02:24

I can't imagine why it wasn't fixed yet with so many complaints.[/quotettty3vhd]

Well if you know *exactly* what the cause of the problem is, then please say so. Because then it can be fixed.
If not, then you just have to wait until I have actually enough time to track this bug down, or wait until there arrives a second developer for rt2x00 who can look into this.

madwolfa

18-05-2008 12:40:30

Well, I have no idea.. cry

2.6.26-rc2 (with rt2500pci 2.1.4) didn't help at all...

madwolfa

18-05-2008 13:43:56

Actually it helped a bit - but I had to force rate to 54M. The quality of signal got up to 90% and speed went up to like 1.5-2.0 Mbps. But it's still far from enough, considering my 6.0 Mbps internet link. )

devosion

23-05-2008 01:11:08

Is the git repository down? Everytime I try accessing it git tells me...

'error No files to search found.'

I visited the main site and noticed the last time it had been accessed was 6 hours ago.

BTW im using this how-to http//rt2x00.serialmonkey.com/wiki/ind ... structions

IvD

23-05-2008 14:00:18

I don't have any problems, cloning/updating/pushing all work for me.

sulligogs

17-06-2008 20:29:25

Hi,

This post is one of success regarding increasing the speed of my RT2500 card in Debian Lenny with the 2.6.24-1-686 kernel that comes with the rt2x00 drivers.

I thought that manually setting the rate of my card to "54M" had worked, but I was wrong.

However! I played around with other rates and when I set it to "11M" my card was flying!

So, at a root terminal I used-

[code3317w1m1]
iwconfig wlan0 rate 11M
[/code3317w1m1]

and my Firefox 3 download went from 7kbs to over 200kbs. Just in time actually as today is Firefox 3 Download Day )

See if it helps you guys.

Sulligogs

JoCo

23-06-2008 20:43:44

Hi,

Just confirming that manually setting the rate to 11M as suggested by Sulligogs results in a better connection for me than setting it to 54M, with the version of the rt2500pci driver contained in the following Mandriva 2008.1 kernel packages

kernel-laptop-2.6.24.5-2mnb
kernel-linus-2.6.25.7-1mdv

Cheers,

Joe

ariveira

25-06-2008 16:25:26

I can confirm this behaviour with a rt2500pci card speed is slow by default on various kernel
versions (all vanilla).
If I force 54M with iwconfig i get back spected speed in kernels prior to 2.6.26-rc* on this
kernelseven this workaround wont work and i'm stuck with low speeds (

So i guess i will have to stick with 2.6.25.y + iwconfig wlan0 rate 54M )

Thanks for taking the time to look into this

amadues

28-06-2008 16:27:37

I can't imagine why it wasn't fixed yet with so many complaints.[/quote31tn4t7z]

Well if you know *exactly* what the cause of the problem is, then please say so. Because then it can be fixed.
If not, then you just have to wait until I have actually enough time to track this bug down, or wait until there arrives a second developer for rt2x00 who can look into this.[/quote31tn4t7z]


IvD, are there any debug commands we can run to help you find the problem? Would shipping you an affected card help or do you also experience the same issue yourself (card associates at 1 Mbps, throughput is low even with rate forced to 54M)?

IvD

28-06-2008 17:12:32

I can confirm the problem for 2.6.25, but have not been able to test 2.6.26 yet due to HardDisk problems on that kernel.
So far I don't know what is causing the problem, and am not sure where to start looking.

meetmeonaholiday

14-07-2008 17:53:06

I can report my connection is still slow in 2.6.26 compiled last night. The fix reported here works though -- forcing the rate to either 11M or 54M (the change will not be reported in iwconfig). No idea what the issue is but I'm happy for this fix. Thanks for all your great work Ivo!

sverf

16-07-2008 09:11:49

Same problem here with a rt2500 pcmcia card (pciid 18143c00, subs 19484c00).
Driver associates fine (using WPA encryption and wpa_supplicant), but its stuck at 1M.

If I manually set rate 54M performance increases (btw, output of iwconfig doesnt show rate change immediately, it takes like 5-10sec to change in the iwconfig output for some reason).

Also the link quality reported goes up from about 53 to 83 after switching to 54M.

Another thing I noticed is when I
* iwconfig wlan0 rate 2M
* wait for iwconfig to report 2M (maybe it doesnt change till next packet is TX'ed? just guessing here),
* iwconfig wlan0 rate auto
* generate some traffic

The speed will automatically climb up to 54M. It seems there is some problem with just the 1M rate.

The rt61 pcmcia card I also have is not affected by this issue. Setting rate to 1M on the rt61 and then back to rate auto makes it climb back up to 54M.

chrisb

17-07-2008 15:52:37

Hi

Tried getting the driver compiled and working on SUSE 10.3 but gave up and installed 11.0 instead.

Similar things happening on Suse 11.0. Using kernel 2.6.25.9-0.2-default and still getting the speed issue described above.
Again using "iwconfig wlan0 RATE 54M[/color11r2xtpl]" works a treat!

Thanks

Chris

ariveira

18-07-2008 10:43:51

I can confirm this behaviour with a rt2500pci card speed is slow by default on various kernel
versions (all vanilla).
If I force 54M with iwconfig i get back spected speed in kernels prior to 2.6.26-rc* on this
kernelseven this workaround wont work and i'm stuck with low speeds (

So i guess i will have to stick with 2.6.25.y + iwconfig wlan0 rate 54M )

Thanks for taking the time to look into this[/quote3osvn6iv]

The problem persits on 26 final the previous working workaround of manually forcing
higher speeds no longer works.

Any advance on this? Anything i can do to help ?

Thanks in advance

Zi7

18-07-2008 17:18:35

Another thing I noticed is when I
* iwconfig wlan0 rate 2M
* wait for iwconfig to report 2M (maybe it doesnt change till next packet is TX'ed? just guessing here),
* iwconfig wlan0 rate auto
* generate some traffic

The speed will automatically climb up to 54M. It seems there is some problem with just the 1M rate.[/quote2exgvm43]
Could you please confirm that this same trick does _not_ work when you set the rate to 1M (instead of 2M) then back to 'auto' (rt2500pci)?

sverf

21-07-2008 07:28:55

I've redone my tests and found something different indeed

* remove the card and modules
* re-insert the card and load modules.
* start wpa_supplicant to do WPA (I've used wpa_supplicant in all cases here btw, TKIP).
* Now its stuck at 1M
* iwconfig wlan0 rate auto
* still stuck at 1M
* iwconfig wlan0 rate 1M
* generate some traffic
* iwconfig wlan0 rate auto
* still stuck at 1M
* iwconfig wlan0 rate 2M
* wait till iwconfig reports 2M
* iwconfig wlan0 rate auto
* rate goes up to 54M
* iwconfig wlan0 rate 1M
* wait till iwconfig reports 1M
* iwconfig wlan0 rate auto
* rate goes up to 54M again!

So rate auto seems only broken on 1M when the driver is just loaded!

Edit
To be complete this is on a vanilla 2.6.26 kernel from kernel.org.

Zi7

21-07-2008 08:36:57

Thank you.
It sounds promising. ;)

amadues

21-07-2008 10:00:27

I've tried the technique sverf posted and the card does not ramp up to 54M after forcing to 2M, then auto.

I'm also seeing something different - when the rate is forced to 54M i can associate fine at 54M. Initially (for the first 10 seconds) I can max out my internet connection at ~ 6 Mbps. After this, throughput in both directions drops to about 400 kbps, even though the card remains associated at 54 Mbps. Latency between the rt2500 card and my access point also increases to 200-300 ms when I sustain 400 kbps of traffic. After some time, packet loss increases to 80+% and the connection becomes unusable until the rt2500pci kernel module is reloaded.

If i leave the iwconfig rate at 1 Mbps, download throughput is consistently 1 Mbps and latency to the access point stays at around 14 ms.

With the same card and access point, I can consistently obtain 6+ Mbps speeds and 1-2 ms latency using a windows or FreeBSD driver.

Is there anything i can do to provide more debug or troubleshooting information? I am running kernel 2.6.26, vanilla from kernel.org.

sverf

21-07-2008 10:03:48

Something I didnt state yet is that I do have to generate some traffic before the speed goes up, like refreshing a web page a couple of times.

AdamBaker

21-07-2008 19:54:00

Consistent behaviour between different users is not expected unless they are using APs running similar firmware. Each end of an 802.11 link controls it's own Tx speed based on acknowledges it receives and other parameters chosen by the authors of the rate control code. Different APs also provide different levels of access to that info.

Zi7

21-07-2008 21:34:37

Although your remark sounds wise, Adam, i actually do expect consistent behavior in this case ([i3sp8jc6s]i.e.[/i3sp8jc6s] relatively to the interface-stuck-at-initial-rate issue), provided a few key variables (like experimental protocol or distance to AP) remain reasonably consistent too.
The max rate and max throughput achieved may vary, but my point for now is whether 'auto' is able to move the rate upward or not.
Please don't refrain from following sverf protocol closely and sharing your results.

ariveira

29-08-2008 13:04:05

I tried 2.6.27-rc5 and rt2500pci works like 2.6.25 again and i can use my
connection at full speed thanks

D

Acesabe

27-11-2008 16:55:13

Has there been any developments with this bug recently? Running the very latest 2.6.27-7mepis1 kernel (and the preceding 2.6.26/7 kernels) in the latest Mepis beta (7.9.9x) with my rt2500 pcmcia card, the default speed is still 1Mb/s, unless it is manually defined in a config. My wireless router also drops its wireless interface much more frequently when using the rt2x00 - but perhaps that is un-related. I have searched extensively but can only find reports of this issue and workarounds. Surely the fix - if there is any - would have made it to the latest kernel??

maxmax

26-12-2008 13:28:40

Hello,
it seems that this problem still exists. Should this actually be fixed in mainline already?

Here the kernel bug
http//bugzilla.kernel.org/show_bug.cgi?id=9273

And the Ubuntu Bug
https//bugs.launchpad.net/ubuntu/+sour ... bug/190515

Any Chance of seeing this fixed with 2.6.29? Thanks in advance!
maxmax

scifi

29-12-2008 20:23:38

Hello,
it seems that this problem still exists. Should this actually be fixed in mainline already?[/quote3u5axag3]
I am hitting this bug too -(
I am running this kernel (rt73usb, ad-hoc, WEP)
http//git.kernel.org/?p=linux/kernel/g ... 6057242c13
If there is anything I can do to help fix this bug, I'd be happy to do it. Testing, maybe?

dopehouse

08-01-2009 12:01:31

I can confirm this bug in vanilla 2.6.28.

Manual workaround
[code1dzo0osa]
#> iwconfig wlan0 rate 54M
#> iwconfig wlan0 rate fixed
[/code1dzo0osa]
After that, the wlan device is working with full 54Mbit rate again.
(scp kernel package (.bz2) with 2MB/s Transferrate)

Edit I'm using Debian Lenny (just because I was asked by PM)

Erwin1967

18-01-2009 22:14:11

I experience the problem too. Only setting the rate to 54M does not seem to work. I am using Ubuntu 8.10 (64 bit) In the previous version I got it working at full speed (2.8 MB/s down, now 145 KB/s). Is there anything I can do (supply logfiles or something else?)

dopehouse

18-01-2009 22:58:24

I experience the problem too. Only setting the rate to 54M does not seem to work.[/quote3hyp340d]
Only setting the rate to 54M didn't work for me, too. But did you set the rate to fixed after setting it to 54M? There are two commands in my previous post (just if you didn't noticed that ) ).

dopehouse

18-01-2009 23:33:22

Hmm, I don't know if it helps, but I'll post my wireless configuration from the router here. It is a Linksys WRT54G with "DD-WRT v24-sp1 (07/27/08) std" firmware
[list2fsu0rx2]
[*2fsu0rx2]Wireless Mode = AP[/*m2fsu0rx2]
[*2fsu0rx2]Wireless Network Mode = G-Only[/*m2fsu0rx2]
[*2fsu0rx2]Wireless Network Name (SSID) = "blabla"[/*m2fsu0rx2]
[*2fsu0rx2]Wireless Channel = 3 (2.422 GHz)[/*m2fsu0rx2]
[*2fsu0rx2]Wireless SSID Broadcast = Enable[/*m2fsu0rx2]
[*2fsu0rx2]Sensitivity Range (ACK Timing) = 2000[/*m2fsu0rx2]
[*2fsu0rx2]Network Configuration = Bridged
[/*m2fsu0rx2]
[*2fsu0rx2]Security Mode = WPA2 Personal[/*m2fsu0rx2]
[*2fsu0rx2]WPA Algorithms = TKIP+AES[/*m2fsu0rx2]
[*2fsu0rx2]WPA Shared Key = "****"[/*m2fsu0rx2]
[*2fsu0rx2]Key Renewal Interval (in seconds) = 3600
[/*m2fsu0rx2]
[*2fsu0rx2]MAC Filter = Enable
[/*m2fsu0rx2]
[*2fsu0rx2]Authentication Type = Auto[/*m2fsu0rx2]
[*2fsu0rx2]Basic Rate = Default[/*m2fsu0rx2]
[*2fsu0rx2]Transmission Fixed Rate = 54Mbps[/*m2fsu0rx2]
[*2fsu0rx2]CTS Protection Mode = Auto[/*m2fsu0rx2]
[*2fsu0rx2]Frame Burst = Enable
[/*m2fsu0rx2]
[*2fsu0rx2]Beacon Interval = 100[/*m2fsu0rx2]
[*2fsu0rx2]DTIM Interval = 1[/*m2fsu0rx2]
[*2fsu0rx2]Fragmentation Threshold = 2346[/*m2fsu0rx2]
[*2fsu0rx2]RTS Threshold = 2346[/*m2fsu0rx2]
[*2fsu0rx2]Max Associated Clients = 4[/*m2fsu0rx2]
[*2fsu0rx2]AP Isolation = Disable[/*m2fsu0rx2]
[*2fsu0rx2]TX Antenna = Auto[/*m2fsu0rx2]
[*2fsu0rx2]RX Antenna = Auto[/*m2fsu0rx2]
[*2fsu0rx2]Preamble = Long[/*m2fsu0rx2]
[*2fsu0rx2]Shortslot Override = Auto[/*m2fsu0rx2]
[*2fsu0rx2]TX Power = 28 ( * I've used higher values with no success )[/*m2fsu0rx2]
[*2fsu0rx2]Afterburner = Auto[/*m2fsu0rx2]
[*2fsu0rx2]Bluetooth Coexistence Mode = Disable
[/*m2fsu0rx2]
[*2fsu0rx2]Radio Scheduling = Disable
[/*m2fsu0rx2]
[*2fsu0rx2]WMM Support = Enable[/*m2fsu0rx2]
[*2fsu0rx2]No-Acknowledgement = Enable[/*m2fsu0rx2][/listu2fsu0rx2]

Erwin1967

19-01-2009 18:32:59

How did you produce that list? If I use iwlist wlan0 rate

wlan0 unknown bit-rate information.
Current Bit Rate54 Mb/s

This is a bit odd, as if the driver is not capable of seeing the available bitrates and therefore starts with the lowest available....

IvD

19-01-2009 18:48:30

This is a bit odd, as if the driver is not capable of seeing the available bitrates and therefore starts with the lowest available....[/quote3u8kjykt]

That is not true, or at least it is partially true. For starters, the beacon send out by the beacon contains all supported bitrates, the driver will intersect that list with the rates it is capable of itself.
_however_ when starting the connection the bitrate starts at 1Mbs and should scale up depending on the link quality (number of succesfull transmitted frames, number of retries, etc). The problem is in rt2x00 which for some reason is upsetting the rate control module provided by mac80211 and keeps the rate down to 1Mbs.

The reason _why_ this is happening remains unknown, so anybody with ideas or likes to experiment on the driver source code, are welcome to do so.

dopehouse

19-01-2009 21:42:43

How did you produce that list?[/quote3nibb24h]
I've copy and paste the keys and values from the web interface of my router. ;)

scifi

27-04-2009 12:37:11

Hi all!

A few months ago I tried using rt73usb in ad-hoc mode. The fixes for the slow rate problem suggested in this thread didn't work for me. I had to switch back to legacy driver...
Has there been any progress with this bug?

woxorz

10-06-2009 23:35:38

Has anyone found a solution to this yet?
I'm using kernel 2.6.28-11-generic - ubuntu 9.04

I am surprised this hasn't been resolved yet. ? cry

Herr_Raus

07-09-2009 02:18:36

I've had the same issue with Debian Lenny stable. Changing the bit rate didn't really do a thing. Even after setting it to 1M manually, it would still get transfer speeds of 200KBps.
Now I've upgraded to Linux kain 2.6.30-1-amd64 #1 SMP Sat Aug 15 180919 UTC 2009 x86_64 GNU/Linux
and the issues have been resolved for me! I'm getting 20MBps now which is my connection max!

0501.0 Network controller RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

IvD

07-09-2009 02:23:38

For all other users a patch has been committed to rt2x00.git and pushed upstream. So the fix will appear in 2.6.31-stable and 2.6.32 soon.

dopehouse

07-09-2009 02:41:14

That sounds good. I'll test it, as soon as it's released in the stable mainline kernel.

dopehouse

10-09-2009 10:39:31

Is the patch included in the just released stabel 2.6.31 release? Or do we have to wait for .32 if we need a stable kernel release?

IvD

10-09-2009 18:54:30

It has been send to 2.6.32, but I'll try to get the patch into 2.6.31.x as well.

dopehouse

10-09-2009 19:01:53

Thank you for that information and thank you for your work on the driver.

Regards
Florian

foxy123

11-10-2009 21:42:57

Does anyone know if the fix will appear in Karmic any time soon?

IvD

11-10-2009 22:29:54

Does anyone know if the fix will appear in Karmic any time soon?[/quote2gr8lif8]

That is a question you should ask the Karmic developers....

foxy123

23-10-2009 17:21:30

I've come across a kernel bug http//bugzilla.kernel.org/show_bug.cgi?id=13362 which describes exactly what I experience but it doesn't seem to be fixed (

rayvd

25-11-2009 06:04:14

I should probably dig into this myself, but... any idea if this has made it into 2.6.31 yet? I am running Fedora 12 w/ kernel 2.6.31.5-122.fc12.i686 and am seeing some pretty abysmal performance.

[code3n10i3b1]
03:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
[/code3n10i3b1]
[code3n10i3b1]
filename: /lib/modules/2.6.31.5-122.fc12.i686/kernel/drivers/net/wireless/rt2x00/rt2500pci.ko
license: GPL
description: Ralink RT2500 PCI & PCMCIA Wireless LAN driver.
version: 2.3.0
author: http://rt2x00.serialmonkey.com
srcversion: 017B67DDC35630260307788
alias: pci:v00001814d00000201sv*sd*bc*sc*i*
depends: rt2x00pci,rt2x00lib,eeprom_93cx6
vermagic: 2.6.31.5-122.fc12.i686 SMP mod_unload 686
filename: /lib/modules/2.6.31.5-122.fc12.i686/kernel/drivers/net/wireless/rt2x00/rt2x00pci.ko
license: GPL
description: rt2x00 pci library
version: 2.3.0
author: http://rt2x00.serialmonkey.com
srcversion: 3A3EE6AFCFE8A9FFB21B401
depends: rt2x00lib,mac80211
vermagic: 2.6.31.5-122.fc12.i686 SMP mod_unload 686
filename: /lib/modules/2.6.31.5-122.fc12.i686/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko
license: GPL
description: rt2x00 library
version: 2.3.0
author: http://rt2x00.serialmonkey.com
srcversion: 24C93ABCB9EF79294940BB0
depends: mac80211,input-polldev,cfg80211
vermagic: 2.6.31.5-122.fc12.i686 SMP mod_unload 686
[/code3n10i3b1]
[code3n10i3b1]
wlan1 IEEE 802.11bg ESSID:"wireless"
Mode:Managed Frequency:2.422 GHz Access Point: 00:0C:41:CB:C6:8A
Bit Rate=54 Mb/s Tx-Power=26 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:XXXXX
Power Management:off
Link Quality=38/70 Signal level=-72 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code3n10i3b1]
It claims I'm connected at 54Mbps, but I'm only seeing round 80-90KB/sec (kilobytes). Not really seeing any errors in dmesg or syslog other than some power reated ones (which I resolved by doing an iwconfig wlan1 power off).

Edit I shoul note that I am connecting to a WRT54G V2 board running Tomato 1.25. Speeds from a Dell laptop with an on-board intel wireless card are normal.

gwingerde

28-11-2009 09:10:07

No, the patch hasn't been included in 2.6.31 yet.

With the imminent release of 2.6.32 I'm not sure whether that is still appropriate to do.

foxy123

28-11-2009 11:15:27

No, the patch hasn't been included in 2.6.31 yet.

With the imminent release of 2.6.32 I'm not sure whether that is still appropriate to do.[/quote5isrbzcd]

is it already in 2.6.32-rc8

gwingerde

29-11-2009 02:52:26

Yes, the patch is included in 2.6.32-rc8.

scifi

02-12-2009 19:08:42

Hi All,

I am testing the in-kernel rt73 driver for my wireless dongle. The kernel version I'm using is 2.6.32-rc8. I was using the legacy driver previously.
Everything seemed to work fine. But now, after 10 days of uptime, I am getting the old problem of transfer rate resetting to 1 Mbit/s. Disabling automatic rate control (iwconfig wlan0 rate 54M fixed) solves the problem.
This seems like the old problem from many months ago. Just to let people know in case anyone is interested...

foxy123

07-12-2009 22:02:03

I tried 2.6.32 stable and had the same problem as with 2.6.31 (

okias

28-01-2010 11:28:24

2.6.33-rc5-git, same problem. I noticed, when rt2500 card start downloading (20KBps, but should be 200KBps), some other card in network are unable to connect or their download speed decrease. I enabled all wireless/rt2500 debug in kernel, so just tell me, how can I help solve this issue.

email d.okias (a) gmail.com
jabber okias (a) isgeek.info
icq 283-633-094.

Thanks

rayvd

28-01-2010 14:40:14

Things have improved slightly for me (2.6.32.2-18.fc13.i686), but still pretty slow with lotsa glitchy pauses and really can't get over 150-200KB/sec (kilobytes). At least it's useable in a pinch...

4javier

09-02-2010 13:38:19

I can confirm the bug in kernel 2.6.32.7, obtained from archlinux repo.
With kernel 2.6.28 I had no problem.
Now rate is correctly 54M, but doesn't receive more than 60-70Kb/s, with a dsl 8Mbps.

4javier

11-02-2010 11:34:53

2.6.32.8 doesn't solve the problem. (
@IvD
Can't you revert the changes you made from 2.6.28? Or the problem isn't in your code? ?

okias

13-02-2010 11:51:55

So, in AD-HOC mode it work full speed. Only in managed mode connected to ap is problematic.

vitko

07-03-2010 16:10:33

I'm also experiencing rather slow rt2500 connection - download cca 80 kB/s on 4 Mbps ADSL line (on my wired NIC download is over 400 kB/s). Any solution in view?

Debian x64, kernel 2.6.32, module rt2500pci.

Wireless hardware
[code3nz390rf]
$ lspci
...
05:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)[/code3nz390rf]

4javier

07-03-2010 23:46:30

wired
[img1wfbq54i]http://www.speedtest.net/result/740774645.png[/img1wfbq54i][/url1wfbq54i]

wireless
[url=http://www.speedtest.net1wfbq54i][img1wfbq54i]http://www.speedtest.net/result/740779778.png[/img1wfbq54i][/url1wfbq54i]

cry

4javier

12-04-2010 19:55:28

kernel 2.6.33.2
same issue.

vitko

30-06-2010 03:32:21

Right now (kernel 2.6.32, Debian x64) I get download 3,50 Mbps and upload 0,44 Mbps on my 4096/512 kbps ADSL line according to speedtest.net.

vitko

30-06-2010 04:52:49

Update (and bad news) after some time I noticed lags and broken images in viewed pages, three tabs open in Firefox have brought rt2500 to its knees.

I tried speedtest.net again, now download is 0.74 Mbps (only some 20 % of "normal" speed!), upload is still around 0.43 Mbps on ADSL 4096/512. Looks like we are experiencing serious performance deterioration under rather normal workload.

Can anyone else confirm?

pcangelo

28-07-2010 14:17:39

I have installed Slackware 13.1 32/64bit builds and both of them doesn't perform well (kernel 2.6.33.4). The latest stable kernel 2.6.34.1 does the same - very slow wireless connection on a rt2500pci card (MSI54G2).
Before, I have had Slack 11 with 2.6.20.X kernel and serialmonkey STA driver and my regular speed was at least 10x-15x faster than now.
The "rate" option is auto and is set in initialization phase to 1M. I can force it to "54M fixed", but this doesn't change anything.
The "best" I can obtain is on slackupdate the connection could sometimes start at around 70-80K, then it drops to 0, then it could stabilize around 9-15Ko.
(with my old config the same wget operation was around 600Ko-1.5Mo and without any drops in signal or speed)

Are there some dependencies in the kernel to compile to improve the speed and stability of this driver?

vitko

28-07-2010 17:31:49

Bad news / good news Because situation with rt2500 was getting unbearable, I have thrown away my "untrusty" rt2500 based card (Edimax EW-7128G PCI) and acquired a brand new RT2860 based Asus PCE-N13 card (kernel module rt2860sta), it is PCIe 1x IIRC. No problems so far with RT2860, signal quality is much better than with rt2500 and after two weeks I can see none of problems I was experiencing with rt2500.

(I still keep rt2500 card in my system should anyone needed debugging info or had new kernel for testing anyway.)

loic_

31-08-2010 09:15:56

Hello,

Is someone familiar with the driver code is working/is going to work on this issue ? (Ivo ?) Or is it a really tricky problem ?

This card is currently advertised as 'supported' by many linux related website, but with such a low throughput it is far from being usable.

I have this card and I have a few kernel skills, so I can help by providing informations (dumps ?) and testing.

Larcen

12-01-2011 09:16:45

Hi all,

Are there any news about this problem?? I have a RT2500 pci card and I'm experimenting this problem since many time ago (as you know). At the begining I thought that the problem was a temporary bug (I use Debian testing), but now I know that it is a general problem.

At the moment I use the kernel version 2.6.32-5-686, and I've tried to compile the latest driver version from http//linuxwireless.org/, but the problem persists. In my case, the rate is set automatically to 54M, but I have low signal and low transfer (1 Mb). I'm also experimenting another problems, like the disconnection of another wireless devices with Ralink chipset (not RT2500) when the RT2500 one is connected.

Is this problem abandoned, or is there someone still working on it? Any suggestions, like using Ndiswrapper, alternative drivers, especific kernel version, ect?

Greetings, Larcen.

4javier

20-02-2011 14:39:20

D
After many months I tried to plug in again my rt2500 based usb pen...and it works!!! it reaches the same speeds of my wired connection to router 6 Mb/0,6Mb. I'll try later with line less busy (I should reach 8Mb in down). It's just a little bit more unstable than lan, but, hey guys, it's wireless mrgreen
I'm using it just since five minutes, I'll post any issue I'll find (hoping to find not ? )
Archlinux
kernel 2.6.37
Thanks Ivo and everybody else worked on this. D

4javier

22-02-2011 23:22:55

Ok, now I can make my considerations
- bandwith is perfect
- at 2-3 meters from AP, but with a wall in the line, signal strenght is 98%. Excellent
- there are some lags in the connection , not disconnections, just line hanging on. I saw this

EEE 802.11bg ESSID"MyEssid"
ModeManaged Frequency2.412 GHz Access Point Mac-of-my-ap
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry long limit7 RTS throff Fragment throff
Power Managementon
Link Quality=66/70 Signal level=-44 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
[bcbygxicg]Tx excessive retries2 Invalid misc94[/bcbygxicg] Missed beacon0

Any solution?

4javier

26-02-2011 13:57:02

I think this driver caused two kernel panic in 24 hours ?
Next time, 'Ill post backtrace.
Could you tell me if somebody is following this thread or my posts are useless? lol