rt61 ad-hoc

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4739

JoyFM

18-04-2008 17:30:29

Hi,
I'm using linux 2.6.24 is it possible to use ad-hoc modus with the rt61 driver?

Thanks for answers ;)

P.S. If it is support i'll post my error messages (currently no network to test)

IvD

18-04-2008 20:07:32

Not with the in-kernel version, you need the legacy drivers (or use the wireless-compat package from linux-wireless.org which contains an updated rt2x00 version).

JoyFM

19-04-2008 18:15:33

hmm... will it be fixed with the 2.6.25 kernel?

IvD

19-04-2008 18:18:48

no, it has been enabled for 2.6.26 but I lack any form of test reports about it at this time.

cpcp

19-04-2008 21:20:55

I am having the same problem. I just downloaded and compiled wireless-compat but I still can't get ad-hoc

[code1jma02c2]sudo iwconfig wlan0 mode ad-hoc
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Device or resource busy.
[/code1jma02c2]

This is with a WMP54G card. What did I get wrong?

IvD

19-04-2008 21:46:00

Make sure the interface is down when changing mode.

cpcp

20-04-2008 12:26:54

Thanks, that works... however, after I bring the interface up again, the system absolutely locks-up a couple of seconds later. I've tried 4 times thus far and it's happening reliably.

I am using the ubuntu Hardy RC, so I'm not sure if it's a problem with the driver or some component of Hardy. I don't see anything interesting in /var/log/messages. Any tips on further diagnostic?

AdamBaker

20-04-2008 20:32:18

Are you able to work at a text console rather than a GUI (i.e ctrl-alt-f1) just before it locks up, if so do you see a panic message with a call trace? If so it would be helpful to see the content of that trace. If you can set it up a serial capture on another PC is ideal but if not a photo of the screen is often enough to capture some useful info.

cpcp

20-04-2008 21:20:22

No luck. Tried without even starting the X server - it still freezes completely right after bringing wlan0 up. No messages or even beeps.

I guess I should note that I am running the 64-bit version of Hardy - could that be the culprit?

Rufnut

21-04-2008 07:53:48

Hi,
I'm using linux 2.6.24 is it possible to use ad-hoc modus with the rt61 driver?
[/quote2gqhlwem]

Hi I have had reasonable success with the compat wireless driver set under 2.6.24

http//linuxwireless.org/en/users/Drivers

http//linuxwireless.org/download/compat-wireless-2.6/

just download the latest daily tarball in the download area and read the instructions , although they are external to the kernel and beta drivers, they do install and uninstall in my gentoo kernel very easy.
The daily driver in my case was dated 20-04-2008 , this is currently working in adhoc as shown below.

not sure about wpa supplicant but they may be worth a try.

I have a few machines around with wifi and 2 have rt61 cards
One machine is running a 2.6.23 kernel with ralinks own 1.1.1.0 linux drivers, the other is configured as above as I cannot get the ralink drivers to compile on 2.6.24

Some test results from the
[code2gqhlwem]
rt61pci 24192 0
crc_itu_t 2176 1 rt61pci
rt2x00pci 10368 1 rt61pci
rt2x00lib 24960 2 rt61pci,rt2x00pci
firmware_class 9728 2 snd_emu10k1,rt2x00lib
rfkill 7056 1 rt2x00lib
input_polldev 5000 1 rt2x00lib
mac80211 162716 2 rt2x00pci,rt2x00lib
cfg80211 28896 2 rt2x00lib,mac80211
eeprom_93cx6 2560 1 rt61pci
[/code2gqhlwem] machine


[code2gqhlwem]wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
wlan0: Selected IBSS BSSID e2:0a:e5:3f:d5:8b based on configured SSID
wlan0: Configured IBSS beacon template
wlan0: Selected IBSS BSSID e2:0a:e5:3f:d5:8b based on configured SSID
wlan0: Configured IBSS beacon template
wlan0: no IPv6 routers present
phy0: Adding new IBSS station 00:14:85:de:d3:31 (dev=wlan0)
wlan0: Selected IBSS BSSID e2:0a:e5:3f:d5:8b based on configured SSID
wlan0: Configured IBSS beacon template
phy0: Adding new IBSS station 00:14:85:de:d3:31 (dev=wlan0)
wlan0: no IPv6 routers present
[/code2gqhlwem]

This driver setup seems to take a while to join the cell but once it does so seems ok speed and stability wise.

[code2gqhlwem]lo no wireless extensions.

eth1 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"WLAN"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: E2:0A:E5:3F:D5:8B
Tx-Power=4 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:yeah-sure-like-i-am-telling-you-;-)
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

ppp0 no wireless extensions.
[/code2gqhlwem]

[code2gqhlwem]
iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[ 4] local 192.168.0.1 port 5001 connected with 192.168.0.2 port 58748
[ 4] 0.0-10.2 sec 24.5 MBytes 20.2 Mbits/sec
[ 6] local 192.168.0.1 port 5001 connected with 192.168.0.2 port 58749
[ 6] 0.0-10.1 sec 25.4 MBytes 21.0 Mbits/sec
[ 4] local 192.168.0.1 port 5001 connected with 192.168.0.2 port 58750
[ 4] 0.0-10.2 sec 26.2 MBytes 21.7 Mbits/sec
[/code2gqhlwem]

[code2gqhlwem]
iperf -c 192.168.0.2
------------------------------------------------------------
Client connecting to 192.168.0.2, TCP port 5001
TCP window size: 16.0 KByte (default)
------------------------------------------------------------
[ 3] local 192.168.0.1 port 60089 connected with 192.168.0.2 port 5001
[ 3] 0.0-10.1 sec 20.1 MBytes 16.7 Mbits/sec
rufnut rufnut # iperf -c 192.168.0.2
------------------------------------------------------------
Client connecting to 192.168.0.2, TCP port 5001
TCP window size: 16.0 KByte (default)
------------------------------------------------------------
[ 3] local 192.168.0.1 port 60090 connected with 192.168.0.2 port 5001
[ 3] 0.0-10.0 sec 20.1 MBytes 16.8 Mbits/sec
[/code2gqhlwem]

I guess the main reason for one side being faster than the other is that in the ralink driver (the other machine) I have the turbo function on.

Most important of all for some, from /etc/conf.d/net (maybe different on yr distro)

[code2gqhlwem]
channel_wlan0="1"
mode_wlan0="Ad-Hoc"
essid_wlan0="WLAN"
key_WLAN="yeah-sure-like-i-am-telling-you-;-) enc open"
config_wlan0=( "192.168.0.1 netmask 255.255.255.0" )
iwconfig_wlan0="txpower on"
[/code2gqhlwem]

A lot of good people have battled to bring this result, thanks guys


regards Brett
-)

LeoNerd

05-05-2008 21:09:27

Not with the in-kernel version, you need the legacy drivers (or use the wireless-compat package from linux-wireless.org which contains an updated rt2x00 version).[/quote24zc27gl]

I can confirm limited success with the latest git kernel source. I checked out that and built it

[code24zc27gl] root@erf:~
# uname -r
2.6.25-rc9.erf-wl[/code24zc27gl]
It manages to put the card into ad-hoc mode just fine

[code24zc27gl] root@erf:~
# iwconfig wireless
wireless IEEE 802.11 ESSID:"leoair"
Mode:Ad-Hoc Frequency:2.432 GHz Cell: D2:79:9A:3F:0C:99
Tx-Power=2 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0[/code24zc27gl]
It doesn't appear in its own scan list - I'm not sure if that's expected or not? I noticed the first time I switched it into ad-hoc mode it did appear for a short while, then went again. Random artefact? Not sure...

It does however, appear in scan lists on other machines and I did, for a while, manage to establish a connection with it. It kept dropping out every few minutes, before finally giving up all together about 20 minutes after first setting it up. Not sure if to blame the RT61 or the client end yet though.

Still, a sign that it does have hope of working, anyway...

inffu

27-05-2008 11:21:40

Using compat-wireless-2008-05-26 my cards can be configured to the ad-hoc mode but no connection can be established. They seem to be jumping around channels which sometimes can be fixed by setting the channel via iwconfig again and they change cell ids frequently because no active IBSS stations could be found. The last behavior is strange, because a simple iwlist scan reveals the other station is in range.

I hope this will be fixed soon because the txpower setting on it's own makes the switch to rt2x00 appealing.

JoyFM

01-07-2008 19:45:41

Does anybody know anything about the current status of adhoc in linux 2.6.26?

JoyFM

13-07-2008 19:19:32

Hi,
I compiled the compat wireless backports and Ad-hoc works perfectly with 2.6.25 linux )

thank you very much!