random rt73usb deauthentication

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4767

Linkin

01-05-2008 16:54:10

Hi!

My rt73 based usb link loses the authentication to the AP on a random basis and in addition to that it needs several tries to get it to associate again. Mostly because of dhcpcd timing out. I googled for it but have not found anything useful. Is there an error with my AP rejecting or closing the connection?

I'm using kernel 2.6.25. The output of dmesg is

[code2kt0tvwg]
wlan0: RX deauthentication from 00:04:0e:86:5b:e0 (reason=2)
wlan0: deauthenticated
wlan0: authenticate with AP 00:04:0e:86:5b:e0
wlan0: RX authentication from 00:04:0e:86:5b:e0 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:04:0e:86:5b:e0
wlan0: RX ReassocResp from 00:04:0e:86:5b:e0 (capab=0x411 status=0 aid=1)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:04:0e:86:5b:e0)
wlan0: No ProbeResp from current AP 00:04:0e:86:5b:e0 - assume out of range
wlan0: RX deauthentication from 00:04:0e:86:5b:e0 (reason=2)
wlan0: deauthenticated
usbcore: deregistering interface driver rt73usb
phy4: Selected rate control algorithm 'pid'
usbcore: registered new interface driver rt73usb
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:04:0e:86:5b:e0
wlan0: authenticate with AP 00:04:0e:86:5b:e0
wlan0: authenticate with AP 00:04:0e:86:5b:e0
wlan0: authentication with AP 00:04:0e:86:5b:e0 timed out
usbcore: deregistering interface driver rt73usb
phy5: Selected rate control algorithm 'pid'
usbcore: registered new interface driver rt73usb
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:04:0e:86:5b:e0
wlan0: RX authentication from 00:04:0e:86:5b:e0 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:04:0e:86:5b:e0
wlan0: RX AssocResp from 00:04:0e:86:5b:e0 (capab=0x411 status=0 aid=1)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:04:0e:86:5b:e0)
wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=2 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=2 cWmin=3 cWmax=7 burst=15
wlan0: association frame received from 00:04:0e:86:5b:e0, but not in associate state - ignored
wlan0: association frame received from 00:04:0e:86:5b:e0, but not in associate state - ignored
wlan0: association frame received from 00:04:0e:86:5b:e0, but not in associate state - ignored
wlan0: No ProbeResp from current AP 00:04:0e:86:5b:e0 - assume out of range
[/code2kt0tvwg]

Thanks for your help.