Rate problems

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4793

pchristy

14-05-2008 11:14:39

I'm running a Belkin F5D7010 (rt2500) pcmcia card on a laptop running Slamd64 (64 bit port of Slackware).

Until recently, I've always used the legacy drivers, as I've found them much more consistent and reliable than the 2x series. However, when I upgraded to kernel 2.6.25, I had problems getting them to work - in fact I couldn't get them to work!

So I compiled the kernel using the built-in rt2x00 drivers. After a little bit of fiddling with the configuration files, these are now working reliably, BUT the rate is stuck solidly at 1 MB/s, regardless of how good the signal is!

I have found several references to this issue in other threads here, but they all seem to imply that it will be fixed when 2.6.25 comes out! Well, I'm running 2.6.25, and it isn't fixed!

Are there any updates on fixes or workarounds for this problem? Since it appears to be a common problem, perhaps we can gather all the information into a single thread to make it easier to find?

All suggestions for a fix gratefully received!

blitzer

14-05-2008 13:06:01

I'm running a Belkin F5D7010 (rt2500) pcmcia card on a laptop running Slamd64 (64 bit port of Slackware).

Until recently, I've always used the legacy drivers, as I've found them much more consistent and reliable than the 2x series. However, when I upgraded to kernel 2.6.25, I had problems getting them to work - in fact I couldn't get them to work!

So I compiled the kernel using the built-in rt2x00 drivers. After a little bit of fiddling with the configuration files, these are now working reliably, BUT the rate is stuck solidly at 1 MB/s, regardless of how good the signal is!

I have found several references to this issue in other threads here, but they all seem to imply that it will be fixed when 2.6.25 comes out! Well, I'm running 2.6.25, and it isn't fixed!

Are there any updates on fixes or workarounds for this problem? Since it appears to be a common problem, perhaps we can gather all the information into a single thread to make it easier to find?

All suggestions for a fix gratefully received![/quote1e4yzdr8]

Hi,
did you read my post from yesterday?
I also tried the rt2x00 drivers for the first time and a work-around that worked for me was the root-command "iwconfig wlan0 rate 54M", while the 1mbps-connection was established. I don't know, if this behavior is a bug or a feature.
Another very small flaw seems to be, that the activity-led of the pcmcia-card isn't blinking - only the link-led is on. I don't worry about, but is this the same with your card, just for interest?

greet

pchristy

15-05-2008 10:06:57

That's why it seemed to me to be a good idea to pull all this together into one thread! wink

Slamd64 (and Slackware, from which it is derived) use scripts to initialise network connections, and these call things like ifconfig and iwconfig, inserting the appropriate parameters from the scripts.

I tried calling iwconfig to set the rate - as you described - and it worked!

So next I went back to look at the scripts. Normally I used to leave the RATE command commented out, as the legacy driver didn't like it. I tried using the default rate setting of "54M auto", and again it stuck at 1 MB. However, deleting the "auto" got it working correctly at 54 MB!

Whether it will automatically reduce the rate as the signal deteriorates remains to be seen, but at least its working at full chat in its normal location.

To summarise, it doesn't like having no rate set (in contrast to the legacy driver) and it doesn't like "auto" - either of these will make it default to 1M!

Regarding the blinking leds, yes mine do blink, but the opposite way round to what I would expect!

There are two leds, one with a wireless symbol (something like ((i)) ) and a network symbol (something like -I= ). When it is communicating, it is the wireless symbol that blinks, not the network one, but at least one of them does blink!

Hope this helps!

blitzer

15-05-2008 22:51:47

That's why it seemed to me to be a good idea to pull all this together into one thread! wink

Slamd64 (and Slackware, from which it is derived) use scripts to initialise network connections, and these call things like ifconfig and iwconfig, inserting the appropriate parameters from the scripts.

I tried calling iwconfig to set the rate - as you described - and it worked!

So next I went back to look at the scripts. Normally I used to leave the RATE command commented out, as the legacy driver didn't like it. I tried using the default rate setting of "54M auto", and again it stuck at 1 MB. However, deleting the "auto" got it working correctly at 54 MB!

Whether it will automatically reduce the rate as the signal deteriorates remains to be seen, but at least its working at full chat in its normal location.

To summarise, it doesn't like having no rate set (in contrast to the legacy driver) and it doesn't like "auto" - either of these will make it default to 1M!

Regarding the blinking leds, yes mine do blink, but the opposite way round to what I would expect!

There are two leds, one with a wireless symbol (something like ((i)) ) and a network symbol (something like -I= ). When it is communicating, it is the wireless symbol that blinks, not the network one, but at least one of them does blink!

Hope this helps![/quote3hq7pbm8]

Nice to hear that it works with 54M. I tried some rate/auto combinations also and achieved rates higher than 1 mbps, but I dont't know, what I'm doing there exactly, so I stay with 54M (static), which does all I need. I found no solution so far to make the command "iwconfig wlan0 rate 54M" persistent. An entry in the wlan0 section of /etc/network/interfaces "wireless-rate 54M" would be possible, but this option does not work, when the interfaces are managed automagically by network-manager. I don't want to deinstall network-manager at the moment - I begin to like it on a laptop.

Thanks for your additional infos about the LEDs. It is only the power-led, that is on permanently on my conceptronic-card. It goes off, when I stop the network-manager. The other led is always off. Good to hear from you, that it works more or less with other pcmcia-cards.