channel 13 / locale settings

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4811

thorstenhirsch

25-05-2008 10:25:30

Hi,

how can I change the locale settings so that I can use channel 13? When I try to do that, I get an "invalid frequency" error. Also iwlist shows me, that the highest channel available is 11. In the man page of iwconfig I've read, that this limitation results from the locale settings ...but my user space locale settings are correct ("de_DE.utf8"), so I guess that there's also a kernel locale setting ...or the rt2x00 modules have their own locale settings. Anyway, how do I change this setting?

edit Someone in the ubuntuforums.org bought a wireless card with an atheros chipset to solve that problem[/url1wnhebic] ...well, I guess there's a more elegant way. ;)

a-slack

25-05-2008 15:50:45

With kernel <= 2.6.25 pass "ieee80211_regdom=64" parameter to "mac80211" module
[codenjo8ki69]# modprobe mac80211 ieee80211_regdom=64[/codenjo8ki69]
With kernel > 2.6.25 pass "ieee80211_regdom=JP" to "cfg80211" module
[codenjo8ki69]# modprobe cfg80211 ieee80211_regdom=JP[/codenjo8ki69]
[codenjo8ki69]# iwlist wlan0 channel
wlan0 14 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 12 : 2.467 GHz
Channel 13 : 2.472 GHz
Channel 14 : 2.484 GHz
Current Frequency=2.422 GHz (Channel 3)[/codenjo8ki69]

thorstenhirsch

25-05-2008 20:16:38

Thank you very much.

sumsum

14-06-2008 09:31:19

Hey, this is great.
Could someone make it sticky?

thx, sumsum