rt2x00 (rt2500usb) kernel 2.6.25-2 debian WUSBGV4

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4824

dramob

31-05-2008 21:56:49

After numerous hours of trying many suggested HOWTOs, I still can't get a consistent dhclient release using the rt2x00 drivers, specifically rt2500usb. On my previous kernel, 2.6.22-3, I am using this driver Ralink RT2570 usb 802.11g WLAN driver 1.0.0 - CVS 2008010720
and wireless is working.

I had been awaiting the 2.6.24 kernel release to use the rt2x00 drivers, and to no avail.. I recently upgraded to 2.6.25-2 and can associate with the WAP, and everything looks to be in order, until dhclient fails to get a working lease. Even on the 1 in 40 chance I do get a release, it only operates for a minute or so if not just for a couple of seconds, then no ping whatsoever. The output of iwconfig appears OK, and most of the time I can get at least my local WAP on an iwlist scan command. Rarely,I can't get any scan results, but I never get a reliable connection especially as the Link Quality is generally in the 20's. When it is about 40 or above, I can get a DHCP RELEASE, but rthe Link Quality rarely is above 28/100.

I am including all the relevant info from the 2.6.25-2 kernel, and I have the working 2.6.22-3 (legacy rt2570) info available as well.

$uname -a
Linux debian 2.6.25-2-amd64 #1 SMP Tue May 27 124524 UTC 2008 x86_64 GNU/Linux

$lsusb
Bus 002 Device 002 ID 13b1000d Linksys WUSB54G Wireless Adapter

$lsmod |grep rt
rt2500usb 28928 0
rt2x00usb 17792 1 rt2500usb
rt2x00lib 28544 2 rt2500usb,rt2x00usb
crc_itu_t 6656 1 rt2x00lib
parport_pc 34344 0
parport 44848 3 ppdev,parport_pc,lp
firmware_class 14976 1 rt2x00lib
rfkill 12832 1 rt2x00lib
input_polldev 9872 1 rt2x00lib
mac80211 143116 2 rt2x00usb,rt2x00lib

$iwconfig wlan0
wlan0 IEEE 802.11g ESSID"spider"
ModeManaged Frequency2.447 GHz Access Point 0014XXXXXXXX (intentionally concealed)
Bit Rate=11 Mb/s Tx-Power=27 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keyoff
Link Quality=28/100 Signal level=-73 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

$iwlist scan
wlan0 Scan completed
Cell 01 - Address 0014XXXXXXXX (intentionally concealed)
ESSID"spider"
ModeMaster
Channel8
Frequency2.447 GHz ( Channel 8 )
Quality=47/100 Signal level=-73 dBm
Encryption keyoff
Bit Rates1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extratsf=0000002766fa06d0

$dhclient
....
No working leases....
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

$modinfo rt2500usb
filename /lib/modules/2.6.25-2-amd64/kernel/drivers/net/wireless/rt2x00/rt2500usb.ko
license GPL
description Ralink RT2500 USB Wireless LAN driver.
version 2.0.14
author http//rt2x00.serialmonkey.com
srcversion B6FAD2276661E5EE4C6D227

A copy of my /etc/network/interfaces file

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Wired network interface
#allow-hotplug wlan0
#iface eth0 inet dhcp

# Primary network interface, wlan0 (wireless)

iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up ifconfig wlan0 down
pre-up ifconfig wlan0 up
pre-up iwlist wlan0 scan
pre-up iwconfig wlan0 mode managed
pre-up iwconfig wlan0 essid spider
wireless-essid spider
pre-up ifconfig wlan0 up
auto wlan0

I would greatly appreciate any direction in to maybe a misconfiguration or guidance toward a resolution as I have been using the legacy driver since January with no encryption. I couldn't seem to ever get the WPA/TKIP to take in all the configuration prior.

dramob

08-06-2008 17:07:46

I still have not solved this problem. If anyone can assist, it would be much appreciated.

IvD

08-06-2008 17:17:48

Please try latest rt2x00.git.