rt2500pci git HEAD Device fails to enter state 5

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4826

Hazzl

01-06-2008 20:35:32

Hi,

I'm unable to do scans with recent git HEAD (commit e4a0e3e and above). In fact, I'm unable to complete an ifconfig wlan0 up. In the kernel log I find the following errors

[quote959ufs1h]
[ 20.649258] phy0 -> rt2500pci_validate_eeprom EEPROM recovery - MAC 0a72e1d8ecaf
[ 20.649263] phy0 -> rt2500pci_validate_eeprom EEPROM recovery - Antenna 0x0002
[ 20.649268] phy0 -> rt2500pci_validate_eeprom EEPROM recovery - NIC 0xfff0
[ 20.649273] phy0 -> rt2500pci_validate_eeprom EEPROM recovery - Calibrate offset 0xff79
[ 20.649279] phy0 -> rt2x00_set_chip Info - Chipset detected - rt 0201, rf 0000, rev 00000004.
[ 20.655741] phy0 Selected rate control algorithm 'pid'
[ 30.517743] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
[ 30.517840] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
[ 33.417737] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
[ 33.417749] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
[ 50.688363] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
[ 50.688424] phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
[/quote959ufs1h]

I'm not sure whether this is an improvement from the situation of not being able to associate with my AP for unknown reasons, but at least I'm seeing some change ;-)

Bye Hazzl

IvD

01-06-2008 21:31:48

Thanks for the report, I seem to have broke something with a very recent commit, fix commited to rt2x00.git
(patch rt2x00 Fix compile-time ffs calculation macros.)

ebrookhouse

05-06-2009 23:16:42

Hi All,

I just pulled a fresh copy with git, compiled against 2.6.30-rc6-wl, and I see a similar message.

When you say that the fix has been comitted to rt2x00.git, did I use git incorrectly to get that fix, or is this different?

Any thoughts appreciated.

Edward

I used git fetch git//git.kernel.org/pub/scm/linux/kern ... rt2x00.git
then git merge master
then built the kernel and booted it

On mod load I see

rt2500pci 00000109.0 PCI INT A -> Link[APC1] -> GSI 16 (level, low) -> IRQ 16
Registered led device rt2500pci-phy0radio
Registered led device rt2500pci-phy0quality
cx88[0]/1 CX88x/0 ALSA support for cx2388x boards
kjournald starting. Commit interval 5 seconds
kjournald starting. Commit interval 5 seconds
RPC Registered udp transport module.
RPC Registered tcp transport module.
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16) .
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16) .
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16) .

ebrookhouse

05-06-2009 23:19:59

When I attempt to up the interface (wlan0)

I get

phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state Error - Device failed to enter state 4 (-5).

IvD

06-06-2009 08:07:00

Does the card work on Windows or has it worked with the driver as released by Ralink?

ebrookhouse

06-06-2009 18:21:07

Yes, it was previously running fine until moving to Fedora 10. I used NDISwrapper and the older rt2500 drivers last time.

majuterus

04-08-2009 15:10:20

Same here, on Gentoo linux with git-sources-2.6.31_rc above or vanilla-sources-2.6.30.2 above.