Fedora 9 and rt2500 PCMCIA card

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4911

birger

24-07-2008 21:32:05

I have a Gigabyte card that presents itself to fedora 9 (2.6.25.10) like this when I plug it in

[code10i4pltr]Jul 24 23:01:36 qxz kernel: cs: pcmcia_socket0: unable to apply power.
Jul 24 23:01:37 qxz kernel: pccard: CardBus card inserted into slot 0
Jul 24 23:01:37 qxz kernel: PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
Jul 24 23:01:37 qxz kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [C141] -> GSI 11 (level, low) -> IRQ 11
Jul 24 23:01:37 qxz kernel: Registered led device: rt2500pci-phy6:radio
Jul 24 23:01:38 qxz NetworkManager: <info> wlan0: Device is fully-supported using driver 'rt2500pci'.
Jul 24 23:01:38 qxz NetworkManager: <info> wlan0: driver supports SSID scans (scan_capa 0x01).
Jul 24 23:01:38 qxz NetworkManager: <info> Found new wireless (802.11) device 'wlan0'.
Jul 24 23:01:38 qxz NetworkManager: <info> (wlan0): exported as /org/freedesktop/Hal/devices/net_00_1d_7d_3e_fc_7d_0
Jul 24 23:01:42 qxz NetworkManager: <info> (wlan0): device state change: 1 -> 2
Jul 24 23:01:42 qxz NetworkManager: <info> (wlan0): bringing up device.
Jul 24 23:01:42 qxz kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 24 23:01:42 qxz NetworkManager: <info> (wlan0): preparing device.
Jul 24 23:01:42 qxz NetworkManager: <info> (wlan0): deactivating device.
Jul 24 23:01:42 qxz NetworkManager: <info> (wlan0): device state change: 2 -> 3
Jul 24 23:01:43 qxz NetworkManager: <info> (wlan0): supplicant interface state change: 1 -> 2.[/code10i4pltr]

If I disconnect my wired network and let NetworkManager try to bring up a connection I get this
[code10i4pltr]
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) starting connection 'Auto Wireless'
Jul 24 23:24:15 qxz NetworkManager: <info> (wlan0): device state change: 3 -> 4
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jul 24 23:24:15 qxz NetworkManager: <info> (wlan0): device state change: 4 -> 5
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0/wireless): connection 'Auto Wireless' requires no security. No secrets needed.
Jul 24 23:24:15 qxz NetworkManager: <info> Config: added 'ssid' value 'Wireless'
Jul 24 23:24:15 qxz NetworkManager: <info> Config: added 'scan_ssid' value '1'
Jul 24 23:24:15 qxz NetworkManager: <info> Config: added 'key_mgmt' value 'NONE'
Jul 24 23:24:15 qxz NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jul 24 23:24:15 qxz NetworkManager: <info> Config: set interface ap_scan to 1
Jul 24 23:24:15 qxz NetworkManager: <info> (wlan0): supplicant connection state change: 1 -> 2
Jul 24 23:24:16 qxz NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 3
Jul 24 23:24:36 qxz NetworkManager: <info> (wlan0): supplicant connection state change: 3 -> 0
Jul 24 23:24:36 qxz NetworkManager: <info> (wlan0): supplicant connection state change: 0 -> 2
Jul 24 23:24:37 qxz NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 3
Jul 24 23:24:40 qxz NetworkManager: <info> Activation (wlan0/wireless): association took too long, failing activation.
Jul 24 23:24:40 qxz NetworkManager: <info> (wlan0): device state change: 5 -> 9
Jul 24 23:24:40 qxz NetworkManager: <info> Activation (wlan0) failed for access point (Wireless)
Jul 24 23:24:40 qxz NetworkManager: <info> Marking connection 'Auto Wireless' invalid.
Jul 24 23:24:40 qxz NetworkManager: <info> Activation (wlan0) failed.
Jul 24 23:24:40 qxz NetworkManager: <info> (wlan0): device state change: 9 -> 3
Jul 24 23:24:40 qxz NetworkManager: <info> (wlan0): deactivating device.
Jul 24 23:24:40 qxz NetworkManager: <WARN> remove_network_cb(): Couldn't remove network from supplicant interface: The requested network does not exist..[/code10i4pltr]

please provide me some advise on what to try next...

birger

25-07-2008 05:07:33

I had another laptop that needed reinstall, so I installed it from a Fedora 9 DVD (2.6.25-14 kernel). I inserted the card, and it worked!

I then used the wireless connection to update fedora, and got the 2.6.25.10-86 kernel. Rebooted, and no more wireless card.

Rebooted the same installation using the old kernel and wireless is back!

I'll just have to go hunting for the last working kernel, then.