rt73usb: setting preamble/short timeslot?

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4940

kompletebastard

08-08-2008 00:07:51

What is the supopred method of getting/setting the state of this settings?
I am using hostapd with and rt73usb on an ARM micro

When starting hostapd I get the following output so I can't change them in hostapd.conf!

root/root# hostapd /etc/hostapd/hostapd.conf
Configuration file /etc/hostapd/hostapd.conf
Failed to update rate sets in kernel module
Could not set passive scanning Unknown error -1
Mode IEEE 802.11g Channel 10 Frequency 2457 MHz
Failed to set CTS protect in kernel driver
Failed to set Short Slot Time option in kernel driver
Could not set preamble for kernel driver
Using interface wlan0 with hwaddr 002129655152 and ssid 'ibright-ap'
Failed to set CTS protect in kernel driver
Failed to set Short Slot Time option in kernel driver
Could not set preamble for kernel driver

It seems that there are no private ioctls to set these.

Any ideas?

IvD

08-08-2008 18:13:15

Sounds like you are not using the latest git snapshot of hostapd.
Use the search button on this forum to find requirements of running master mode.