Deb 3.0: rt2500pci card (1814:0201) will not negotiate w/ AP

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4992

jynx

14-09-2008 09:04:15

I have a Belkin PCI card which I believe has a rt2500pci chipset. I had a pair of them and I've used the other with ndiswrapper and rt2500.sys (I'm afraid I can't recall the source of the driver file).

I'd like to get it working with the new rt2x00 driver, and checked out IvD's repository last night. Before that I had tried the latest from kernel.org, 2.6.26.5. The machine, which is running Sarge, is slow so it only finished compiling this morning. I tried it and it didn't work, so I recompiled the module with debug turned on and rebooted.

With all three kernel set-ups, whenever I try to bring wlan0 up, I get

[code1wfzmuzt]
ADDRCONF(NETDEV_UP) wlan0
link not ready
[/code1wfzmuzt]

I'm using wireless-tools version 20.

[code1wfzmuzt]iwlist wlan0 scan[/code1wfzmuzt] always works when wlan0 is up, and shows my AP.

I've tried manual configuration with
[code1wfzmuzt]
# ifconfig wlan0 up
# iwconfig wlan0 channel 4
# iwconfig wlan0 essid NETGEAR
# iwpriv wlan0 set AuthMode=WPAPSK
# iwpriv wlan0 set EncrypType=TKIP
# iwpriv wlan0 set WPAPSK="password"
# ifconfig wlan0 10.0.0.12
[/code1wfzmuzt]
all the iwpriv commands give the message "no private ioctls"



The output of lspci -nvv -s0d is
[code1wfzmuzt]
0000:00:0d.0 0280: 1814:0201 (rev 01)
Subsystem: 1799:700a
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64, Cache Line Size: 0x08 (32 bytes)
Interrupt: pin A routed to IRQ 10
Region 0: Memory at ff002000 (32-bit, non-prefetchable) [size=8K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
[/code1wfzmuzt]

The configuration in /etc/network/interfaces is
[code1wfzmuzt]
auto wlan0
iface wlan0 inet static
pre-up /sbin/ifconfig wlan0 up
pre-up /usr/local/sbin/iwlist wlan0 scan
pre-up /usr/local/sbin/iwconfig wlan0 ap 00:14:6C:AD:F5:3C
pre-up /sbin/ifconfig wlan0 down
# tried both with and without ^this line, result is the same.
address 10.0.0.12
gateway 10.0.0.2
netmask 255.255.255.0
broadcast 10.0.0.255
wireless_essid NETGEAR
wireless_mode Managed
wireless_channel 4
[/code1wfzmuzt]

The configuration in /etc/wpa_supplicant.conf is
[code1wfzmuzt]
ctrl_interface=/var/run/wpa_supplicant
network={
ssid="NETGEAR"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP CCMP
group=TKIP CCMP
psk="password"
}
[/code1wfzmuzt]

The configuration in /etc/default/wpasupplicant is
[code1wfzmuzt]
# /etc/default/wpasupplicant

# WARNING! Make sure you have a configuration file!

ENABLED=1

# Useful flags:
# -D <driver> Wireless Driver
# -i <ifname> Interface (required, unless specified in config)
# -c <config file> Configuration file
# -d Debugging (-dd for more)
# -w Wait for interface to come up

OPTIONS="-w -i wlan0 -D wext"
[/code1wfzmuzt]

adding -d and -dd did not give anything extra, so I guess it's not getting that far.

Messages in dmesg containing "rt2", case insensitive
[code1wfzmuzt]
rt2500pci 0000:00:0d.0: PCI INT A -> Link[LNKA] -> GSI 10 (level, low) -> IRQ 10
phy0 -> rt2500pci_validate_eeprom: EEPROM recovery - NIC: 0xfff0
phy0 -> rt2x00_set_chip: Info - Chipset detected - rt: 0201, rf: 0003, rev: 00000004.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs: 2, TXop: 0.
[/code1wfzmuzt]

I guess I should think about how to compile the kernel on my 64-bit machine running Etch to use on the slower machine.

Am I missing something, or is this broken in the kernel? Anyone else using this device?

jynx

14-09-2008 10:12:37

Just found this http//www.uwsg.iu.edu/hypermail/linux/ ... /2891.html
will see if it's relevant.

jynx

14-09-2008 10:23:41

Made the following change after re-reading the FAQ, but the network card seems to not work in the same way.

[code3twx5u0p]...
pre-up /usr/local/sbin/iwlist wlan0 scan
pre-up /usr/local/sbin/iwconfig wlan0 channel 4
pre-up /usr/local/sbin/iwconfig wlan0 ap 00:14:6C:AD:F5:3C
...[/code3twx5u0p]

a-slack

14-09-2008 17:32:48

I have a rt2500pci working in debian testing with kernel 2.6.26 and it works well.

[b3uqkodwr]/etc/network/interfaces[/b3uqkodwr] for Open AP
[code3uqkodwr]auto wlan0
iface wlan0 inet static
wireless-channel <channel number>
wireless-essid "the ESSID"
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1[/code3uqkodwr]

######################

[b3uqkodwr]/etc/network/interfaces[/b3uqkodwr] for WEP
[code3uqkodwr]auto wlan0
iface wlan0 inet static
wireless-key <HEXADECIMAL key>
wireless-channel <channel number>
wireless-essid "the ESSID"
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1[/code3uqkodwr]

######################

With WPA wpa_supplicant application is mandatory, two examples

[b3uqkodwr]/etc/network/interfaces[/b3uqkodwr] for WPA-PSK/TKIP
[code3uqkodwr]auto wlan0
iface wlan0 inet static
#wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1[/code3uqkodwr][b3uqkodwr]AND[/color3uqkodwr] /etc/wpa_supplicant.conf[/b3uqkodwr]
[code3uqkodwr]# WPA-PSK/TKIP

ctrl_interface=/var/run/wpa_supplicant

network={
ssid="the ESSID"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="top secret password"
}[/code3uqkodwr]

---------------------------------------------

[b3uqkodwr]/etc/network/interfaces[/b3uqkodwr] for WPA2-PSK/CCMP
[code3uqkodwr]auto wlan0
iface wlan0 inet static
#wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1[/code3uqkodwr][b3uqkodwr]AND[/color3uqkodwr] /etc/wpa_supplicant.conf[/b3uqkodwr]
[code3uqkodwr]# WPA2-PSK/CCMP

ctrl_interface=/var/run/wpa_supplicant

network={
ssid="the ESSID"
proto=WPA2
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
psk="top secret password"
}[/code3uqkodwr]
I am using last example and it works well, there is a problem with the bitrate (starts at 1 Mbps and needs manual change with iwconfig wlan0 rate <other rate>) but that is a mac80211 issue.

jynx

14-09-2008 20:46:20

Thanks. Will give this a try.