Again strange problem with rt73usb driver with a little load

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4995

laforge

14-09-2008 22:49:19

Hi guys,
i'm here again about a problem with the rt73usb driver. With a traffic near 1mbits the driver fails and last link with the access point.
During the problem the kernel send a lot of messages
Sep 15 002116 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -71.
Sep 15 002116 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x308c with error -71.
Sep 15 002117 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x30c0 with error -71.
Sep 15 002117 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x30c4 with error -71.
Sep 15 002117 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x07 failed for offset 0x308c with error -71.
Sep 15 002117 dubhe kernel phy1 -> rt2x00usb_vendor_request Error - Vendor Request 0x06 failed for offset 0x308c with error -71.

The only way to restart the usb dongle is to put down the interface, remove the driver modules (rmmod...), disconnect the usb dongle and reconnect it.
But after this procedure, when i connect to an access point and start to download something the connection goes down when i reach the 1mbit of traffic.
I wrote about the same problem in the past on this blog.

I have resolved the problem by change a long usb cable. But now i have the same problem with a a short cable.

The usb dongle now is a Linksys WUSB54GR connected on a usb hub with a 2 meters cable.
I use a vanilla kernel version 2.6.25.16 without any patch.

There is a solution about this problem ?