iwconfig with Kernel 2.6.26(.3) doesn´t work anymore

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4996

ManuelSahm

15-09-2008 14:41:16

Hello,
I have a problem with the rt25xx Driver which is included in thec linux kernel.
I uses a gigabyte usb stick.
I uses the wireless tools Version 0.29 to configure the usb wlan stick.
I have an linksys router without encryption with ip 192.168.10.1
I have enabled the new mac80211 support in the kernel.
With version 2.6.25.10 all works fine; with Version 2.6.26(.3) it doesn´t work anymore...?

If I type
[code3g5nr0lh]
iwconfig wlan0 essid "obid"
ifconfig wlan0 192.168.10.10
[/code3g5nr0lh]
my usb stick doesn't connect to my AccessPoint anymore ?

With Kernel Version 2.6.25.10 all works fine...

Could anybody help me ?

Thanks

IvD

15-09-2008 14:58:41

IMPORTANT READ BEFORE POSTING!!![/url1kqu3ukp]

Your problem description misses almost all information which could be considered as usefull for providing assistance.

ManuelSahm

16-09-2008 06:32:00

I have added the information in my first post.

Anybody who has the same problems with kernel 2.6.26(.3) ?

Thanks

ManuelSahm

16-09-2008 08:53:05

I always get the output

[code2pr65u3y]phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 4, CWmax: 10, Aifs:2.
phy6 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 4, CWmax: 10, Aifs:2.[/code2pr65u3y]


And nothing happens....

With rt73usb - it seems to work...

Thanks very much for helping me

IvD

16-09-2008 18:15:13

iwconfig wlan0 ap <BSSID address>
is mandatory to start an association.

Since your log doesn't indicate any attempts to associate, I bet that you didn't perform a scan, and you didn't use the ap command

poloskin

23-09-2008 14:50:13

ManuelSahm,

can you see your Access Point issuing "iwlist wlan0 scan"?

dj_def

23-09-2008 22:29:58

On my system (with rt2561) the authentication (sudo iwconfig wlan0 ap xxxx....) with my access point works only the first time, then I need to restart the PC (because of the time out error).
This happens with 2.6.26 and 2.6.26.5 kernels, not with the 2.6.24 and not with the 2.6.27-rc6-wl (even if this gives me other errors like "Failed to register rfkill handler" or that of CRDA).

ManuelSahm

24-09-2008 06:29:21

[quote1sjvpaco]This happens with 2.6.26 and 2.6.26.5 kernels, not with the 2.6.24 and not with the 2.6.27-rc6-wl (even if this gives me other errors like "Failed to register rfkill handler" or that of CRDA).[/quote1sjvpaco]

This is the same thing that I mentioned - but why does it work with 2.6.25.x and not with 2.6.26.x ?

With 2.6.27-rc6 it works too....

dj_def

24-09-2008 07:53:06

I think they changed something in the code.