wireless problem with FC9

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5007

naveedmurtuza

24-09-2008 01:38:28

Hi,

I am Linux newbie and i am having problems with my wireless card (rt61pci) . Its getting disconnected every 5 mins and when connected the internet is very slow.

the drivers i am using came out-of-the-box with fedora 9..

Here is some info abt my box


[code2t2m4kqh]
[root@localhost ~]# uname -r
2.6.25-14.fc9.i686
[/code2t2m4kqh]

[code2t2m4kqh]
[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:02.0 Display controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
01:04.0 Network controller: RaLink RT2561/RT61 rev B 802.11g
[/code2t2m4kqh]

[code2t2m4kqh]
[root@localhost ~]# ifconfig

wlan0 Link encap:Ethernet HWaddr 00:1E:58:98:D8:51
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21e:58ff:fe98:d851/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:49873 errors:0 dropped:0 overruns:0 frame:0
TX packets:42390 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:69427468 (66.2 MiB) TX bytes:4097526 (3.9 MiB)


[/code2t2m4kqh]

[code2t2m4kqh]
[root@localhost ~]# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:21:29:6F:9A:91
ESSID:"Silent-AssAssIn"
Mode:Master
Frequency:2.462 GHz (Channel 11)
Channel:11
Quality=47/100 Signal level=-78 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 12 Mb/s
24 Mb/s; 48 Mb/s
Extra:tsf=00000003662c85cf
[/code2t2m4kqh]

plz help!

thanks in advance

Spy84464

24-09-2008 22:10:43

Hello,
I've moved this thread to the appropriate section.
You're indeed using rt2x00, which is still under heavy development. You seem to be using a rather old version (from kernel 2.6.25 apparently), so I suggest you either upgrade your kernel, or if that is not an option, try the rt61 legacy driver from our download section (the CVS version). If you go for that driver, make sure you disable rt61pci (rt2x00) first, as the two drivers cannot be loaded at the same time.

Regards,
Romain

naveedmurtuza

25-09-2008 04:40:29

Hi

thanks for replying...

updated my kernel to 2.6.26.3-29.fc9.i686[/color25v83l08]

still no luck.
now i'lll try the second option by installin the legacy rt61 drivers..

BTW is there a nice HOW TO for FC9...

naveedmurtuza

25-09-2008 07:55:26

Hi After following all the steps from the HOW TO ( Ubuntu how to, thought shud work for fedora as well...)

it gives me this error [code23n3k331][root@localhost Module]# iwlist ra0 scan
ra0 Interface doesn't support scanning.
[/code23n3k331]

my drivers were compiled fine.. donno what went wrong

plz help

ZX81

25-09-2008 10:50:28

Maybe the interface is in the wrong mode.
Is the interface up?
What does -> ifconfig ra0 <- and -> iwconfig ra0 <- show?

naveedmurtuza

26-09-2008 00:09:25

Hi
thanks for the reply

here is the output of those two commands ?
[code1xdylj4c]
root@localhost Module]# ifconfig ra0
ra0: error fetching interface information: Device not found
[root@localhost Module]# iwconfig ra0
ra0 No such device


[/code1xdylj4c]

ZX81

26-09-2008 07:08:03

OK, there is no active device with the name ra0

Is the module loaded? Check lsmod
Then find the name of the WLAN interface in the system.
If the system uses udev, look for the file with the names
of the network interfaces udev has found in the system.
On a gentoo system the name of the file is 70-persistent-net.rules
and it is located in the /etc/udev/rules.d/ folder.

Open the file with an editor and you should found a line that
looks simliar to this

# PCI device 0x80860x10bd (e1000e)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="xxxxxxxxxxxx", NAME="eth0"
The line above is only an example, it's the entry for a Intel EtherExpress Pro 1000 Card.

Normally you should found more than one of these lines.
The expression after NAME= is the interface-name within the system.
Write down all the names and then check ifconfig.
If the interface is down, the interface name is missing in the ifconfig output.
So compare the output with your list of the names from the file.
Find the missing name and try to bring the WLAN interface up with the command
ifconfig <interface-name> <ip-address> up

naveedmurtuza

27-09-2008 00:57:36

Yup GOT IT!!!!

actually the interface name is wlan0 and not ra0...

Thanks a Lot!!

Though i am connected to internet Network Manager thinks i am not... donno why?

But as far as i am able to browse websites ... i really dont mind mrgreen

thanks again..

Starcrasher

27-09-2008 07:42:05

# PCI device 0x80860x10bd (e1000e)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="xxxxxxxxxxxx", NAME="eth0"
The line above is only an example, it's the entry for a Intel EtherExpress Pro 1000 Card.[/quoteeja48om4]
ZX81, on recent kernel, use of e1000e driver can be dangerous for your hardware. See here[/urleja48om4] for more details.
Despite the title of the page, it affects all distributions with recent kernels. It's not recommended to use it at this time.