Failed to select rate control algorithm

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5066

MartinHerrman

01-11-2008 22:01:34

All,

running gentoo with custom compiled 2.6.27.4 kernel and it's rt2x00 driver on a 64-bit SMP machine (Intel Q9300).

$ dmesg
rt61pci 00000601.0 PCI INT A -> GSI 19 (level, low) -> IRQ 19
phy1 -> rt61pci_validate_eeprom EEPROM recovery - NIC 0xff80
phy1 -> rt2x00_set_chip Info - Chipset detected - rt 0301, rf 0003, rev 0002561c.
phy1 Failed to select rate control algorithm
phy1 Failed to initialize rate control algorithm
phy1 -> rt2x00lib_probe_dev Error - Failed to initialize hw.
rt61pci 00000601.0 PCI INT A disabled
rt61pci probe of 00000601.0 failed with error -2

martindesktop rt2x00 # lsmod
Module Size Used by
rt61pci 15424 0
rt2x00pci 3776 1 rt61pci
rt2x00lib 17216 2 rt61pci,rt2x00pci
eeprom_93cx6 1408 1 rt61pci

$lspci -vvv
0601.0 Network controller RaLink RT2561/RT61 802.11g PCI
Subsystem Giga-byte Technology GN-WP01GS
Control I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt pin A routed to IRQ 19
Region 0 Memory at e9200000 (32-bit, non-prefetchable)
Capabilities [40] Power Management version 2
Flags PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status D0 PME-Enable- DSel=0 DScale=0 PME-
Kernel modules rt61pci

Using WPA_supplicant as described here
http//www.gentoo.org/doc/en/handbook/h ... t=4&chap=4

I hope you can help me fix this, thanks in advance!

Martin

IvD

01-11-2008 22:09:05

You didn't select a rate control algorithm for mac80211.
reconfigure your kernel and make sure you select a Rate control algorithm in the mac80211 section.

MartinHerrman

02-11-2008 09:06:35

Stupid me -) Thanks for your support!

Next it was complaining about not able to find the firmware, after putting that in /lib/firmware, connection is perfect!