WPA setup on Intrepid 8.10

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5109

3rdegreeBurn

05-12-2008 20:43:23

Is this possible yet?
Do I do this manually or through the GUI?

Also would it be a good idea to setup RutIT?

IvD

05-12-2008 21:58:33

viewtopic.php?f=5&t=4926

3rdegreeBurn

05-12-2008 23:47:40

ahh yeah like I was saying using the rtx00 driver how would I set these up?

I would be more than happy to help on a wiki ansering questions like these seach my serach button seems to not work.

You da man IvD

IvD

06-12-2008 10:13:44

Just use the wireless configuration tools that come with your distribution.

3rdegreeBurn

08-12-2008 04:51:47

The net manager is not working can't connect.

do I need to do something with the wpa_supplicant?

IvD

08-12-2008 10:11:42

Again viewtopic.php?f=5&t=4926
And provide more information.

3rdegreeBurn

09-12-2008 02:18:49

oh I am back the say that 3rd time is a charm and I guess they were right cuz I got it working after some heave googling
and some magic words from my main man IvD

I was trying to connect with the Asus wl-167g ( rt2500) usb doogle in Ubuntu Linux 8.10 64bit
The doogle works fine on wep but I thought that I would like a bit more security.
I am currently trying to connect to a linksys wrt54g router with WPA-PSK TKIP.
Works great in windows with ralink drivers

So far I have tried putting my setting manually in to net manageer with no luck.
I also tried setting up a static ip connection with no luck.

I have also tried setting up the connection in the terminal via wicongfig and iwpriv. However for some reason
iwpriv gives me an error of "no private ioctls." I have no idea what that means. If any one can enlighten my I would be
greatfull.

The doogle is currently running under the interface wlan0

I tried editing the network interface file by typing "gksudo gedit /etc/network/interfaces"

In the file I put this in notting that essid and wpapsk is in quotes. Also the WPAPSK must be in hex

auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up ifconfig wlan0 down
pre-up ifconfig wlan0 up
pre-up ifconfig wlan0 down
pre-up iwconfig wlan0 essid "3rdscrib"
pre-up iwconfig wlan0 mode Managed
pre-up iwpriv wlan0 set AuthMode=WPAPSK
pre-up iwpriv wlan0 set EncrypType=TKIP
pre-up iwpriv wlan0 set WPAPSK="527858515794F585066335A675961"
pre-up ifconfig wlan0 up

This didn't work I ran into the "no private ioctls" error with iwpriv. So I erase the code to start over.

Next I tried setting up the wpa_supplicant config file.
gksudo gedit /etc/wpa_supplicant.conf

That I put in

3rdinlinux@mirage~$ wpa_passphrase NetworkEssid
# reading passphrase from stdin
TextPassphrase
network={
ssid="3rdscrib"
#psk="presharekey in ascii"
psk=preshare in hex
}

network={
ssid="3rdscrib"
scan_ssid=1 # only needed if your access point uses a hidden ssid
proto=WPA
key_mgmt=WPA-PSK
psk=presharekey
}

This worked to get me connected to the router but I still could not get any internet.
I went into the net manager
and fixed the subnet mask and some other ip setting and it worked.

So now I would like to know how I can setup my wpa config so the right setting are load automatically.

Also How's the wireless n work going? I will alpha test that if needed.

3rdegreeBurn

09-12-2008 04:55:32

after some more head scratching and some flexing of my linux newbie skills, I have stumbled onto the fact that my doogle was using the old rt73 driver, which may explain why nothing was working the way it should. As IvD mentioned in this post

[url15jopcve]http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?f=5&t=987[/url15jopcve]


But the doogle is working fine under the rt73 driver and wpa_supllicant. However I would still like to use the rtx00 drivers so I am gonna just play around untill I get it to work.

IvD

09-12-2008 06:28:27

When using the in-kernel drivers you can't use iwpriv, you should use wpa_supplicant for the WPA configuration.
You can't connect to the internet since you are not setting your IP address, so after running the wpa_supplicant command you might want to run dhcpcd wlan0 or dhclient wlan0 to get an IP address.