Can't get my rt2500 card connect to any wireless network

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5193

twobear

06-02-2009 19:11:34

Hi, I've installed latest Kubuntu(Ibex) on my Packard Bell Easynote laptop but can't get the wireless working(Ralink RT2500 802.11g Cardbus/mini-PCI). Have search a lot but can't find any good solution. Is there some easy Howto or such, to fix this?
Do I have to uninstall Knetworkmanager(obviously it doesn't work with rt2500) before I install Rutilt, and how does that affect my wired-connection? Because it is the rt2x00 driver which is shipped with Kubuntu/Ubuntu isn't it? I have tried and managed to change the settings but no luck. This is what I get out of iwlist and lshw

bjorn@pblaptop~$ sudo iwconfig

wlan0 IEEE 802.11bg ESSID""
ModeManaged Frequency2.412 GHz Access Point Not-Associated
Tx-Power=0 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keyoff
Power Managementoff
Link Quality0 Signal level0 Noise level0
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0
bjorn@pblaptop~$ lshw
*-network0 DISABLED
description Wireless interface
product RT2500 802.11g Cardbus/mini-PCI
vendor RaLink
physical id 6
bus info pci@00000006.0
logical name wmaster0
version 01
serial 001060653e6d
width 32 bits
clock 33MHz
capabilities bus_master cap_list logical ethernet physical wireless
configuration broadcast=yes driver=rt2500pci latency=64 module=rt2500pci multicast=yes wireless=IEEE 802.11bg

As I'm quite new to linux I would be very greatful to get supported in this matter!
Thanks in advance!

Spy84464

06-02-2009 19:38:55

Hello,
You will probably have more luck with networkmanager than RutilT, because it does not work too well with rt2x00.
The driver you are using seems indeed to be rt2x00, what is your problem exactly, how did you try to configure your card? To connect to what kind of network?

Regards,
Romain

twobear

10-02-2009 01:40:08

Hi Romain, and thanks for your aswer!

Absolutley no disrespect, but I must admit that I gets a little bit suprised when you tell me that Rutilt "does not work too well with rt2x00" cause I red in ubuntu homepage "RutilT is a Gtk+2 utility for Linux that helps you configure your wireless devices. Although primarily written for the rt2x00 project, it supports any Linux wireless extensions compliant kernel module. " .
So I'll be very glad if you'll explain this to me.

Anyway, in networkmanager I just get the msg wlan0 down (tried everything, and offcourse it doesn't find any networks,not my home network dlink - router-with and without WEP -, not my university network - no security ), with iwconfig on the other hand I can change most of the parameters (mode, Tx-Power etc.), but still no action.
By the way ifup brings up the wired devices but not the w-less, It seems to me, is there a corresponding command which brings up wireless devices?

Thanks in advance
Regards Björn

IvD

10-02-2009 09:56:20

RutilT was written for the legacy drivers and not the in-kernel rt2x00 drivers.
The reason was that the Legacy drivers didn't use the API where all other wireless configuration tools made use of, and hence couldn't talk to the legacy driver. The in-kernel drivers do use the proper APIs which means all regular wireless configuration tools (wpa_supplicant, NetworkManager, etc) can properly communicate with the driver.

twobear

10-02-2009 19:37:58

Thank you Ivo, for your explanation about drivers.

Still I've got the problem, and referring to your answer Networkmanager doesn't seem to communicate properly with my driver, why?

Or at least, the wireless can't find any networks. A friend of mine, a year ago in an earlier Ubuntu version, I recall, had to enable 'roaming' to get his wireless working(e.g. see possible networks to connect to), but I can't find any settings of it neither in networkmanager or elsewhere, so I'm still "begging" D for help!

I don't know what more information about my wireless that can be of interest, but it works fine under Win XP and I've tried with an usb device(sitecom) which worked fine with N-manager, so it's really both confusing and frustrating that I can't get it to work!

Best Regards
Björn

IvD

10-02-2009 19:44:46

What does 'iwlist wlan0 scan' return?

twobear

11-02-2009 23:39:05

Not so much, ( sadly
bjorn@pblaptop~$ sudo iwlist wlan0 scan
wlan0 Interface doesn't support scanning Network is down

hope you can read out something of it though!

Best Regards
Björn

IvD

12-02-2009 11:50:29

Well the error message should explain itself, your interface is down. So why not enable your interface before you scan?

twobear

12-02-2009 21:30:49

This is my problem, I don't know howto, I've tried with the ifup -all command, but that assumes, as far as I understand, that the device
is set to 'auto', which I tried to set with iwconfig unsuccessfully

bjorn@pblaptop~$ sudo iwconfig wlan0 mode Auto
[sudo] password for bjorn
Error for wireless request "Set Mode" (8B06)
SET failed on device wlan0 ; Invalid argument.

so, what should I do? cry

Best Regards
Björn

IvD

13-02-2009 08:02:34

To work with network interfaces man ifconfig
Additionally to work with wireless interfaces man iwconfig

P.S. Don't PM _and_ reply to a topic with the same message. As described in the infamous IMPORTANT READ BEFORE POSTING!!![/url29gdckux] topic "Private messages to this projects members are not intended for driver support".

twobear

17-02-2009 01:34:47

Sorry for double posting and not reading!

I've tried editing the etc/networks/interfaces like this(only the first two rows existed before)
auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp

And then it says in Knetworkmanager
"Unhandled"(translated from swedish) instead of "Down"

Also tried the following

bjorn@pblaptop~$ sudo ifup wlan0
ifup interface wlan0 already configured

bjorn@pblaptop~$ sudo iwlist wlan0 scan
wlan0 Interface doesn't support scanning Network is down

bjorn@pblaptop~$ sudo iwconfig wlan0 up
iwconfig unknown command "up"
bjorn@pblaptop~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS Device or resource busy(also transl. from swedish)

and still not working, any more suggestions?

Best Regards
Björn