rt2x00pci_alloc_reg: Error - Failed to allocate register

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5234

p369

25-03-2009 23:37:03

Hey,

I'm using the rt2500pci driver shipped with Lenny. Most of the time the card works all fine, but from time to time at boot time I get the following and it does not

[codefwov72s8]
Mar 23 10:39:05 localhost kernel: [ 21.136810] ACPI: Unable to derive IRQ for device 0000:05:00.0
Mar 23 10:39:05 localhost kernel: [ 21.136810] ACPI: PCI Interrupt 0000:05:00.0[?]: no GSI
Mar 23 10:39:05 localhost kernel: [ 21.136810] PCI: cache line size of 32 is not supported by device 0000:05:00.0
Mar 23 10:39:05 localhost kernel: [ 21.136810] rt2x00pci -> rt2x00pci_probe: Error - MWI not available.
Mar 23 10:39:05 localhost kernel: [ 21.136810] rt2x00pci -> rt2x00pci_alloc_reg: Error - Failed to allocate registers.
Mar 23 10:39:05 localhost kernel: [ 21.136810] ACPI: Unable to derive IRQ for device 0000:05:00.0
Mar 23 10:39:05 localhost kernel: [ 21.136810] rt61pci: probe of 0000:05:00.0 failed with error -12
Mar 23 10:39:05 localhost kernel: [ 21.136810] ACPI: PCI Interrupt 0000:05:01.1[A] -> GSI 17 (level, low) -> IRQ 17
[/codefwov72s8]

when working lsmod | grep rt gives me

[codefwov72s8]rt2500pci 23168 0
rt61pci 27136 0
crc_itu_t 6528 1 rt61pci
rt2x00pci 13056 2 rt2500pci,rt61pci
rt2x00lib 30080 3 rt2500pci,rt61pci,rt2x00pci
firmware_class 12544 2 cx24116,rt2x00lib
rfkill 11168 1 rt2x00lib
led_class 8968 1 rt2x00lib
input_polldev 8720 1 rt2x00lib
mac80211 162864 2 rt2x00pci,rt2x00lib
cfg80211 30224 2 rt2x00lib,mac80211
eeprom_93cx6 6784 2 rt2500pci,rt61pci[/codefwov72s8]

The lspci output for the card is

[codefwov72s8]
05:00.0 Network controller: RaLink RT2561/RT61 802.11g PCI[/codefwov72s8]

Is there any other information I should provide? Do the outputs above tell anything peculiar?
I appreciate any help!

IvD

26-03-2009 15:38:25

That error indicates hardware problems, try putting the device in another PCI slot or try checking the device on another computer.