RT73 master

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5272

blind_oracle

22-04-2009 08:19:16

Yes, i've used search FAQ etc )
And read about ACK issue, i wish to use patched hostapd to ignore ACK absence.

Kernel is latest stable, 2.6.29.1, as i understand next-gen drivers are already there?
But master mode can not be enabled anyway
[code3tm3q3zw]
# iwconfig wlan0 mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.
[/code3tm3q3zw]
It seems that drivers are legacy?
Which driver should i use? I don't want to use your GIT kernel tree if it's possible, better stick with vanilla.

My card is D-Link DWA-110, ids
[code3tm3q3zw]
# lsusb
...
Bus 001 Device 005: ID 07d1:3c07 D-Link System
...
[/code3tm3q3zw]

Module loading
[code3tm3q3zw]
wmaster0 (rt73usb): not using net_device_ops yet
phy1: Selected rate control algorithm 'minstrel'
wlan0 (rt73usb): not using net_device_ops yet
usbcore: registered new interface driver rt73usb
[/code3tm3q3zw]

IvD

22-04-2009 10:34:40

Yes, i've used search FAQ etc )
And read about ACK issue, i wish to use patched hostapd to ignore ACK absence.

Kernel is latest stable, 2.6.29.1, as i understand next-gen drivers are already there?
But master mode can not be enabled anyway
[code1o888n3m]
# iwconfig wlan0 mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.
[/code1o888n3m]
[/quote1o888n3m]

You can _only_ use hostapd. Don't try to configure the device with iwconfig.

blind_oracle

23-04-2009 06:47:01

Thanks, i've managed to get latest hostpad with disabled ACK running, but i can't see any beacons on my notebook somewhy.
While running in debug mode, hostapd shows that it sees probes from notebook, but notebook doesn't see any SSID.