Results from rt2x00 driver - Indirect register access failed

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5326

Unrepentant1

02-05-2009 22:32:44

I've downloaded the latest source version through GIT and compiled a new kernel.
Upon bootup i receive the following messages.

[code3rqlpucx]
kernel: rt2800pci 0000:00:0f.0: found PCI INT A ->IRQ 10
kernel: rt2800pci 0000:00:0f.0: sharing IRQ 10 with 0000:00:0d.0
kernel: Registered led device: rt2800pci-phy0::radio
kernel: Registered led device: rt2800pci-phy0::assoc
kernel: Registered led device: rt2800pci-phy0::quality[/code3rqlpucx][/size3rqlpucx]

So it looks like the kernel recognizes the device and everything's cool...

I can set all the necessary parameters using iwconfig no problem...

Then once I bring the interface up using ifconfig i receive the following messages via dmesg....


[code3rqlpucx]
rt2800pci 0000:00:0f.0: firmware: requesting rt2860.bin
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
ADDRCONF(NETDEV_UP): wlan0: link is not ready[/code3rqlpucx][/size3rqlpucx]

Whats interesting is, when I bring up the interface i can use 'iwlist wlan0 scan' and it works fine...
It just will not connect to any wireless network..

I've seen another post with similar messages, but there was no resolution to the problem...

Any help would be much appreciated..

Thanks

IvD

03-05-2009 07:41:47

could you please specify which driver you are using....

Unrepentant1

03-05-2009 08:50:20

i'm using driver rt2860pci...

After some tweaking with building the kernel i have received some additional error messages...

[code37b1l4kz]rt2800pci 0000:00:0f.0: found PCI INT A -> IRQ 10
rt2800pci 0000:00:0f.0: sharing IRQ 10 with 0000:00:0d.0
phy0 -> rt2x00_set_chip: Info - Chipset detected - rt: 0601, rf: 0001, rev: 28600103.
phy0: Selected rate control algorithm 'minstrel'
Registered led device: rt2800pci-phy0::radio
Registered led device: rt2800pci-phy0::assoc
Registered led device: rt2800pci-phy0::quality
[/code37b1l4kz]

and

[code37b1l4kz]phy0 -> rt2x00lib_request_firmware: Info - Loading firmware file 'rt2860.bin'.
rt2800pci 0000:00:0f.0: firmware: requesting rt2860.bin
phy0 -> rt2x00lib_request_firmware: Info - Firmware detected - version: 0.11.
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00007010, value=0xffffffff
phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 0 - CWmin: 5, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 1 - CWmin: 5, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 2 - CWmin: 5, CWmax: 10, Aifs: 2, TXop: 0.
phy0 -> rt2x00mac_conf_tx: Info - Configured TX queue 3 - CWmin: 5, CWmax: 10, Aifs: 2, TXop: 0.
[/code37b1l4kz]

little more information....

IvD

03-05-2009 11:45:07

Well in that case, this is a known issue, and you are already in luck the scanning is working.

Other then that I only want to point you to viewtopic.php?f=5&t=4200
which is the main discussion thread for the unreleased rt2800pci driver.