How to know and change the sending rate

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5462

shirie

12-06-2009 06:28:56

Here is the infomation of my wirless card. I can't get the sending rate. And the command
"iwconfig eth0 rate .. " doesn't make any sense. Can anybody help. Thanks in advance.

wlan0 IEEE 802.11bg ESSID"myhoc"
ModeAd-Hoc Frequency2.412 GHz Cell 82168610D261
Tx-Power=4 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keyoff
Power Managementoff
Link Quality0 Signal level0 Noise level0
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

IvD

12-06-2009 17:21:23

Well since the interface is called wlan0, why don't just to 'iwconfig wlan0 rate ...'

shirie

14-06-2009 04:19:10

Well since the interface is called wlan0, why don't just to 'iwconfig wlan0 rate ...'[/quote1vudedcy]

Sorry, I mistype the command. Actually I run the command "iwconfig wlan0 rate..." but it seems doesn't make any sense. What's the problem? Thanks.

IvD

14-06-2009 08:53:21

Why doesn't make any sense, what kind of command would make sense to you for changing the bitrate?

shirie

01-07-2009 06:23:08

Why doesn't make any sense, what kind of command would make sense to you for changing the bitrate?[/quote1735gis4]

I don't know the reason. The command "iwconfig wlan0 rate ..." doesn't return any error message, but I still can't see any information about the sending rate. I tried many times. May you help me ?

lfcorreia

05-07-2009 22:06:27

there is no 'sending rate'.

you just set manually the rate that you want the card to be operated with and that's really it!

as an example, for 48Mb/s you will write
[code22aejpzf]iwconfig wlan0 rate 48M[/code22aejpzf]

HTH

shirie

06-07-2009 07:22:50

there is no 'sending rate'.

you just set manually the rate that you want the card to be operated with and that's really it!

as an example, for 48Mb/s you will write
[code2u8dmunu]iwconfig wlan0 rate 48M[/code2u8dmunu]

HTH[/quote2u8dmunu]

Yes, I really did that. But how can I know if the command works. There is not any information I can get about it from the "iwconfig" before or after I tried to chang the rate.

lfcorreia

07-07-2009 07:57:55

how much more information will you need, really?

(sensitive information masked)

[lfcorreia@lc ~]$ sudo iwconfig wlan0
wlan0 IEEE 802.11bg ESSID"whatever"
ModeManaged Frequency2.462 GHz Access Point 000000000000
[b1yb2gqlz]Bit Rate=1 Mb/s[/b1yb2gqlz] Tx-Power=12 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keykey-secure Security modeopen
Power Managementoff
Link Quality=73/100 Signal level-40 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

[lfcorreia@lc ~]$ sudo iwconfig wlan0 [b1yb2gqlz]rate 54M[/b1yb2gqlz]
[lfcorreia@lc ~]$ sudo iwconfig wlan0
wlan0 IEEE 802.11bg ESSID"whatever"
ModeManaged Frequency2.462 GHz Access Point 000000000000
[b1yb2gqlz]Bit Rate=54 Mb/s[/b1yb2gqlz] Tx-Power=12 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keykey-secure Security modeopen
Power Managementoff
Link Quality=73/100 Signal level-42 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

shirie

08-07-2009 19:24:53

how much more information will you need, really?

(sensitive information masked)

[lfcorreia@lc ~]$ sudo iwconfig wlan0
wlan0 IEEE 802.11bg ESSID"whatever"
ModeManaged Frequency2.462 GHz Access Point 000000000000
[b1otyapr6]Bit Rate=1 Mb/s[/b1otyapr6] Tx-Power=12 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keykey-secure Security modeopen
Power Managementoff
Link Quality=73/100 Signal level-40 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

[lfcorreia@lc ~]$ sudo iwconfig wlan0 [b1otyapr6]rate 54M[/b1otyapr6]
[lfcorreia@lc ~]$ sudo iwconfig wlan0
wlan0 IEEE 802.11bg ESSID"whatever"
ModeManaged Frequency2.462 GHz Access Point 000000000000
[b1otyapr6]Bit Rate=54 Mb/s[/b1otyapr6] Tx-Power=12 dBm
Retry min limit7 RTS throff Fragment thr=2352 B
Encryption keykey-secure Security modeopen
Power Managementoff
Link Quality=73/100 Signal level-42 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0[/quote1otyapr6]

But as my first message descript, there is no "Bit Rate" property after I run "iwconfig ..." command. May it be due to the wireless card work under the mode "adhoc"?

lfcorreia

09-07-2009 04:42:09

so, only now you say you're in ad-hoc mode???

sheesh, when will people learn how to file a 'bug report'?

adhoc modes are restricted to 11Mb/sec according to specification, therefore there is no rate change allowed.

case closed!

IvD

09-07-2009 04:47:13

so, only now you say you're in ad-hoc mode???
[/quoteagjvgd7r]

Was already part of his first post.


adhoc modes are restricted to 11Mb/sec according to specification, therefore there is no rate change allowed.
[/quoteagjvgd7r]

Rate changes are allowed, but only to rates 1, 2, 5.5 and 11Mbs. But even then iwconfig should display the used rate,
however when it doesn't it is a problem of iwconfig and not the driver.