D-Link G122 Rev c1 and 64 Studio Beta 3

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5479

click

21-06-2009 21:40:03

Hello,

I'm new to this forum. I'm a relative newbie to Linux which means that I've installed and tried several distributions in the last years but haven't mainly used Linux for home use. At the office I'm using Linux on some server systems but that doesn't go very deep.

I'm making music with computers and try to switch to Linux Audio because I think that Microsofts strategy sucks. On my dedicated PC only 64 Studio Beta 3 installed and worked properly right now which is basically Ubuntu Studio 8.04 LTS + new realtime multimedia kernel and some extras.

Ok, so now I've buyed a D-Link G122 because I've read that it works out-the-box in Ubuntu 8.04. Unfortunately this is not the case on my PC. I've then found out that the statement was meant for Revision b1 G122's and that I have a Revision c1 one which uses the rt73 chipset.
As far as I understand it the rt2x00 drivers should be included in the realtime kernel as it is a version 2.6.29 one but the G122 is not recognized.
lsusb shows the USB WLAN stick correctly but lsmod doesn't list any rt modules.

And I have to say that the rt2x00 documentation is very confusing for me

How can I determine if the kernel used in 64 Studio Beta 3 has the rt2x00 drivers included?

If it is not included Should I use the latest snapshot from the rt2x00 site (AFAIU I have to build a completely new kernel for them including the realtime options) or is it recommended to use the legacy rt73 drivers and the corresponding Ubuntu packages (available only for 8.10 and higher)?

IvD

22-06-2009 08:50:05

I heard the real-time developers disabled rt2x00 for a period of time due to compile errors (no they didn't report that problem to the rt2x00 team....) but those errors have no been fixed so check your kernel configuration to see if CONFIG_RT2X00 is available or not.

click

22-06-2009 17:29:06

[code1ul5w6cc]cat /boot/config-2.6.29-1-multimedia-amd64 | grep RT2[/code1ul5w6cc]
only shows
[code1ul5w6cc]# CONFIG_RT2860 is not set
# CONFIG_RT2870 is not set[/code1ul5w6cc]

IvD

22-06-2009 22:45:41

That sounds like the RT2X00 disabled kernel version... (
You'll need the 2.6.30 kernel

click

24-06-2009 18:56:45

Compiled the kernel successfully (a recent git snapshot) but ran into a grub (legacy => 0.97-29) problem
( https//bugs.launchpad.net/ubuntu/+sour ... bug/365331)

I then installed lilo 22.8.3 but liloconf gives me a warning (in german) that either my /etc/fstab is defective or I'm using hardware which is not supported by this easy configuration program.

Is there a recommended boot loader for 2.6.30?
(Lilo, Grub2, ...)

IvD

24-06-2009 19:00:27

Not really, all bootloaders should simply work.

click

09-07-2009 06:35:27

I now want to start a new try with the latest stable 2.6.30 kernel (2.6.30.1 from kernel.org).

With
[code1uvo5b8g]make menuconfig[/code1uvo5b8g]
I have not found a configuration option for the rt2x00 drivers.

But in the .config file there is a line
[code1uvo5b8g]# CONFIG_RT2X00 is not set[/code1uvo5b8g]

If I understand it correctly I can simply rewrite that to
[code1uvo5b8g]CONFIG_RT2X00=m[/code1uvo5b8g]

Do I also have to add
[code1uvo5b8g]CONFIG_RT73USB=m[/code1uvo5b8g]
or other configuration items?

Where do I find these settings in make menuconfig?

IvD

09-07-2009 06:53:07

No manually changing that option is not correct, since that file is automatically generated.
You are probably missing the dependencies, you have to enable wireless and mac80211 before rt2x00 will appear in the drivers section.

click

10-07-2009 05:03:37

This kernel didn't boot, too. ?

I've then tried a prebuild kernel from here
http//kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30/

Now it looks like the driver is loaded. So I guess I've compiled the kernel in a wrong way or have done something else wrong.

And, of course, I have a new problem (

dmesg | grep firmware gives me

[code2pe84095]
rt73usb 1-1:1.0: firmware: requesting rt73bin
phy0 -> rt2x00lib_request_firmware: Error: Failed ro request Firmware[/code2pe84095]

And rutilt crashes when I try so edit the settings. It doesn't seem to have any options for WPA2 anyway.

Edit I have a rt73.bin (compiled from a source downloaded from the Ralink homepage), but I don't have a clue where I have to put it in. I put it in the directory /etc/Wireless/RT73STA as the README said.

Edit2 Found this posting
viewtopic.php?p=29442#p29442
[quote2pe84095]Is udev/hotplug configured to accept firmware files?[/quote2pe84095]

I, too, don't know to how check that, but the kernel configuration contains
[code2pe84095]CONFIG_HOTPLUG=y[/code2pe84095]
Maybe this is meant.

Btw. The search doesn't work. It always says
[quote2pe84095]Sorry but you cannot use search at this time. Please try again in a few minutes.[/quote2pe84095]

IvD

10-07-2009 06:14:17

Firmware files belong in /lib/firmware, for enabling udev to detect firmware files you should check the udev manpage.

click

10-07-2009 06:33:14

There is no 'firmware' in the manpage of udev. ?