help w/ WLI-UC-GN, not sure of which Ralink chipset

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5490

buffer

12-07-2009 08:25:39

I've got the wireless-n ultra-compact USB 2.0 adapter (WLI-UC-GN) and I'm trying to get it working with a 2.6.29-r5 kernel. In the kernel I've enabled

Device Drivers -> Network Device Support -> Wireless LAN -> Ralink driver support
<*> Ralink rt2500 (USB) support
<*> Ralink rt2501/rt73 (USB) support
<*> Ralink debug output

Here's more info

[code1xvgtnnb]
$ lsusb
Bus 002 Device 006: ID 0411:015d MelCo., Inc.
Bus 002 Device 001: ID 1d6b:0002
Bus 008 Device 001: ID 1d6b:0001
Bus 007 Device 002: ID 0461:4d17 Primax Electronics, Ltd
Bus 007 Device 001: ID 1d6b:0001
Bus 006 Device 001: ID 1d6b:0001
Bus 001 Device 001: ID 1d6b:0002
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp.
Bus 005 Device 001: ID 1d6b:0001
Bus 004 Device 001: ID 1d6b:0001
Bus 003 Device 001: ID 1d6b:0001
[/code1xvgtnnb]

When I plug it in, I get this in /var/log/messages ...

[code1xvgtnnb]
Jul 11 16:56:26 Radar [ 1167.841548] usb usb2: usb resume
Jul 11 16:56:26 Radar [ 1167.841553] ehci_hcd 0000:00:1d.7: resume root hub
Jul 11 16:56:26 Radar [ 1167.882146] hub 2-0:1.0: hub_resume
Jul 11 16:56:26 Radar [ 1167.882159] ehci_hcd 0000:00:1d.7: GetStatus port 2 status 001803 POWER sig=j CSC CONNECT
Jul 11 16:56:26 Radar [ 1167.882162] hub 2-0:1.0: port 2: status 0501 change 0001
Jul 11 16:56:26 Radar [ 1167.983163] hub 2-0:1.0: state 7 ports 6 chg 0004 evt 0000
Jul 11 16:56:26 Radar [ 1167.983170] hub 2-0:1.0: port 2, status 0501, change 0000, 480 Mb/s
Jul 11 16:56:26 Radar [ 1168.034333] ehci_hcd 0000:00:1d.7: port 2 high speed
Jul 11 16:56:26 Radar [ 1168.034335] ehci_hcd 0000:00:1d.7: GetStatus port 2 status 001005 POWER sig=se0 PE CONNECT
Jul 11 16:56:26 Radar [ 1168.085148] usb 2-2: new high speed USB device using ehci_hcd and address 8
Jul 11 16:56:26 Radar [ 1168.138333] ehci_hcd 0000:00:1d.7: port 2 high speed
Jul 11 16:56:26 Radar [ 1168.138335] ehci_hcd 0000:00:1d.7: GetStatus port 2 status 001005 POWER sig=se0 PE CONNECT
Jul 11 16:56:26 Radar [ 1168.212381] usb 2-2: default language 0x0409
Jul 11 16:56:26 Radar [ 1168.218879] usb 2-2: New USB device found, idVendor=0411, idProduct=015d
Jul 11 16:56:26 Radar [ 1168.218883] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jul 11 16:56:26 Radar [ 1168.218885] usb 2-2: Product: 802.11 n WLAN
Jul 11 16:56:26 Radar [ 1168.218887] usb 2-2: Manufacturer: Ralink
Jul 11 16:56:26 Radar [ 1168.218889] usb 2-2: SerialNumber: 1.0
Jul 11 16:56:26 Radar [ 1168.218963] usb 2-2: uevent
Jul 11 16:56:26 Radar [ 1168.218983] usb 2-2: usb_probe_device
Jul 11 16:56:26 Radar [ 1168.218986] usb 2-2: configuration #1 chosen from 1 choice
Jul 11 16:56:26 Radar [ 1168.219126] usb 2-2: adding 2-2:1.0 (config #1, interface 0)
Jul 11 16:56:26 Radar [ 1168.220378] usb 2-2:1.0: uevent
Jul 11 16:56:26 Radar [ 1168.220556] drivers/usb/core/inode.c: creating file '008'
[/code1xvgtnnb]

[code1xvgtnnb]
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.
[/code1xvgtnnb]

Any help much appreciated.

IvD

12-07-2009 18:12:26

[code21das8zi]
Jul 11 16:56:26 Radar [ 1168.218885] usb 2-2: Product: 802.11 n WLAN
Jul 11 16:56:26 Radar [ 1168.218887] usb 2-2: Manufacturer: Ralink
[/code21das8zi]

Apparently it is an 11n device, this means you need the rt2800usb driver which was introduced in 2.6.31, but be aware that the driver is very buggy. See viewtopic.php?f=5&t=4200