[rt61] turn txpower off under 2.6.33

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6060

poloskin

08-04-2010 12:35:23

I'm trying to turn the txpower off with the following command

iwconfig wlan0 txpower off

After this command I can still ping my host. iwconfig shows following

wlan0 IEEE 802.11bg ESSID"TESTWPA2"
ModeManaged Frequency2.442 GHz Access Point 00904C910001
Bit Rate=1 Mb/s Tx-Power=11 dBm
Retry long limit7 RTS throff Fragment throff
Encryption keyoff
Power Managementoff
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

If using 2.6.26 iwconfig shows "Tx-Power=off" and no data transmission is possible.

The version of wireless-tools

debian~# iwconfig -v
iwconfig Wireless-Tools version 29
Compatible with Wireless Extension v11 to v22.

Kernel Currently compiled with Wireless Extension v22.

wlan0 Recommend Wireless Extension v21 or later,
Currently compiled with Wireless Extension v22.

The system is Debian Lenny for ARM.

If I try to reduce the txpower to 0 I can see it in iwconfig output, but the data transmission is possible.

What can I do to disable txpower as in 2.6.26? The only way I see is calling "ifconfig wlan0 down", but it is not the desired approach.

Regards,
poloskin