Error inserting rt2800usb

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6081

joker5bb

16-06-2010 00:52:16

I have compiled master-2010-06-15 of wireless-testing and i get this from dmesg

[ 638.466463] rt2x00lib disagrees about version of symbol ieee80211_register_hw
[ 638.466466] rt2x00lib Unknown symbol ieee80211_register_hw
[ 638.466577] rt2x00lib disagrees about version of symbol ieee80211_get_hdrlen_from_skb
[ 638.466579] rt2x00lib Unknown symbol ieee80211_get_hdrlen_from_skb
[ 638.466636] rt2x00lib disagrees about version of symbol ieee80211_wake_queue
[ 638.466638] rt2x00lib Unknown symbol ieee80211_wake_queue
[ 638.466694] rt2x00lib disagrees about version of symbol ieee80211_tx_status_irqsafe
[ 638.466695] rt2x00lib Unknown symbol ieee80211_tx_status_irqsafe
[ 638.466749] rt2x00lib disagrees about version of symbol wiphy_rfkill_set_hw_state
[ 638.466751] rt2x00lib Unknown symbol wiphy_rfkill_set_hw_state
[ 638.466871] rt2x00lib disagrees about version of symbol ieee80211_queue_delayed_work
[ 638.466873] rt2x00lib Unknown symbol ieee80211_queue_delayed_work
[ 638.466927] rt2x00lib disagrees about version of symbol wiphy_rfkill_stop_polling
[ 638.466928] rt2x00lib Unknown symbol wiphy_rfkill_stop_polling
[ 638.466985] rt2x00lib disagrees about version of symbol ieee80211_ctstoself_get
[ 638.466986] rt2x00lib Unknown symbol ieee80211_ctstoself_get
[ 638.467115] rt2x00lib disagrees about version of symbol ieee80211_wake_queues
[ 638.467117] rt2x00lib Unknown symbol ieee80211_wake_queues
[ 638.467174] rt2x00lib disagrees about version of symbol ieee80211_iterate_active_interfaces
[ 638.467175] rt2x00lib Unknown symbol ieee80211_iterate_active_interfaces
[ 638.467268] rt2x00lib disagrees about version of symbol ieee80211_stop_queue
[ 638.467269] rt2x00lib Unknown symbol ieee80211_stop_queue
[ 638.467326] rt2x00lib disagrees about version of symbol ieee80211_stop_queues
[ 638.467327] rt2x00lib Unknown symbol ieee80211_stop_queues
[ 638.467416] rt2x00lib disagrees about version of symbol wiphy_rfkill_start_polling
[ 638.467417] rt2x00lib Unknown symbol wiphy_rfkill_start_polling
[ 638.467474] rt2x00lib disagrees about version of symbol ieee80211_iterate_active_interfaces_atomic
[ 638.467476] rt2x00lib Unknown symbol ieee80211_iterate_active_interfaces_atomic
[ 638.467652] rt2x00lib disagrees about version of symbol ieee80211_unregister_hw
[ 638.467653] rt2x00lib Unknown symbol ieee80211_unregister_hw
[ 638.467758] rt2x00lib disagrees about version of symbol ieee80211_rts_get
[ 638.467759] rt2x00lib Unknown symbol ieee80211_rts_get
[ 638.467836] rt2x00lib Unknown symbol ieee80211_beacon_get
[ 638.467944] rt2x00lib disagrees about version of symbol ieee80211_queue_work
[ 638.467946] rt2x00lib Unknown symbol ieee80211_queue_work
[ 638.468017] rt2x00lib disagrees about version of symbol ieee80211_rx_irqsafe
[ 638.468018] rt2x00lib Unknown symbol ieee80211_rx_irqsafe

IvD

17-06-2010 15:04:11

Sounds like you didn't load mac80211, or have loaded a different mac80211 version then where you compiled rt2x00 for.
Which probably means you took wireless-testing, and instead of using that kernel, you are using your old kernel with the new rt2x00 drivers.

So either use compat-wireless to override all wireless modules of your old kernel with the most recent version,
or reboot into the kernel you build with wireless-testing.