RT2860 Dualband 2.4 Ghz / 5 Ghz

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6104

ash

17-11-2010 15:21:48

Hi guys,

first off thanks a bunch for the time and brains you guys invest into this driver!
Highly appreciated!

I'm running OpenSuse 11.3 and after installing a newer hostapd that includes support for 802.11n (ieee80211n=y)
and installing compat-wireless from wireless.kernel.org I was able to use use the card in master mode on both
the 2.4 and 5 ghz band with N features enabled.
For 5ghz setting the regulatory domain was an important step because that gave me a completly different
available channel list, and figuring out hostapd will set the WLAN card into master mode which was not possible
via iwconfig was another.

[b3akqlkbe]Now to my question[/b3akqlkbe]
Is it theoretically possible to run the card on both bands at the same time?

cheers
ash

ash

19-11-2010 00:38:55

Also to make everything more stable I had to add this "patch"
http//permalink.gmane.org/gmane.linux. ... eral/57752

Otherwise it would bring down the server quite often or not work at all.
Sometimes it would use up ~30% cpu via a IRQ/... process and make the whole
server very sluggish.

And to have android connect correctly use the firmware supplied with OpenSuse 11.3
and not the one available on the RALINK website.

MD5Sum of the firmware files
7f55011396eff4983f26bb7dd7339fb3 rt2860.bin.OPENSUSE
66332d7636ee78db31b056aa0e44b097 rt2860.bin.RALINK

ash

25-11-2010 07:47:37

Just FYI in case someone else hits the same problems

After messing around a bit to get another device working together with the AP I hit
the IRQ uses up all CPU time problem again.

Went and installed compat-wireless-2.6.37-rc3-1 which was the latest available at that time.
IRQ utilization still stayed high - but after installing the firmware supplied by ralink it seems
to work fine. Even android likes it now.

cheers
ash

mist

18-12-2010 23:12:58

ash, thanks for your helpful information!

I'm currently trying to get my rt2860 (linksys WMP600N) work in 5 GHz AP mode. Im using the latest compat-wireless, the same firmware file that you posted (ralink website) and hostapd 0.7.3. The card works fine on the 2.4 GHz band, but hostapd fails to set the card to the 5 GHz band. I also applied your the patch you linked to the rt2800lib.c file and tried multiple times to unload/reload the modules and restarting hostapd as you posted in another thread. I set hw_mode=a and channel=48 in my hostapd configuration.

Did you do anything specific to get the 5 GHz band working? My regulatory domain seems to be correctly set (DE).

iw list shows the second band with the 5 GHz channels, but the hostapd startup output shows that it seems to see only the 2.4 GHz band.

[codevoycrlsx]
Configuration file: /etc/hostapd/5g.conf
ctrl_interface_group=0
nl80211: Interface wlan0 is in bridge br0
nl80211: Add own interface ifindex 7
nl80211: Add own interface ifindex 26
nl80211: New interface mon.wlan0 created: ifindex=33
nl80211: Add own interface ifindex 33
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
nl80211: Added 802.11b mode based on 802.11g information
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=12 freq=2467 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=13 freq=2472 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=12 freq=2467 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=13 freq=2472 MHz max_tx_power=20 dBm
wlan0: IEEE 802.11 Configured channel (48) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-1)
wlan0: Unable to setup interface.
Flushing old station entries
Deauthenticate all stations
nl80211: Remove interface ifindex=33
netlink: Operstate: linkmode=0, operstate=6
nl80211: Failed to set interface 26 to mode 2: -16 (Device or resource busy)
nl80211: Failed to set interface 26 to mode 2: -16 (Device or resource busy)
nl80211: Interface mode change to 2 from 3 failed
[/codevoycrlsx]

ash

19-12-2010 10:54:48

Hey mist,

maybe you try this firmware file, its newer as far as I know.. If I'm not mistaken comes from some win installer blob as has version id 29
http//git.kernel.org/?p=linux/kernel/g ... git;a=tree

Im now using
[code346prci2]
router19:/lib/firmware # md5sum rt2860.bin.29
7f55011396eff4983f26bb7dd7339fb3 rt2860.bin.29
[/code346prci2]
But that shouldn't make a difference for your problem tho, I've been using the .26 you are using before.


Reg Domain does seem to be set correctly as you can use channel 13, which by default is off (US doesnt allow those channels without restrictions)

What does "iw reg get" print?
[code346prci2]
router19:~ # iw reg get
country DE:
(2400 - 2483 @ 40), (N/A, 40)
(5150 - 5350 @ 40), (N/A, 40), NO-OUTDOOR, DFS
(5470 - 5725 @ 40), (N/A, 53), NO-OUTDOOR, DFS
[/code346prci2]

Sometimes it does take 2+ hostapd starts to have a correct channel list. It might end up showing this and then segfault
[code346prci2]
wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
[/code346prci2]

Currently I'm using the latest code from ivo git, intermerged with the latest git-next tree from wireless.kernel.org.
Copied over rt2x00 and kfifo.h/c and added the kfifo to the Makefile for rt2x00
ivos tree http//git.kernel.org/?p=linux/kernel/g ... ;a=summary


Did you enable/compile in support the ieee80211n in hostapd?

Always helpful
[code346prci2]
rmmod rt2800pci rt2800lib crc_ccitt rt2x00pci rt2x00lib mac80211 cfg80211 eeprom_93cx6
and
echo 1 > /sys/kernel/debug/ieee80211/phy0/reset
[/code346prci2]

mist

20-12-2010 20:22:47

Hi ash,

thanks, I finally got it working -)

It seems that the frequencies are disabled for AP mode (iw list says (radar detection) following all the 5 GHz channels). Strangely enough, when I change my reg domain to US, there are a few 5 GHz channels left without the radar detection note, and these are available to hostapd. I wonder why those are not available in the German regulatory domain. Anyway, I'm currently simply setting the reg domain to US to work around this issue. What package is the regulatory domain database part of? Maybe I just need to pull an update..

Another odd thing is that I have to reload the driver modules for a regulatory domain change to take effect. I also had a crash of my router yesterday; I'm not yet sure whether its related to rt2800, but I'll notice if more crashes occur during the next days -)

-Mike

ash

20-12-2010 22:27:20

If you see a big van with a bunch of antennas on the roof parked in front of your house, that might be the RegTP trying to figure out whos broadcasting on frequencies not open for public consumption.

You are best advised to not use a regulatory domain that is different from the country you are currently in.
Check the frequency you are using now and what policies there are for germany on that frequency, otherwise
you might end up paying fines for not adhering to the regulatory rules.

Each country has different rules for different parts of the spectrum, like in Japan you can use channel 14 on 2.4GhZ ...
That is why there is crda, and why it uses signed databases .. to make it harder for the causal user to use frequencies
that are less crowded for the reason you shouldn't be using them.

mist

21-12-2010 09:41:33

Hi,

I do not intend to use prohibited frequencies, just tried to figure out why the the channels that are available for indoor use were not available to hostapd. In fact, upgrading the regulatory.db file to the latest from linuxwireless.org solved my issue, since the DE definitions changed from

[code1tukwl0d]
country DE:
(2400.000 - 2483.500 @ 40.000), (N/A, 20.00)
(5150.000 - 5350.000 @ 40.000), (N/A, 20.00), NO-OUTDOOR, DFS
(5470.000 - 5725.000 @ 40.000), (N/A, 26.98), NO-OUTDOOR, DFS
[/code1tukwl0d]

to

[code1tukwl0d]
country DE:
(2400.000 - 2483.500 @ 40.000), (N/A, 20.00)
(5150.000 - 5250.000 @ 40.000), (N/A, 20.00), NO-OUTDOOR
(5250.000 - 5350.000 @ 40.000), (N/A, 20.00), NO-OUTDOOR, DFS
(5470.000 - 5725.000 @ 40.000), (N/A, 26.98), DFS
[/code1tukwl0d]

which makes channels 36-48 available to AP usage. To my guessing the constraints given for the other frequency ranges require the driver to take measures to avoid possible interference such as DFS, which the rt2800 driver maybe does not implement wherefor these constrained frequency ranges are disabled for AP usage.

Anyway, it seems to work now, time will show how stable it is...