ASUS USB-N11 (rt2870) frequently disconnects

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6137

eza

01-04-2011 08:27:27

I'm running Ubuntu 10.10 (kernel 2.6.35-PAE). The rt2x00 modules were installed by default and the USB-N11 dongle seems to work correctly as soon as the computer starts. However after a few minutes, the connection gets lost and never comes back, unless I restart the network-manager.
This behavior is very similar to what was described in the following thread Linksys WUSB600N v1 disconnecting from AP[/url1mx1tjrq]
I tried to change the status of the power saving modes, as it was suggested [url=http://rt2x00.serialmonkey.com/pipermail/users_rt2x00.serialmonkey.com/2011-January/003078.html1mx1tjrq]here[/url1mx1tjrq], but this doesn't help in my case. Also I do not use TKIP anymore, since it was not supported at first, and I don't know what is the current status.
I observed dmesg output when it fails, and it seems that the disconnections always follow this line
[code1mx1tjrq]cfg80211: Calling CRDA to update world regulatory domain[/code1mx1tjrq]
What seems to improve the situation a little bit is to change the regulatory domain (defaults to "World") with the following line
[code1mx1tjrq]iw reg set US[/code1mx1tjrq]
Then the disconnections are less, but still frequent (approx every 10 minutes).
And then when a disconnection occurs, dmesg says
[code1mx1tjrq]cfg80211: Calling CRDA to update world regulatory domain
...
cfg80211: Calling CRDA for country: US
[/code1mx1tjrq]
Seems that even if "US" is set as regulatory domain, the World regulatory domain is still updated and causes the disconnections (at least it seems to). I don't know exactly why it is required to update this regulatory domains regularly (is it linked somewhat to roaming?) and I don't know if it is possible to disable this behavior, but I have the feeling that something is wrong with this update of the world regulatory domain.

Do someone understands what may happen here? Any ideas what to do next ?

eza

01-04-2011 23:20:24

Good news )
All my problems disappeared magically after the installation of linux-backports-modules-compat-wireless-2.6.38-2.6.35-28-generic-pae (2.6.35-28.20)