Ralink RT3070L configuration problem

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6177

metanoya

02-09-2011 12:47:03

Hi everyone.

I need to get a built-in wifi device with a RT3070L chip working. The Linux I'm using is Meego 1.0. What I have done so far is to enable support for the driver in the kernel. This setting was at Staging drivers->Ralink 2870/3070 wireless support. I also downloaded this file 2011_0407_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.2_DPO.bz2 from the Ralink website. I extracted the archive and copied RT2870STA.dat to /etc/Wireless/RT2870STA.

The device is now detected and the wlan0 section of ifconfig -a is as follows

wlan0 Link encapEthernet HWaddr 74F06D49BBE6
UP BROADCAST MULTICAST MTU1500 Metric1
RX packets304969 errors0 dropped0 overruns0 frame0
TX packets128182 errors0 dropped0 overruns0 carrier0
collisions0 txqueuelen1000
RX bytes45333757 (43.2 MiB) TX bytes9177784 (8.7 MiB)

iwconfig produces the following

wlan0 Ralink STA ESSID"" Nickname"RT2870STA"
ModeAuto Frequency=2.412 GHz Access Point Not-Associated
Bit Rate1 Mb/s
RTS throff Fragment throff
Encryption keyoff
Link Quality=10/100 Signal level0 dBm Noise level-115 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

iwlist scan also manages to find the network that I wish to connect to. Problem is when I do iwconfig wlan0 essid "My Network". This command doesn't seem to change anything. Same goes for iwconfig wlan0 mode managed. Issuing iwconfig again doesn't show that anything on wlan0 has changed. Another thing that I also noticed is that iwpriv returns

wlan0 no private ioctls.

So, the issue that I have is that the device seems to be detected correctly, but I'm not able to correctly configure it to connect to a network.

Can anyone please help me with this?

Thank you in advance.

IvD

03-09-2011 09:12:21

Support for non-rt2x00 drivers is not given here, you need to find support on the Ralink website.