MAC problem with rt2800 in master mode

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=6184

peak

16-10-2011 00:03:48

I had been using my ralink usb in master mode using hostapd for a while, until it stopped working. Now clients can connect to the access point, but they cannot communicate. First DHCP is not working, although I can see DHCP requests coming to the server, but server is not sending any response. The same goes for ARP requests, the server is not responding any ARP request.

Here you can see that the box cannot find out the MAC address of 192.168.64.4 even when it is receiving packets from that machine

[code1nnfpe9r]root@efika:~# ip addr show dev wlan0
19: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
link/ether 74:f0:6d:49:cb:1c brd ff:ff:ff:ff:ff:ff
inet 192.168.64.1/24 brd 192.168.64.255 scope global wlan0
inet6 fe80::76f0:6dff:fe49:cb1c/64 scope link
valid_lft forever preferred_lft forever
root@efika:~# tcpdump -n -e -i wlan0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlan0, link-type EN10MB (Ethernet), capture size 65535 bytes
01:34:27.550369 4c:ed:de:60:3e:42 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: Request who-has 192.168.64.1 tell 192.168.64.4, length 28
01:34:27.550593 4c:ed:de:60:3e:42 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: Request who-has 192.168.64.1 tell 192.168.64.4, length 28
^C
2 packets captured
2 packets received by filter
0 packets dropped by kernel
root@efika:~# arp -na
? (192.168.64.4) at <incomplete> on wlan0
? (192.168.3.1) at 00:1a:80:d3:6d:d7 [ether] on eth0 [/code1nnfpe9r]


Any ideas of what is happening?

device(on an efika MX smarttop)
13d33273 IMC Networks 802.11 n/g/b Wireless LAN USB Mini-Card

compat-wireless version compat-wireless-3.1-rc8-1
kernel version
[code1nnfpe9r]root@efika:/usr/src/drivers# uname -a
Linux efika 2.6.31.14.24-efikamx #2 PREEMPT Fri Jul 22 11:43:26 CDT 2011 armv7l GNU/Linux[/code1nnfpe9r]