Rt61 pings & dhcp fail, however i can scan and connect

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=3898

Gruelius

27-05-2007 04:10:14

Hey all,
Ive got a Dlink GWL630 (Ref F1) which uses the RT61 module. Ive installed the latest cvs as of two nights ago and i have gentoo linux setup with the 2.6.20 kernel.

Im a bit of a newb to linux and this problem has me stumped. Using iwconfig i can see wlan0, and iwlist wlan0 scan, can see the AP within my house.

I then proceed to type
iwconfig essid Roschach
iwconfig key s0422xxxxxx open

then if i try dhcpcd wlan0 it times out, and setting everything with ifconfig doesnt help because i cant ping. Another wierd thing is that the activity lights remain blank however sometimes they flash according to activity. This does not concern me because when i was very lucky a few bootups ago it was connecting and pinging with no activity lights.

If someone could give me a few pointers as to where i should look to fixing this problem that would be great.

Cheers
Julius
**Edit**
I also got a kernel bug thing fill up my CLI screen before, it was talking about SMP or something.

thelinuxportal

27-05-2007 05:58:12

What does the iwconfig command bring up.

Gruelius

27-05-2007 08:10:00

iwconfig lists wan0 as RT61 Wireless and has all the correct settings for my home network.

Two things confuse me tho, it tells me i have a signal level of -60dmb and a noise level of -111dbm, im just thinking they should be posotive? p

Gruelius

27-05-2007 08:33:53

Another piece of info that might be helpful is that in my /var/log/messages ,after stating dhcpcd is broadcasting for a lease it says no ipv6 routers present. Should i be forcing dhcp to look for ipv4 routers? or is that part of iwconfig?

Zi7

27-05-2007 10:33:54

Should i be forcing dhcp to look for ipv4 routers? or is that part of iwconfig?[/quote3te8zpu3]
I don't know actually, but it seems to be something worth looking into...

Zi7

27-05-2007 10:37:30

iwconfig lists wan0 as RT61 Wireless and has all the correct settings for my home network.[/quote34mdk2rh]
But iwconfig also states whether you're associated with an AP or not. That's the interesting bit here.

Two things confuse me tho, it tells me i have a signal level of -60dmb and a noise level of -111dbm, im just thinking they should be posotive? p[/quote34mdk2rh]
Don't worry about that.

nixnoob

06-07-2007 20:05:53

Yes, I too have this problem, DHCP simply doesn't work at all, it times out and says No DHCP Offers Received. It then tries the old lease which I had fed to it manually using
sudo ifconfig wlan0 192.168.0.104 netmask 255.255.255.0
route default gw 192.168.0.1

After that all is well.

So in short DHCP = not working with RT61 and Ubuntu Feisty... btw I've tried this on the stock kernel as well as my custom kernel without SMP.

Linux geoff-laptop 2.6.22-rc7-custom #1 Fri Jul 6 111258 EDT 2007 i686 GNU/Linux

filename /lib/modules/2.6.22-rc7-custom/extra/rt61.ko
license GPL
description Ralink RT61 802.11abg WLAN Driver 1.1.0 CVS 2007070522
author http//rt2x00.serialmonkey.com
srcversion BAA45D5F5D46C7FAAF572DC
alias pciv00001814d00000401sv*sd*bc*sc*i*
alias pciv00001814d00000302sv*sd*bc*sc*i*
alias pciv00001814d00000301sv*sd*bc*sc*i*
depends
vermagic 2.6.22-rc7-custom mod_unload 586
parm debugEnable level accepted values 1 to switch debug on, 0 to switch debug off. (int)
parm ifnameNetwork device name (default wlan%d) (charp)

Vern

07-07-2007 18:32:07

Please keep the same problem in the same thread.

Vern

09-07-2007 16:12:03

then if i try dhcpcd wlan0 it times out,[/quote24c57yi8]
Just a swag here, but what do you have in /etc/dhcpc/config? There should be something (I think) like

case ${INTERFACE} in
eth1|wlan0)

This thing recently underwent a name change and there may be loose ends hanging around.

owczi

18-07-2007 18:50:53

I am facing a similar problem. With the latest rt61-cvs this is what happens

An unencrypted connection with my AP works OK, dhcp and all, but when using WEP or WPA-PSK, the card is able to associate but won't communicate with the AP - simply no transmitted packets, though it receives beacons and stuff as normal and stays in associated state, it doesn't transmit (the activity LED won't blink at all when using dhcpcd, or when I set a static IP and try to ping something.

Also, when I insert the card or load the module, activity/link LEDs work as they should, but after the link goes down even once, the LEDs stop working - the card works as it did - I can use the network (or not - as stated above) - but the lights are dim. The lights start working again when the card initializes ( when I rmmod/insmod the module, or reinsert the card).

I am using a 2.6.20 (preempt) kernel on a PowerBook (ppc arch) machine. I built the module with debugging code and I'm going to take a close look at /var/log/kernel, but for now I am quite lost and clueless.

ideas, anyone? ]


[bl1me03l9]EDIT I'm sorry for this messy post, actually all I should report is the LEDs not working - the problem with encryption was actually a problem with my AP (Linux-based AP, Coova firmware).[/bl1me03l9][/colorl1me03l9]

dburton

22-08-2007 20:33:36

I seem to have pretty much the same problem with the Edimax EW-7128ig card on Debian. I compiled from the CVS source yesterday and tried both the 2.6.18 and 2.6.22 kernels from Debian. I get scan results and can associate with my access point, but pinging and DHCP don't work. Setting my IP address and gateway manually does not seem to work either (there is no connectivity). I haven't looked closely at the LED's.

I also compiled the rt2x00-source package from Debian (stable), and got the same result. I tried the open source driver from Ralink with the same result. I tried the Beta release of the rt61 legacy driver, and that had the same behavior as well. Apparently all these versions of the driver have the same problem. For now, I would just like to get the legacy driver working, because that will allow me to stick with Debian stable.

Spy84464

23-08-2007 11:39:14

Hello,
Are you sure it's not a configuration problem? I had my rt61 card working well with debian etch.
How did you configure your card? What is the encryption scheme used on your network?

Regards,
Romain

dburton

23-08-2007 18:56:40

I turned off encryption and made my access point open just to check for connectivity. Normally, I use a 128-bit WEP key. I couldn't connect either way.

Initially, I did things like this

$ ifconfig wlan0 up
$ iwlist wlan0 scan
(This shows me my access point.)
$ iwconfig wlan0 essid Burton
$ iwconfig wlan0 key sxxxxxx
$ dhclient wlan0

I also tried this

$ iwconfig wlan0 ap [address of my access point]

And then I repeated all the other steps after "iwlist".

Instead of dhclient, I tried setting the address with ifconfig, but I still couldn't ping the IP address of my router.

I also tried configuring things in /etc/network/interfaces with the wireless-* parameters set. This didn't work either.

"iwconfig wlan0" shows my key, my essid, and the access point I am associated with. I can post the actual screenshots later if necessary, but I'm not on that machine right now.

Spy84464

24-08-2007 08:16:14

If it doesn't work without encryption, there's a deeper problem. Please post a debug trace as explained in the TESTING file coming with the driver.

dburton

04-09-2007 04:08:51

Here is the output when I install the module

mothra/usr/local/src/modules/rt61-cvs-2007082117/Module# insmod rt61.ko debug=31
rt61 1.1.0 CVS 2007082117 http//rt2x00.serialmonkey.com
PCI Enabling device 00000109.0 (0000 -> 0002)
ACPI PCI Interrupt 00000109.0[A] -> Link [APC4] -> GSI 19 (level, high) -> IRQ 177
RT61 RfIcType= 4

(The same information appears in the system log.)

Here is the output of "iwlist wlan0 scan"

mothra/usr/local/src/modules/rt61-cvs-2007082117/Module# iwlist wlan0 scan
wlan0 Scan completed
Cell 01 - Address 001195775144
ESSID"Burton"
ModeManaged
Channel11
Encryption keyon
Bit Rates0 kb/s
Quality0/100 Signal level-78 dBm Noise level-256 dBm
Cell 02 - Address 00149577C739
ESSID"2WIRE333"
ModeManaged
Channel6
Encryption keyon
Bit Rates0 kb/s
Quality0/100 Signal level-80 dBm Noise level-256 dBm

This appears in the system log

Aug 26 123341 localhost kernel wlan0 no IPv6 routers present

The following commands do not produce any additional output

iwconfig essid Burton
iwconfig ap 001195775144
iwconfig key sxxxxxxxxxxx

Here is the system log output from running "dhclient wlan0"

Aug 26 122356 localhost dhclient Internet Software Consortium DHCP Client 2.0pl5
Aug 26 122356 localhost dhclient Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
Aug 26 122356 localhost dhclient All rights reserved.
Aug 26 122356 localhost dhclient
Aug 26 122356 localhost dhclient Please contribute if you find this software useful.
Aug 26 122356 localhost dhclient For info, please visit http//www.isc.org/dhcp-contrib.html
Aug 26 122356 localhost dhclient
Aug 26 122356 localhost dhclient sit0 unknown hardware address type 776
Aug 26 122358 localhost dhclient sit0 unknown hardware address type 776
Aug 26 122358 localhost dhclient Listening on LPF/wlan0/000e2e86d88c
Aug 26 122358 localhost dhclient Sending on LPF/wlan0/000e2e86d88c
Aug 26 122358 localhost dhclient Sending on Socket/fallback/fallback-net
Aug 26 122358 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Aug 26 122404 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Aug 26 122410 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
Aug 26 122417 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
Aug 26 122429 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
Aug 26 122437 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
Aug 26 122446 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
Aug 26 122456 localhost dhclient DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
Aug 26 122457 localhost dhclient No DHCPOFFERS received.
Aug 26 122457 localhost dhclient No working leases in persistent database.
Aug 26 122457 localhost dhclient Sleeping.

Here is the output of "iwconfig wlan0" (afterward)

wlan0 RT61 Wireless ESSID"Burton"
ModeManaged Frequency2.412 GHz Bit Rate=54 Mb/s
RTS throff Fragment throff
Encryption keyxxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xx
Link Quality=0/100 Signal level-81 dBm Noise level-63 dBm
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0

uname -a reports the following

Linux mothra 2.6.18-5-k7 #1 SMP Fri Jun 1 012637 UTC 2007 i686 GNU/Linux

I'm not seeing a whole lot of output in the logs, even with debug set to 31. This is all I have.

hennichodernich

04-09-2007 09:33:28

I'm not seeing a whole lot of output in the logs, even with debug set to 31.[/quote29f98108]

But you did compile the module with debug info enabled, didn't you?

regards
Henning

dburton

05-09-2007 19:32:21

Whoops.... I don't know if I compiled with debug enabled. What do I have to do to make sure?

Spy84464

06-09-2007 11:22:43

Recompiling it again ("make debug") would be the easiest way I guess. Just make sure the previous module is overwritten by the new one, and properly inserted. So
Remove current rt61 module from the kernel, delete it, recompile with debug enabled, insert the new module. Though not very subtle, that should give you piece of mind )

dburton

10-09-2007 15:36:11

Uh oh... with the newest stable Debian kernel, the module doesn't even load now. This is what happens

mothra/usr/local/src/modules/rt61-cvs-2007091009/Module# insmod rt61.ko
insmod error inserting 'rt61.ko' -1 Unknown symbol in module

"uname -a" now returns the following

Linux mothra 2.6.18-5-k7 #1 SMP Thu Aug 30 025231 UTC 2007 i686 GNU/Linux

Spy84464

12-09-2007 18:00:25

If you have upgraded your kernel, you'll need to recompile the module using the _new_ kernel sources, so make sure they are installed.

hennichodernich

13-09-2007 06:25:43

mothra/usr/local/src/modules/rt61-cvs-2007091009/Module# insmod rt61.ko
insmod error inserting 'rt61.ko' -1 Unknown symbol in module
[/quote1ydm2fqi]

The module has depencies that insmod isn't able to resolve (modprobe is, if there is depmod information available).

Could anyone please have a look at his or her output of lsmod, which modules list rt61 as being used by? I'm not able to check it on this computer.

regards
Henning

blade106

18-09-2007 08:41:04

Hi all,

I've got a similar problem, on a Debian Etch too. I've got two boxes with kernel 2.6.18-4-686 on both.

One is going really well, using the Ralink driver, so everything's fine for this one. But the other one, everything's wrong
- neither Ralink or Rt2x00 is working good
- seems to work really slow (so much so that DHCP goes wrong as it don't receive the answer within the defined timeout)
- when DHCP runs okay, then traffic is really slow (even on the local network)

Here's a ping
yvan@blade~$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1 icmp_seq=1 ttl=64 time=26.2 ms
64 bytes from 192.168.0.1 icmp_seq=2 ttl=64 time=18.1 ms
64 bytes from 192.168.0.1 icmp_seq=3 ttl=64 time=50.6 ms
64 bytes from 192.168.0.1 icmp_seq=4 ttl=64 time=48.5 ms
64 bytes from 192.168.0.1 icmp_seq=5 ttl=64 time=6.26 ms
64 bytes from 192.168.0.1 icmp_seq=6 ttl=64 time=18.3 ms
64 bytes from 192.168.0.1 icmp_seq=7 ttl=64 time=17.6 ms
64 bytes from 192.168.0.1 icmp_seq=8 ttl=64 time=217 ms
64 bytes from 192.168.0.1 icmp_seq=9 ttl=64 time=11.9 ms
64 bytes from 192.168.0.1 icmp_seq=10 ttl=64 time=1261 ms
64 bytes from 192.168.0.1 icmp_seq=11 ttl=64 time=441 ms
64 bytes from 192.168.0.1 icmp_seq=12 ttl=64 time=38.8 ms
64 bytes from 192.168.0.1 icmp_seq=13 ttl=64 time=63.5 ms
64 bytes from 192.168.0.1 icmp_seq=14 ttl=64 time=7.39 ms
64 bytes from 192.168.0.1 icmp_seq=15 ttl=64 time=72.0 ms
64 bytes from 192.168.0.1 icmp_seq=16 ttl=64 time=57.5 ms
64 bytes from 192.168.0.1 icmp_seq=17 ttl=64 time=12.1 ms

Every other box pinging the router does it within 2ms, even this same box with another card (atheros based).

Compiling Ralink was full of errors, compiling rt2x00 was clean, but results are the sames.

I'll try to post some data if I recompile it in debug mode, I don't know what to give you in fact. /var/log/messages or syslog don't give anything useful.

blade106

18-09-2007 11:58:34

I tried compiling with «make debug» but nothing showed up (neither in the logs nor in the console).

The card is a Dlink DWL-G510 with ralink chip.

I tried to reboot on my other card (I switch the card, only one was used at the time), and my Linux hanged at start-up (it's a Dlink DWL-G520 with Atheros chip). I don't know why, and I couldn't boot on this one...

So I put back the Ralink one, and don't ask me why, but it seems really stable (before that the bitrate was changing everytime) and no problem with pinging (or some packets lost, I think that's okay now the ping time is about 1ms).

Really weird... I just reinstalled ath_pci module, recompiled in debug mode rt2x00 module (but it wasn't running okay since the reboot), had the hang at start-up with the G520 card.

Any clue? I really hope this will last forever (quality link is 98/100 now, was ranging from 30 to 70/100 with rt2x00, and was up to 30/100 with G520, and my box/router haven't moved a bit during the tests...)

Best regards,
Yvan.

Vern

18-09-2007 16:09:55

You may have inadvertently cleaned the contacts by removing and reseating the board.

blade106

18-09-2007 16:13:53

That may be a reason, yes -) Also it's strange that's the card is barely working. I mean for example a graphic card doesn't work at all in such a case. Anyway, that's working, I'll see tomorrow if it's still working -)

Thanks for the clue!

Starcrasher

19-09-2007 09:04:42

Or you may have moved your card to another pci slot and irq are not shared anymore or not with the same device.

blade106

19-09-2007 10:38:15

Was the same slot, but yes, that could be a reason too. Today it's working real fine -)

Also we tested some cards (as said above), and results are really weird
- DWL-G520 with madwifi driver, 108Mbps, best signal quality was 40/100 (~30/100 mean)
- DWL-G510 with rt2x00 driver, 54Mbps, best signal quality was 99/100 (~80/100 mean)

How can it be that the best card is really receiving so bad? Same box, same router, same distance... I know this can be driver-related, but it's really strange isn't it?

sbrunthaler

23-09-2007 11:43:17

Hi,

I found that with SuSE 10.0 on an ACER notebook with a rt61 PCMCIA card, I have to issue the [b1ls6ojrj]iwconfig ra0 key <hexstring>[/b1ls6ojrj] command manually to make the card work after inserting it.

The setting in the /etc/sysconfig/network/ifcfg-wlan-id-<mac> file alone does not seem to be sufficient although I copy-pasted the key from it.

Regards,
Stefan

PS driver version rt61-1.1.0-b2

hestef

24-09-2007 12:18:59

Hi!

I have a similiar problem. DHCP is not working, if i try to bring up the interface at bootup. It seems that the driver doesn't take the key. If i do an "iwpriv wlan0 set WPAPSK=mykey" at command line and then run dhclient manually, everything works fine.

If I configure my card static in /etc/network/interfaces everything works correct, too.

The Card is a Conceptronic C54RC Version 2.0, the Router is a Speedport W700V, I am using rt61 1.1.0 CVS 2007092304 on Debian unstable, 2.6.18-4-686 kernel. (I tried 2.6.22-2-686 also, but same problem)

I appreciate every advice to solve the problem.

Greets!

hennichodernich

24-09-2007 13:45:05


I found that with SuSE 10.0 on an ACER notebook with a rt61 PCMCIA card, I have to issue the [b3akiz13e]iwconfig ra0 key <hexstring>[/b3akiz13e] command manually to make the card work after inserting it.

The setting in the /etc/sysconfig/network/ifcfg-wlan-id-<mac> file alone does not seem to be sufficient although I copy-pasted the key from it.
[/quote3akiz13e]

Sure, since the ifup-wireless is unable to deal with the iwpriv mechanism required for the legacy drivers, it can only use wpa_supplicant for WPA. I wrote a patch for openSUSE 10.2's ifup-wireless to fix this [url3akiz13e]http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?p=23449#23449[/url3akiz13e]

regards
Henning

flabbergasted

14-11-2007 01:54:03

As the original post in this thread I have made numerous attempts to configure driver from the hourly cvs. I am using the openSuse 10.3 distro and I patched the ifup-wireless script found in /etc/sysconfig/network/scripts so it would not attempt to use the wpa-supplicant script as advised by hennichodernich in the previous post. That patch seems to have worked as I am no longer getting a message about wpa-supplicant not being compatible in my log when bringing up wlan0.

I am currently using

[code1icd5cs4]uname -a
Linux mainland 2.6.22.12-0.1-default #1 SMP 2007/11/06 23:05:18 UTC x86_64 x86_64 x86_64 GNU/Linux[/code1icd5cs4]

The pertinant line from #lspci showing that I should be using the rt61 driver.
[code1icd5cs4]
03:08.0 Network controller: RaLink RT2561/RT61 802.11g PCI
[/code1icd5cs4]

The results of running
[code1icd5cs4]
# make
make[1]: Entering directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
make -C ../../../linux-2.6.22.12-0.1 O=../linux-2.6.22.12-0.1-obj/x86_64/default modules
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_main.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/mlme.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/connect.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/sync.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/assoc.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/auth.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/auth_rsp.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_data.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_init.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/sanity.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_wep.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/wpa.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/md5.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_tkip.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/eeprom.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt2x00debug.o
LD [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.mod.o
LD [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.ko
make[1]: Leaving directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
*** Module rt61.ko built successfully
[/code1icd5cs4]

The result of running
[code1icd5cs4]
# make install
*** Install module in /lib/modules/2.6.22.12-0.1-default/extra ...
make[1]: Entering directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
make -C ../../../linux-2.6.22.12-0.1 O=../linux-2.6.22.12-0.1-obj/x86_64/default modules_install
INSTALL /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.ko
DEPMOD 2.6.22.12-0.1-default
make[1]: Leaving directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
/sbin/depmod -a
*** Update /etc/modprobe.conf alias for wlan*
*** Install firmware in /lib/firmware ...
*** Check old config ...
[/code1icd5cs4]

The results of running
[code1icd5cs4]
# make debug
make[1]: Entering directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
make -C ../../../linux-2.6.22.12-0.1 O=../linux-2.6.22.12-0.1-obj/x86_64/default modules
make[4]: Warning: File `/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt_config.h' has modification time 2.3e+03 s in the future
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_main.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/mlme.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/connect.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/sync.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/assoc.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/auth.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/auth_rsp.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_data.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_init.o
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_init.c: In function ‘NICLoadFirmware’:
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_init.c:1529: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘size_t’
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/sanity.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_wep.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/wpa.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/md5.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_tkip.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.o
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c: In function ‘RTMPIoctlBBP’:
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c:5425: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘size_t’
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c:5435: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘size_t’
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c: In function ‘RTMPIoctlMAC’:
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c:5509: warning: format ‘%d’ expects type ‘int’, but argument 3 has type ‘size_t’
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c:5552: warning: format ‘%d’ expects type ‘int’, but argument 3 has type ‘size_t’
/home/michael/Download/drivers/rt61-cvs-2007111310/Module/rtmp_info.c:5650: warning: format ‘%d’ expects type ‘int’, but argument 2 has type ‘size_t’
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/eeprom.o
CC [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt2x00debug.o
LD [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.o
make[4]: warning: Clock skew detected. Your build may be incomplete.
Building modules, stage 2.
MODPOST 1 modules
CC /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.mod.o
LD [M] /home/michael/Download/drivers/rt61-cvs-2007111310/Module/rt61.ko
make[1]: Leaving directory `/usr/src/linux-2.6.22.12-0.1-obj/x86_64/default'
*** Module rt61.ko built successfully
[/code1icd5cs4]
Then the info on the module
[code1icd5cs4]
#modinfo rt61
filename: /lib/modules/2.6.22.12-0.1-default/extra/rt61.ko
license: GPL
description: Ralink RT61 802.11abg WLAN Driver 1.1.0 CVS 2007111310
author: http://rt2x00.serialmonkey.com
srcversion: 5EC8DC5C524BA1F2258C9CA
alias: pci:v00001814d00000401sv*sd*bc*sc*i*
alias: pci:v00001814d00000302sv*sd*bc*sc*i*
alias: pci:v00001814d00000301sv*sd*bc*sc*i*
depends: firmware_class
vermagic: 2.6.22.12-0.1-default SMP mod_unload
parm: debug:Debug mask: n selects filter, 0 for none (int)
parm: ifname:Network device name (default wlan%d) (charp)
[/code1icd5cs4]

Before Configuration
[code1icd5cs4]
#iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:14:BF:36:61:E4
ESSID:"linksys_SES_29928"
Mode:Managed
Channel:6
Encryption key:on
Bit Rates:0 kb/s
Quality:0/100 Signal level:-38 dBm Noise level:0 dBm
[/code1icd5cs4]

After manual Configuration. Note link quality is 98%.

[code1icd5cs4]
iwconfig wlan0
wlan0 RT61 Wireless ESSID:"linksys_SES_29928" Nickname:""
Mode:Managed Frequency:2.437 GHz Bit Rate:54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=98/100 Signal level:-41 dBm Noise level:-111 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code1icd5cs4]

Since I did not have an assigned ip address I Configured with Yast for DHCP and restarted. The pertinant logs from messages.
[code1icd5cs4]
Nov 13 11:26:52 mainland avahi-daemon[3422]: Withdrawing address record for fe80::217:31ff:fec5:bf15 on eth0.
Nov 13 11:26:53 mainland ifprobe: eth0 changed config file: ifcfg-eth0 --> restart interface!
Nov 13 11:26:53 mainland ifdown: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a3)
Nov 13 11:26:54 mainland ifprobe: wlan0 changed config file: ifcfg-wlan0 --> restart interface!
Nov 13 11:26:54 mainland ifdown: wlan0 device: RaLink RT2561/RT61 802.11g PCI
Nov 13 11:26:54 mainland dhcpcd[8451]: terminating on signal 15
Nov 13 11:26:54 mainland avahi-daemon[3422]: Withdrawing address record for fe80::216:b6ff:fe5a:5e07 on wlan0.
Nov 13 11:26:54 mainland modify_resolvconf: removing info block from /etc/resolv.conf, because there is no backup left
Nov 13 11:26:54 mainland dhcpcd-hook: Skipping 'ifdown $INTERFACE -o dhcp' call
Nov 13 11:26:55 mainland ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a3)
Nov 13 11:26:55 mainland ifup: eth0 Startmode is 'manual'
Nov 13 11:26:55 mainland ifup: wlan0 device: RaLink RT2561/RT61 802.11g PCI
Nov 13 11:26:55 mainland ifup-dhcp: wlan0 (DHCP)
Nov 13 11:26:55 mainland ifup-dhcp: .
Nov 13 11:26:55 mainland ifup-dhcp: .
Nov 13 11:26:56 mainland avahi-daemon[3422]: Registering new address record for fe80::216:b6ff:fe5a:5e07 on wlan0.*.
Nov 13 11:26:57 mainland ifup-dhcp: .
Nov 13 11:27:01 mainland syslog-ng[2713]: last message repeated 2 times
Nov 13 11:27:01 mainland ifup-dhcp: no IP address yet... backgrounding.
Nov 13 11:27:01 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:27:01 mainland SuSEfirewall2: batch committing...
Nov 13 11:27:01 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:27:02 mainland SuSEfirewall2: batch committing...
Nov 13 11:27:02 mainland SuSEfirewall2: Firewall rules unloaded.
Nov 13 11:27:02 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:27:02 mainland SuSEfirewall2: batch committing...
Nov 13 11:27:02 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:27:04 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:27:04 mainland SuSEfirewall2: batch committing...
Nov 13 11:27:04 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:27:05 mainland kernel: wlan0: no IPv6 routers present
[/code1icd5cs4]

Of course since dhcp doesn't work I still do not have an IP address.
[code1icd5cs4]
# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:46 errors:0 dropped:0 overruns:0 frame:0
TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3422 (3.3 Kb) TX bytes:3422 (3.3 Kb)

wlan0 Link encap:Ethernet HWaddr 00:16:B6:5A:5E:07
inet6 addr: fe80::216:b6ff:fe5a:5e07/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1492 Metric:1
RX packets:9577 errors:0 dropped:0 overruns:0 frame:0
TX packets:2128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1179642 (1.1 Mb) TX bytes:0 (0.0 b)
Interrupt:16
[/code1icd5cs4]


An IP address was not assigned via dhcp from my Linksys WRT54GSV4 so I reConfigured with Yast for Static IP. The logs now show;
[code1icd5cs4]
Nov 13 11:36:05 mainland avahi-daemon[3422]: Withdrawing address record for fe80::217:31ff:fec5:bf15 on eth0.
Nov 13 11:36:07 mainland ifprobe: eth0 changed config file: ifcfg-eth0 --> restart interface!
Nov 13 11:36:07 mainland ifdown: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a3)
Nov 13 11:36:07 mainland ifprobe: wlan0 changed config file: ifcfg-wlan0 --> restart interface!
Nov 13 11:36:07 mainland ifdown: wlan0 device: RaLink RT2561/RT61 802.11g PCI
Nov 13 11:36:07 mainland dhcpcd[9984]: terminating on signal 15
Nov 13 11:36:07 mainland avahi-daemon[3422]: Withdrawing address record for fe80::216:b6ff:fe5a:5e07 on wlan0.
Nov 13 11:36:07 mainland dhcpcd-hook: Skipping 'ifdown $INTERFACE -o dhcp' call
Nov 13 11:36:08 mainland ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a3)
Nov 13 11:36:08 mainland ifup: eth0 Startmode is 'manual'
Nov 13 11:36:08 mainland ifup: wlan0 device: RaLink RT2561/RT61 802.11g PCI
Nov 13 11:36:08 mainland ifup: wlan0
Nov 13 11:36:08 mainland ifup: IP address: 192.168.1.106/24
Nov 13 11:36:08 mainland ifup:
Nov 13 11:36:08 mainland avahi-daemon[3422]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.106.
Nov 13 11:36:08 mainland avahi-daemon[3422]: New relevant interface wlan0.IPv4 for mDNS.
Nov 13 11:36:08 mainland avahi-daemon[3422]: Registering new address record for 192.168.1.106 on wlan0.IPv4.
Nov 13 11:36:09 mainland SuSEfirewall2: /var/lock/SuSEfirewall2.booting exists which means system boot in progress, exit.
Nov 13 11:36:09 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:36:09 mainland SuSEfirewall2: batch committing...
Nov 13 11:36:09 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:36:09 mainland avahi-daemon[3422]: Registering new address record for fe80::216:b6ff:fe5a:5e07 on wlan0.*.
Nov 13 11:36:13 mainland SuSEfirewall2: batch committing...
Nov 13 11:36:13 mainland SuSEfirewall2: Firewall rules unloaded.
Nov 13 11:36:13 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:36:13 mainland SuSEfirewall2: batch committing...
Nov 13 11:36:13 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:36:15 mainland SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Nov 13 11:36:15 mainland SuSEfirewall2: batch committing...
Nov 13 11:36:15 mainland SuSEfirewall2: Firewall rules successfully set
Nov 13 11:36:18 mainland kernel: wlan0: no IPv6 routers present
[/code1icd5cs4]
Now I have an IP address,
[code1icd5cs4]
#ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:46 errors:0 dropped:0 overruns:0 frame:0
TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3422 (3.3 Kb) TX bytes:3422 (3.3 Kb)

wlan0 Link encap:Ethernet HWaddr 00:16:B6:5A:5E:07
inet addr:192.168.1.106 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:b6ff:fe5a:5e07/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:9714 errors:0 dropped:0 overruns:0 frame:0
TX packets:2128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1188909 (1.1 Mb) TX bytes:0 (0.0 b)
Interrupt:16
[/code1icd5cs4]
I am showing in both cases packets received and transmitted but I can only ping the ip assigned to wlan0. I cannot ping the ap.
[code1icd5cs4]
#ping 192.168.1.106
PING 192.168.1.106 (192.168.1.106) 56(84) bytes of data.
64 bytes from 192.168.1.106: icmp_seq=1 ttl=64 time=0.094 ms
64 bytes from 192.168.1.106: icmp_seq=2 ttl=64 time=0.077 ms
64 bytes from 192.168.1.106: icmp_seq=3 ttl=64 time=0.078 ms
64 bytes from 192.168.1.106: icmp_seq=4 ttl=64 time=0.079 ms
64 bytes from 192.168.1.106: icmp_seq=5 ttl=64 time=0.084 ms
64 bytes from 192.168.1.106: icmp_seq=6 ttl=64 time=0.081 ms

--- 192.168.1.106 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5000ms
rtt min/avg/max/mdev = 0.077/0.082/0.094/0.007 ms

ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.106: icmp_seq=2 Destination Host Unreachable
From 192.168.1.106 icmp_seq=2 Destination Host Unreachable
From 192.168.1.106 icmp_seq=3 Destination Host Unreachable
From 192.168.1.106 icmp_seq=4 Destination Host Unreachable
From 192.168.1.106 icmp_seq=6 Destination Host Unreachable
From 192.168.1.106 icmp_seq=7 Destination Host Unreachable
From 192.168.1.106 icmp_seq=8 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
11 packets transmitted, 0 received, +7 errors, 100% packet loss, time 10002ms
, pipe 3
[/code1icd5cs4]

It does not appear that this thread has provided a resolution to the problem. If anyone has any guidance, I would greatly appreciate it. If there is any otehr information I can provide, let me know. I apologize for the length of this post, but I figured too much is better than not enough.

hestef

14-11-2007 08:27:28

Hey,

is Yast managing routes? What does a "route -n" say? I am using Debian, no Yast here...

Henrik

flabbergasted

14-11-2007 17:37:42

Henrik,

Yes, yast manages the gateway. I downloaded a newer version of the driver this morning and now am getting a different result in the messages log.

The results of route -n with each of the interfaces brought up seprately are
[code2eo3li2l]route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0[/code2eo3li2l]

and

[code2eo3li2l]
route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0[/code2eo3li2l]

but with this new driver I am now getting

[code2eo3li2l]Nov 14 11:29:31 mainland syslog-ng[2691]: last message repeated 65 times
Nov 14 11:29:31 mainland kernel: rt61: rt61_get_stats --->
[/code2eo3li2l]

even when the wlan0 interface is down and the eht0 interface is up.

When I now try to bring up wlan0 messages shows;
[code2eo3li2l]ov 14 09:24:17 mainland kernel: rt61: MlmeHardTransmit
Nov 14 09:24:17 mainland kernel: rt61: WriteTxD: scatter #1 = 59 + 0 + 0 ... = 59
Nov 14 09:24:17 mainland kernel: MLMEHardTransmit use rate 1
Nov 14 09:24:17 mainland kernel: rt61: SYNC - send ProbeReq @ channel=8, Len=59
Nov 14 09:24:17 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 09:24:17 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 09:24:17 mainland kernel: rt61: RTMPHandleMgmtRingDmaDoneInterrupt...
Nov 14 09:24:17 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 09:24:17 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 09:24:17 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 09:24:17 mainland kernel: rt61: SYNC - Scan Timeout
Nov 14 09:24:17 mainland kernel: rt61: MlmeEnqueue, num=1
Nov 14 09:24:17 mainland kernel: rt61: ScanNextChannel(ch=9)
Nov 14 09:24:17 mainland kernel: rt61: AsicAntennaSelect(ch=9) - Tx=Ant-B, Rx=Ant-B
Nov 14 09:24:17 mainland kernel: rt61: AsicSwitchChannel(RF=3, Pwr=11) to #9, R1=0x95002ccc, R2=0x95004796, R3=0x95069655, R4=0x950c8a0b
Nov 14 09:24:17 mainland kernel: rt61: MlmeHardTransmit
Nov 14 09:24:17 mainland kernel: rt61: WriteTxD: scatter #1 = 59 + 0 + 0 ... = 59
Nov 14 09:24:17 mainland kernel: MLMEHardTransmit use rate 1
Nov 14 09:24:17 mainland kernel: rt61: SYNC - send ProbeReq @ channel=9, Len=59
Nov 14 09:24:17 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 09:24:17 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 09:24:17 mainland kernel: rt61: RTMPHandleMgmtRingDmaDoneInterrupt...
Nov 14 09:24:17 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 09:24:17 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 09:24:17 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 09:24:17 mainland kernel: rt61: SYNC - Scan Timeout
Nov 14 09:24:17 mainland kernel: rt61: MlmeEnqueue, num=1
Nov 14 09:24:17 mainland kernel: rt61: ScanNextChannel(ch=10)
Nov 14 09:24:17 mainland kernel: rt61: AsicAntennaSelect(ch=10) - Tx=Ant-B, Rx=Ant-B
Nov 14 09:24:17 mainland kernel: rt61: AsicSwitchChannel(RF=3, Pwr=11) to #10, R1=0x95002ccc, R2=0x95004796, R3=0x95069655, R4=0x950c8a1f[/code2eo3li2l]

It is doing this repeatedly.
BTW, the above log was generated after I deleted the configuration for wlan0 through yast and loaded this morning hourly and did a complete manual configuration according to the README. When I went into yast and configured wlan0 there for a static IP, the results are the same. I will download the newest version since it has been several hours. Thanks for your help.

Michael

flabbergasted

14-11-2007 19:50:46

Apparently the drivers versions from today broke what worked before. I went back to version rt61-cvs-2007111310 and deleted the wlan0 configuration through yast and completely configured the wlan0 manually. These are the steps that I took that enabled me to ping my router.

[code39fd8rgt]
make debug
make install
modprobe rt61 debug=31
ifconfig wlan0 up
iwlist wlan0 scan
ifconfig wlan0 down
iwconfig wlan0 mode managed
ifconfig wlan0 up
ifconfig wlan0 192.168.1.106
iwconfig wlan0 essid <ESSID>
iwpriv wlan0 set AuthMode=WPA2PSK
iwpriv wlan0 set WPAPSK=<KEY>
iwpriv wlan0 set EncrypType=AES
iwconfig wlan0[/code39fd8rgt]

After taking these steps I was able to ping my router and access the router through the browser. I was not able to go anywhere else because I did not have a gateway set. So I took the connection down and brought up eth0 to look up how to set the gateway by command. After taking down eth0 and taking wlan0 up again, I could no longer ping the router even after doing all of the above steps again with the exception of compiling and reloading the module. This is really getting frustrating.

This is bazaar. I clicked the preview button below and remembered that I had not changed my connection over to eth0. The page refreshed before I brought down wlan0. Could this be real?

I struck the enter key before I notice what had loaded in my browser window. Apparently I can't seem to get the encryption key to stick. The first time I went through the manual configuration the key was set properly.

[code39fd8rgt]
iwconfig wlan0
wlan0 RT61 Wireless ESSID:"linksys_SES_29928" Nickname:""
Mode:Managed Frequency:2.437 GHz Bit Rate:54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:8FD9-FAE4-3FC6-58B4-B92D-4E71-51EA-2D85
Link Quality=98/100 Signal level:-41 dBm Noise level:-111 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code39fd8rgt]

But apparently even though I went through all of the manual configuration again, it does not take.

[code39fd8rgt]
iwconfig wlan0 mode managed
ifconfig wlan0 up
iwconfig wlan0 essid linksys_SES_29928
iwpriv wlan0 set AuthMode=WPA2PSK
iwpriv wlan0 set WPAPSK=a69f43deb713c4d8
iwpriv wlan0 set EncrypType=AES
iwconfig wlan0
wlan0 RT61 Wireless ESSID:"linksys_SES_29928" Nickname:""
Mode:Managed Frequency:2.437 GHz Bit Rate:54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=100/100 Signal level:-37 dBm Noise level:-111 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code39fd8rgt]

This may have something to do with it. Seems to me that I should have to reconfigure the interface every time I bring i up. ?

flabbergasted

14-11-2007 20:06:18

OK, I removed the module again and redid everything with the exception of recompiling the module. I just came to this post through wlan0. It isn't very fast, but I am now getting the following in my messages log again. I only included the last portion starting at 140102 and went through a portion of 140103. This will give you an idea of what is being generated in a second.

I have made progress since, although VERY slow, I made this post through my wireless card. (Yes, I did unplug my ethernet cable just to be sure.)

[code4881z70c]
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cd
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cd
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cd
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cd
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cd
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: rt61_get_stats --->
Nov 14 14:01:02 mainland kernel: rt61: OneSecFalseCCACnt = 0
Nov 14 14:01:02 mainland kernel: rt61: strong RSSI=-52, CCA=0, fixed R17 at 0x40
Nov 14 14:01:02 mainland kernel: rt61: MMCHK - PortCfg.Ssid[17]=link... MlmeAux.Ssid[17]=link...
Nov 14 14:01:02 mainland kernel: rt61: MMCHK - CQI= 86 (Tx Fail=0/Retry=0/Total=0, Rx Fail=0/Total=10, RSSI=-53 dbm)
Nov 14 14:01:02 mainland kernel: 54: NDIS push BE=0, BK=0, VI=0, VO=0, TX/RX AGGR=<0,0>, p-NDIS=0, RSSI=-52, ACKbmap=15f, PER=0%
Nov 14 14:01:02 mainland kernel: rt61: AsicAdjustTxPower = 12, AvgRssi = -52
Nov 14 14:01:02 mainland kernel: rt61: STAMlmePeriodicExec - LastRssi=68, BbpRssiToDbmDelta=121
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:02 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:02 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:02 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:02 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:02 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:02 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:03 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:03 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:03 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:03 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:03 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:03 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:03 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:03 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:03 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:03 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:03 mainland kernel: rt61: MlmeDequeue, num=0
Nov 14 14:01:03 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:03 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:03 mainland kernel: rt61: ====> RTMPHandleInterrupt
Nov 14 14:01:03 mainland kernel: rt61: <==== RTMPHandleInterrupt (1 handled)
Nov 14 14:01:03 mainland kernel: rt61: MlmeEnqueueForRecv, num=1
Nov 14 14:01:03 mainland kernel: rt61: IE_RSN length = 24
Nov 14 14:01:03 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:03 mainland kernel: rt61: PeerBeaconAndProbeRspSanity - Receive IE_WPA
Nov 14 14:01:03 mainland kernel: rt61: SYNC - PeerBeacon from 00:14:bf:36:61:e4 - Dtim=0/1, Rssi=cb
Nov 14 14:01:03 mainland kernel: rt61: Rx My BEACON
Nov 14 14:01:03 mainland kernel: rt61: MlmeDequeue, num=0
[/code4881z70c]

flabbergasted

15-11-2007 00:12:22

OK, I am probably getting ahead of myself, since I was not able to maintain the connection I had from using a previous version of the daily and I was getting all that garbage (although useful information I am sure) I decided to download another. I have loaded rt61-cvs-2007111417 and am again posting through wlan0 although slow, but do not have all of that garbage seen in the previous post.

I do hope this info is helping someone. I will let you know if I am able to maintain this connection.

UPDATE I wasn't able to keep it up. But since the issue no longer fits this thread, I will be cruising another.

joban

16-11-2007 18:02:28

Hi flabbergasted,

deja vue!

I use an RT61 with openSuse10.3 since yesterday and seem to have exactly the same problem.
I have not done as much as you did (yet?), only used the module provided with the online updated newest suse kernel and copied the fw files from the ra web site to /lib/firmware.

I can see AP's and connect to one of mine with WEP/104bit ascii key (i just now learned about the proper sequence to use WPA/PSK. I'll try when I'm back at this notebook).

If I send iwconfig wlan0 key 'smyWepKeyHere' some time after starting the network via rcnetwork restart wlan0, and if I am lucky, i can use the wlan.
I double checked that the key shown by iwconfig wlan0 did NOT change by this command.

Just wanted to let you know.
I'll keep you posted if I can find out more.
What do you mean with cruising another thread?

Regards,

Joachim

joban

18-11-2007 11:42:25

Hi,

After much fiddling, I ended up using the RaLink driver.
Does not work out of the box but I could solve it. D

If you're interested, you can read about it in my wiki[/url2cpbzxin]

I'm still interested to make it work with the new driver(s), though! roll

HTH