Support for Master mode in rt61 drivers

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4203

dmohapatro

24-08-2007 02:16:07

hi,

This is my first post .
Can somebody help me in setting up the rt61 driver to set my AWLC5025 MIMO XR 802.11g Wireless Cardbus Adapter to master mode.

can any body send me the procedure for setting up the driver to work in master(AP) mode for the rt61 driver

Spy84464

24-08-2007 08:13:11

Hello,
This is impossible, the legacy rt61 driver doesn't support it. You have to use our new driver rt2x00. Master mode is unsupported by vanilla kernels at the moment, so rt2x00 CVS is no use for you, you'll have to grab a whole new kernel from git, see the instructions here [url3f6hszyr]http://rt2x00.serialmonkey.com/wiki/index.php?title=Rt2x00_GIT_instructions[/url3f6hszyr], rt2x00 comes with this kernel, keep in mind it is not considered stable yet.

Regards,
Romain

C00LM4N

27-08-2007 22:51:02

I still don't understand what I need to do to be able to set master mode. Could you describe all install process at greater length?
Gentoo Linux, kernel 2.6.19, D-Link DWL-G510 (rt61/rt2561).

IvD

28-08-2007 17:04:30

read the rt2x00 git instructions romain pointed out and download rt2x00.git
since you use Gentoo we can assume you know how to compile a kernel...

C00LM4N

30-08-2007 14:16:34

I were following GIT instructions at [url2ku4b1s6]http://rt2x00.serialmonkey.com/wiki/index.php?title=Rt2x00_GIT_instructions[/url2ku4b1s6] but I don't understand what I have to do after creating my branch... really...
And I should use any branch name, at will? Don't know what it means.

IvD

30-08-2007 16:01:38

You don't need a branch, you need to compile the kernel...

C00LM4N

30-08-2007 17:58:08

I've installed kernel. But if I compile drvers in kernel than it panics. Works correctly only as a module.

m00dawg

18-09-2007 02:08:40

So I was able to get things working and the card appears to be working correctly

filedawg bin # iwconfig
...
wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID"AirdawgExpress"
ModeMaster Frequency2.427 GHz Tx-Power=27 dBm
Retry min limit7 RTS throff Fragment thr=2346 B
Encryption key6539-786C-6231-38
Link Quality0 Signal level0 Noise level0
Rx invalid nwid0 Rx invalid crypt0 Rx invalid frag0
Tx excessive retries0 Invalid misc0 Missed beacon0
...

However, when I try to scan the networking using KisMAC or my iBook or try to join the network, it doesn't appear in the list. I have only gotten ad-hoc to sorta work.

I can't find any errors in 'dmesg' about this; is there anything I might be missing? I basically have the following in my /etc/conf.d/net (Gentoo)

essid_wlan0="test"
mode_wlan0="master"
channel_wlan0="4"
config_wlan0=( "192.168.3.1 netmask 255.255.255.0 brd 192.168.3.255" )

Any help would be appreciated! I am using the rt2x000 drivers with the RT61 chipset.

m00dawg

18-09-2007 02:22:26

I almost forgot! I am using the GIT kernel

Linux filedawg.moocow.home 2.6.23-rc4-g1dff65b1 #1 Mon Sep 17 083118 CDT 2007 i686 AMD Athlon(tm) processor AuthenticAMD GNU/Linux

And my previous snapshot mentioned a WEP key. I have tried it both ways and neither cause anything to come up using KisMAC or when trying to simply join the network regularly.

IvD

18-09-2007 17:27:01

Please compile rt2x00 with debug enabled.

Also you will need hostapd for master mode capabilities.

WatsonJX

22-12-2007 08:22:07

Hi there,

I am very interested to run rt61pci in master mode. Could you point me to some instruction or document on setting it up?

Thanks a lot!

Spy84464

22-12-2007 11:52:02

Hello,
None of our driver support this mode, it has been disabled because it's currently broken.

Regards,
Romain

moratm

05-02-2008 14:24:34

Hello Spy,
Do you mean that the new 2x00 driver doesn't support master mode ?

IvD

05-02-2008 17:09:39

Master mode is enabled in rt2x00, you will need Johannes Berg's patches for mac80211 to add support for master mode to mac80211.