[rt61] the driver sometimes freezes the system, ra0 or wlan0

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4462

elkanguro

26-11-2007 09:17:25

Hi,
I'm new in Linux so maybe it is my mistake but i don't think so. Sometimes, when I launch rt61 mod, my system freezes and only reboot can help me. I use CVS. I have rt61 normally blacklisted becouse when it isn't it often tells me when starting "Soft lockup detected on CPU#0".

The second strange thing is that, when i use modprobe rt61 my wireless interface is ra0 and when I type insmod rt61.ko the interface is wlan0.

In the end, or maybe on the beginning, when I type make, it makes rt61.ko sccessfully but with warning [code3gf6tbd3]kangur@kangur:~/linux_programy/rt61-cvs-2007112517/Module$ sudo make
Password:
make[1]: Wejście do katalogu `/usr/src/linux-headers-2.6.20-16-generic'
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_main.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/mlme.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/connect.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/sync.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/assoc.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/auth.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/auth_rsp.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_data.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_init.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/sanity.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_wep.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/wpa.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/md5.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_tkip.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rtmp_info.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/eeprom.o
CC [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rt2x00debug.o
LD [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rt61.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rt61.mod.o
LD [M] /home/kangur/linux_programy/rt61-cvs-2007112517/Module/rt61.ko
make[1]: Opuszczenie katalogu `/usr/src/linux-headers-2.6.20-16-generic'
!!! WARNING: Module file much too big (>1MB),
!!! Check your kernel settings or use 'strip'
*** Module rt61.ko built successfully
[/code3gf6tbd3] I don't know which settings to check and what is strip.

Please help me, and if you need more information just tell me and I will check it.

Spy84464

26-11-2007 23:36:20

Hello,
It looks like you have two versions of the driver installed an old one, from the time the interface was called ra0 (it could be Ralink's driver also), and a more recent one.
I suggest you delete all "rt61.ko" files from your system, and install again the latest CVS tarball.

Regards,
Romain