WPA Static IP Not Working, Gutsy

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4472

charleshand

28-11-2007 14:55:59

I have installed Mythbuntu 7.10, and I have the Edimax RT2561 card.

I have a WPA / WPA2 TKIP network with MAC Filtering. The card works fine when you connect with roaming, and also when you manually configure it with DHCP (although it doesn't start automatically on boot and you have to ifdown ifup).

I would like to configure the card manually and use static IP settings (as follows) and have it start up automatically on boot. Is there any way that I can do that? Do I need to install the new beta driver, and if so are there some instructions on how to do that in Gutsy?

"iface wlan0 inet static
address 192.168.7.50
netmask 255.255.255.0
gateway 192.168.7.1
wpa-psk blahblahblah
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid Homer

auto wlan0"

Any help would be hugely appreciated!

Charles

lol

Spy84464

01-12-2007 22:00:00

Hello,
I have never used wpa_supplicant with the legacy drivers, and don't know how it should be set up using /etc/network/interfaces. Perhaps you would have better luck using "iwpriv"
[code1oy6vnxz]post-up iwpriv wlan0 set AuthMode=WPAPSK
post-up iwpriv wlan0 set EncryptType=WPAPSK
post-up iwpriv wlan0 set WPAPSK='your_key'[/code1oy6vnxz]
DNS settings are also lacking in your file.

Regards,
Romain