[SOLVED] 2.6.24 compilation problem

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4622

dopey

19-02-2008 07:44:39

Hi everybody,

I have a problem compiling ralink driver RT2501PCI/mPCI/CB(RT61RT2561/RT2561S/RT2661) RT61.

Before, with kernel 2.6.23 it worked fine.

Now I get an error like that
[ifgxfszdl]"CFLAGS was changed Fix it to use EXTRA_CFLAGS. "[/ifgxfszdl]

So here are two questions

[bfgxfszdl]1) Do you know what is wrong ? It seems they changed something in the new 2.6.24 kernel and driver won't compile.[/bfgxfszdl] Even if I replace CFLASG by EXTRA_CFLAGS I get more errors.

[bfgxfszdl]2) I want to try your drivers for the RT61[/bfgxfszdl]
- Do they support wpa-psk/wpa2-psk ?
- I think firmware's paths is different ? And config file are not in /Etc/Wireless/.... ?
- I have a laptop, so pcmcia chipset ? Will it work (I see the word 'pci' in this forum ?)

Thanks for your help.

Spy84464

20-02-2008 18:22:14

Hello,

I have a problem compiling ralink driver RT2501PCI/mPCI/CB(RT61RT2561/RT2561S/RT2661) RT61.

Before, with kernel 2.6.23 it worked fine.

Now I get an error like that
[ijbqn0n4h]"CFLAGS was changed Fix it to use EXTRA_CFLAGS. "[/ijbqn0n4h][/quotejbqn0n4h]
We don't support Ralink's releases, so we can't help you here.

[bjbqn0n4h]1) Do you know what is wrong ? It seems they changed something in the new 2.6.24 kernel and driver won't compile.[/bjbqn0n4h] Even if I replace CFLASG by EXTRA_CFLAGS I get more errors.[/quotejbqn0n4h]
Not at all. ;)

[bjbqn0n4h]2) I want to try your drivers for the RT61[/bjbqn0n4h]
- Do they support wpa-psk/wpa2-psk ?[/quotejbqn0n4h]
Yes, it does. Our drivers (labelled) "legacy" are derived from Ralink's one, so they have, at least, the same features.

- I think firmware's paths is different ?[/quotejbqn0n4h]
The firmwares must be placed in "/lib/firmware", though that may be different on your distribution. And config file are not in /Etc/Wireless/.... ?[/quotejbqn0n4h]
We've get rid of that file, there's no need for it anymore.
- I have a laptop, so pcmcia chipset ? Will it work (I see the word 'pci' in this forum ?)[/quotejbqn0n4h]
No problem.

Regards,
Romain

dopey

22-02-2008 07:27:09

Thanks for your answer D

rt61 legacy driver compile perfectly and now I can load the module in my new shiny 2.6.24 and see my interface with iwconfig.

Now I just have to configure it (wpa2-psk AES) in /etc/network/interfaces.

I'll report if I have any stability issues.