connecting with WPA2 and AES on Ubuntu Gutsy

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4635

tr333

26-02-2008 15:07:57

Hi.

I seem to be having a bit of trouble connecting to my AP using WPA2 with AES (i assume that its a PSK, since the AP said "WPA2 Personal"). The SSID of the AP is set to be hidden in the AP preferences. I have set-up some configuration info in the file /etc/network/interfaces using the sample configs given in the iwpriv_usage.txt file included with the latest rt61 CVS source. When I restart the neworking with "sudo /etc/init.d/netwoking restart", it tries to scan both eth0 and wlan0 for DHCP and successfully gets an IP on eth0 but fails to find anything on wlan0. This is on kernel version 2.6.22-14 (ubuntu) Can someone please verify the configs that i'm using to connect on the wlan0 interface.

[code1d4kw7hz]
# /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 down
pre-up iwconfig wlan0 set mode managed
pre-up iwpriv wlan0 set AuthMode=WPA2PSK
pre-up iwpriv wlan0 set EncrypType=AES
pre-up iwconfig wlan0 essid "XXXXX"
pre-up iwpriv wlan0 set WPAPSK="XXX"
pre-up ifconfig wlan0 up
[/code1d4kw7hz]
The WPAPSK="XXX" line uses the output of the command "wpa_passphrase SSID Passphrase", where the "Passphrase" is the password listed in the AP preferences.

Spy84464

02-03-2008 16:51:21

Hello,
rt61 tends to work better when the settings are set while the interface is up, so try this version instead
[code2zndvp9m]auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up iwconfig wlan0 set mode managed
pre-up iwpriv wlan0 set AuthMode=WPA2PSK
pre-up iwpriv wlan0 set EncrypType=AES
pre-up iwconfig wlan0 essid "XXXXX"
pre-up iwpriv wlan0 set WPAPSK="XXX"[/code2zndvp9m]

Regards,
Romain